Home » Developer & Programmer » Application Express, ORDS & MOD_PLSQL » Error while executing EXEC DBMS_XDB.SETHTTPPORT (Oracle 10g , windows xp)
Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659231] Tue, 10 January 2017 03:23 Go to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
https://drive.google.com/file/d/0B7Sq5KuQDDduYjI3YWtwVkpodjQ/view?usp=sharingHi
I am try to run apex locally on my computer. I already do this for oracle 11 g. I am configuring the embedded PL/SQL gateway for this purpose. but when i trying to execute this command :

EXEC DBMS_XDB.SETHTTPPORT(8080);

results in :

ORA-00900: invalid SQL statement

I test this code

SELECT owner, object_name, object_type, created, TIMESTAMP, status
  FROM dba_objects
 WHERE object_name = 'DBMS_XDB';


results in :
https://drive.google.com/file/d/0B7Sq5KuQDDduYjI3YWtwVkpodjQ/view?usp=sharing

[Updated on: Tue, 10 January 2017 03:28]

Report message to a moderator

Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659233 is a reply to message #659231] Tue, 10 January 2017 03:36 Go to previous messageGo to next message
Littlefoot
Messages: 20958
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Where did you try to run
EXEC DBMS_XDB.SETHTTPPORT(8080);
Was it in SQL*Plus? TOAD? Something else?
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659235 is a reply to message #659233] Tue, 10 January 2017 04:04 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
Hi
Thanks for your reply
I test it in Oracle Mastero , The results is the same in Pl/SQL Developer .
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659236 is a reply to message #659235] Tue, 10 January 2017 04:11 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
Another point that when i run @apex_epg_config in sql plus , all of the commands that use dbms_xmldom.* result in error !
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659238 is a reply to message #659236] Tue, 10 January 2017 04:49 Go to previous messageGo to next message
Littlefoot
Messages: 20958
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
If it is not a problem, try to rewrite it to a standard PL/SQL block:
begin
  DBMS_XDB.SETHTTPPORT(8080);
end;
/
and/or run it in SQL*Plus.

What happens in both cases?
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659239 is a reply to message #659238] Tue, 10 January 2017 05:04 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
Hi

when running this Code In Oracle mastero or PL/SQL Developer the Results is :

ORA-06550: line 2, column 12:
PLS-00302: component 'SETHTTPPORT' must be declared
ORA-06550: line 2, column 3:
PL/SQL: Statement ignored


When running in sqlplus(After connect to it)

begin
dbms_xdb.sethttpport(8080) ;
end ; 

the same results showed .
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659240 is a reply to message #659239] Tue, 10 January 2017 05:10 Go to previous messageGo to next message
Littlefoot
Messages: 20958
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Cool. What happens when you run this query:
select count(*)
from all_objects
where object_type = 'PACKAGE'
  and object_name like 'DBMS_XDB%';
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659241 is a reply to message #659240] Tue, 10 January 2017 06:06 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
Littlefoot wrote on Tue, 10 January 2017 14:10
Cool. What happens when you run this query:
select count(*)
from all_objects
where object_type = 'PACKAGE'
  and object_name like 'DBMS_XDB%';
Thanks for your reply

The results is :

4
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659242 is a reply to message #659241] Tue, 10 January 2017 06:12 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
And the object name are : 1-DBMS_XDBZ 2-DMMS_XDB 3-DBMS_XDBZO 4-DBMS_XDBUTIL_INT . maybe usefull for you !
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659244 is a reply to message #659242] Tue, 10 January 2017 06:58 Go to previous messageGo to next message
Littlefoot
Messages: 20958
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
How did you connect to the database (which user)? If it wasn't SYS, try to connect as SYS and then run
begin
  DBMS_XDB.SETHTTPPORT(8080);
end;
/
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659245 is a reply to message #659244] Tue, 10 January 2017 07:26 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
I Connected with sys user as sysdba .
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659247 is a reply to message #659245] Tue, 10 January 2017 07:31 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
I see tablespace with the name XDB but in the users not see XDB user !
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659252 is a reply to message #659247] Tue, 10 January 2017 09:44 Go to previous messageGo to next message
John Watson
Messages: 6667
Registered: January 2010
Location: Global Village
Senior Member
Are you sure that th XDB component is actually installed and valid? In my database it is:
orclz> select COMP_ID,VERSION,STATUS from dba_registry order by 1;

COMP_ID                        VERSION                        STATUS
------------------------------ ------------------------------ --------------------------------------------
APEX                           4.2.5.00.08                    VALID
APS                            12.1.0.2.0                     VALID
CATALOG                        12.1.0.2.0                     VALID
CATJAVA                        12.1.0.2.0                     VALID
CATPROC                        12.1.0.2.0                     VALID
CONTEXT                        12.1.0.2.0                     VALID
DV                             12.1.0.2.0                     VALID
JAVAVM                         12.1.0.2.0                     VALID
OLS                            12.1.0.2.0                     VALID
ORDIM                          12.1.0.2.0                     VALID
OWM                            12.1.0.2.0                     VALID
RAC                            12.1.0.2.0                     OPTION OFF
SDO                            12.1.0.2.0                     VALID
XDB                            12.1.0.2.0                     VALID
XML                            12.1.0.2.0                     VALID
XOQ                            12.1.0.2.0                     VALID

16 rows selected.

orclz>
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659257 is a reply to message #659252] Tue, 10 January 2017 11:01 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
Hi

The Same results accure for me .
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659264 is a reply to message #659257] Tue, 10 January 2017 13:57 Go to previous messageGo to next message
Michel Cadot
Messages: 64269
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Surely not as you said you are in 10g and John is on 12c.
So use SQL*Plus and copy and paste the actual result.
Also post the result of
select * from v$version;

Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659276 is a reply to message #659264] Wed, 11 January 2017 04:36 Go to previous messageGo to next message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
Hi
Thank for your reply

Results :
BANNER                                                          
Oracle Database 10g Enterprise Edition Release 10.1.0.2.0 - Prod
PL/SQL Release 10.1.0.2.0 - Production                          
CORE	10.1.0.2.0	Production                                      
TNS for 32-bit Windows: Version 10.1.0.2.0 - Production         
NLSRTL Version 10.1.0.2.0 - Production 
Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659277 is a reply to message #659276] Wed, 11 January 2017 04:42 Go to previous messageGo to next message
Michel Cadot
Messages: 64269
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

So now post the result of John's query as it is.

Re: Error while executing EXEC DBMS_XDB.SETHTTPPORT [message #659278 is a reply to message #659277] Wed, 11 January 2017 05:02 Go to previous message
Rasoul_57
Messages: 20
Registered: October 2012
Location: Iraq
Junior Member
COMP_ID                        VERSION                        STATUS     
AMD                            10.1.0.2.0                     VALID      
APEX                           3.2.1.00.12                    VALID     
APS                            10.1.0.2.0                     VALID      
CATALOG                        10.1.0.2.0                     VALID      
CATJAVA                        10.1.0.2.0                     VALID      
CATPROC                        10.1.0.2.0                     VALID      
CONTEXT                        10.1.0.2.0                     VALID      
EM                             10.1.0.2.0                     VALID      
EXF                            10.1.0.2.0                     VALID      
JAVAVM                         10.1.0.2.0                     VALID      
ODM                            10.1.0.2.0                     VALID      
ORDIM                          10.1.0.2.0                     VALID      
OWM                            10.1.0.2.0                     VALID      
SDO                            10.1.0.2.0                     VALID      
XDB                            10.1.0.2.0                     VALID      
XML                            10.1.0.2.0                     VALID      
XOQ                            10.1.0.2.0                     VALID      

Previous Topic: Hide schema name,username and password from url
Next Topic: oops internet explorer could not connect to app_server:7778
Goto Forum:
  


Current Time: Mon Jan 16 11:53:55 CST 2017

Total time taken to generate the page: 0.11159 seconds