Home » Developer & Programmer » Forms » Debug Form
Debug Form [message #659026] Wed, 04 January 2017 10:02 Go to next message
shawaj
Messages: 32
Registered: January 2016
Member
hi
i have installed oracle forms 11g but unable to debug form in forms builder .Please guide me ?

Configuration Options
Middleware Home Location: C:\Oracle\Middleware
Oracle Home Location: C:\Oracle\Middleware\as_1
Oracle Instance Location: C:\Oracle\Middleware\asinst_1
Oracle Instance: asinst_1
Domain Option: Create Domain
Domain Name: ClassicDomain
Domain Home: C:\Oracle\Middleware/user_projects/domains/ClassicDomain
Domain Host Name: admin
Domain Port No: 7001
User Name: weblogic
Automatic Port Detection: true
Administrator Console: http://admin:7001/console
EM Console: http://admin:7001/em
EMAgent URL: http://admin:5155/emd/main
Forms URL: http://admin:9001/forms/frmservlet
Reports URL: http://admin:9002/reports/rwservlet
and also created tnsnames.ora ...
Re: Debug Form [message #659027 is a reply to message #659026] Wed, 04 January 2017 10:07 Go to previous messageGo to next message
cookiemonster
Messages: 12771
Registered: September 2008
Location: Rainy Manchester
Senior Member
So what happens when you try to debug?
Re: Debug Form [message #659035 is a reply to message #659027] Wed, 04 January 2017 13:58 Go to previous messageGo to next message
Littlefoot
Messages: 21123
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Do you know how to enter debug mode? If not, here's a short walkthrough: you have to set a breakpoint somewhere in code; for example, a trigger - open it (in its PL/SQL editor), right-click the left margin and set the breakpoint. Then run a form in debug mode (it is an icon next to the "normal" run form icon in the toolbar, it has a mark on it). Once the form's execution reaches the breakpoint, it stops and notifies you to switch to Forms Builder. Then, using the toolbar icons, navigate through the code, watch variables, items, etc.
Re: Debug Form [message #659131 is a reply to message #659035] Fri, 06 January 2017 10:21 Go to previous messageGo to next message
shawaj
Messages: 32
Registered: January 2016
Member
Thanks for reply

Yes i know how to debug a form but it says no URL found when i run it
Re: Debug Form [message #659132 is a reply to message #659131] Fri, 06 January 2017 10:32 Go to previous messageGo to next message
Littlefoot
Messages: 21123
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
So, the form runs in "normal" mode, but won't run in "debug" mode?
Re: Debug Form [message #659295 is a reply to message #659132] Wed, 11 January 2017 11:14 Go to previous messageGo to next message
shawaj
Messages: 32
Registered: January 2016
Member
hello sir

Form does not run in "normal" mode also.
I am getting problem while startup weblogic
Pease check log file that is generated .

Thanks for reply
  • Attachment: WLS_FORMS.log
    (Size: 184.24KB, Downloaded 33 times)
Re: Debug Form [message #659301 is a reply to message #659295] Wed, 11 January 2017 14:41 Go to previous messageGo to next message
Littlefoot
Messages: 21123
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I know nothing about WebLogic server so ... I'm pretty much useless here.
Re: Debug Form [message #659378 is a reply to message #659301] Fri, 13 January 2017 12:18 Go to previous messageGo to next message
shawaj
Messages: 32
Registered: January 2016
Member
can anyone tell me how to uninstall weblogic without affecting forms and reports and database ????
Re: Debug Form [message #659379 is a reply to message #659378] Fri, 13 January 2017 12:29 Go to previous messageGo to next message
joy_division
Messages: 4755
Registered: February 2005
Location: East Coast USA
Senior Member
Which Weblogic, on the server or your client machine? You cannot run forms locally without the local Weblogic installed. If you don't want to use it, just don't start up the service(s). you just won't be able to test any form locally. You can still create forms.

What is it you really want to do?
Re: Debug Form [message #659392 is a reply to message #659379] Sat, 14 January 2017 00:33 Go to previous messageGo to next message
shawaj
Messages: 32
Registered: January 2016
Member
I m using Oracle WebLogic Server 10.3.6 on my personal machine not server.
can i re-install Oracle WebLogic Server 10.3.6 without affecting my forms and reports ?
Re: Debug Form [message #659393 is a reply to message #659392] Sat, 14 January 2017 05:10 Go to previous messageGo to next message
Littlefoot
Messages: 21123
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Quote:

... without affecting my forms and reports
Do you mean FMB and RDF files, or Forms and Reports services (if WebLogic has them, just as IAS previously did)?

If former, I don't know WHY would they be affected (in other words: no, they wouldn't be affected). If latter, I don't know the answer, but I presume that you'd have to reinstall them as well.
Re: Debug Form [message #659394 is a reply to message #659393] Sat, 14 January 2017 05:13 Go to previous messageGo to next message
shawaj
Messages: 32
Registered: January 2016
Member
ok
i mean forms and report services that i have already installed...
Thanks
Re: Debug Form [message #659448 is a reply to message #659394] Tue, 17 January 2017 08:17 Go to previous messageGo to next message
joy_division
Messages: 4755
Registered: February 2005
Location: East Coast USA
Senior Member
You are still not clear.
First you say uninstall, then re-install. Which is it?
As I said, you cannot run a form unless you have Weblogic installed and running.
Re: Debug Form [message #659591 is a reply to message #659448] Mon, 23 January 2017 05:11 Go to previous message
shawaj
Messages: 32
Registered: January 2016
Member
thanks to all
i have re-installed my weblogic and forms
Previous Topic: Oracle Forms exit_form twice
Next Topic: CLIENT_OLE2 Problems
Goto Forum:
  


Current Time: Thu Jun 29 04:18:20 CDT 2017

Total time taken to generate the page: 0.33331 seconds