Home » RDBMS Server » Networking and Gateways » Z/OS Compatibility (sql*net V2 z/os V2)
Z/OS Compatibility [message #655927] Fri, 16 September 2016 13:30 Go to next message
Ugoperri
Messages: 2
Registered: September 2016
Junior Member
Currently running an application with SQL*NET V2.3.3 client under OS390 V2R5 on a old IBM mainframe... to access an ORACLE11g distributed server database.

Planning to move the application under z/OS V2.2 on a newer IBM mainframe .......

Can we just move our SQL*NET as is ???
or
Should we migrate SQL*NEt to Net8 or whatever other '' net software '' ???
or else
Re: Z/OS Compatibility [message #655944 is a reply to message #655927] Sat, 17 September 2016 12:19 Go to previous messageGo to next message
EdStevens
Messages: 848
Registered: September 2013
Senior Member
So you have an application running under Z/OS, and that application connects to an Oracle 11g (is that 11.1 or 11.2?) database on some other system?
And that application is moving to another system running Z/OS ?

I would think migrating to "Net8" would be a downgrade, as that was what came with Oracle 8.

Unless I have misunderstood something, why would you currently be running the oracle v11 client stack on the current Z/OS, and why would you not continue to use that on the new Z/OS? Or move to the v12 client stack?

FWIW, while I don't have anything on Z/OS, all of my databases are currently at 11.2.0.4, and the only client software I ever install on either desktops or application servers is 12.1.
Re: Z/OS Compatibility [message #655991 is a reply to message #655944] Mon, 19 September 2016 09:52 Go to previous messageGo to next message
Ugoperri
Messages: 2
Registered: September 2016
Junior Member
Net8 wouldn't be a downgrade...

Net8 was a replacement for SQL*Net that we are presently running

Yes I know Net8 came with Oracle8...

So let me rephrase my '' two '' questions ...


Would the client SQL*Net that we are presently running under OS/390 V2R5 would run under a newer z/OS V2.2 ?

In case it didn't ... what would be the replacement for our old SQL*Net ..... Net8 or else ??

Re: Z/OS Compatibility [message #656016 is a reply to message #655991] Tue, 20 September 2016 06:25 Go to previous message
EdStevens
Messages: 848
Registered: September 2013
Senior Member
Looking at the certification tool on MOS, I don't see sqlnet specifically listed as a product, so I selected "Oracle Database Client". From there, the highest version of Z/OS listed is 2.1.

I'd be asking my Oracle account rep.
Previous Topic: Instance "ASH2", status BLOCKED, has 1 handler(s) for this service...
Next Topic: Intercept connection to Oracle DB
Goto Forum:
  


Current Time: Mon Nov 20 15:04:17 CST 2017

Total time taken to generate the page: 0.07733 seconds