Home » RDBMS Server » Enterprise Manager » Cannot create OEM repository (Oracle 10g, 10.2.0.4.0 - 64bit, Linux RHEL6)
Cannot create OEM repository [message #651134] Wed, 11 May 2016 23:11 Go to next message
devan0165
Messages: 27
Registered: September 2015
Location: Malaysia
Junior Member
I managed to upgrade Oracle 10g 10.2.0.1.0 to 10.2.0.4.0 in test server.

But, I am unable to create OEM due to some errors.

When I revisited the make.log file, it shows errors to missing file 'crti.o' and 'crt1.o' as shown below:-

...
/usr/bin/make -f ins_net_client.mk client_sharedlib ORACLE_HOME=/dot/oracle/product/10.2.0/db_1//dot/oracle/product/10.2.0/db_1/bin/genclntsh
cat: /dot/oracle/product/10.2.0/db_1/lib32/ldflags: No such file or directory
/usr/bin/ld: crti.o: No such file: No such file or directory
collect2: ld returned 1 exit status
genclntsh: Failed to link libclntsh.so.10.1
...
Linking external procedure agent (/dot/oracle/product/10.2.0/db_1/rdbms/lib/extproc32)
rm -f /dot/oracle/product/10.2.0/db_1/rdbms/lib/extproc32
gcc -m32 -o /dot/oracle/product/10.2.0/db_1/rdbms/lib/extproc32 -L/dot/oracle/product/10.2.0/db_1/rdbms/lib32/ -L/dot/oracle/product/10.2.0/db_1/lib32/ -L/dot/oracle/product/10.2.0/db_1/lib32/stubs/ /dot/oracle/product/10.2.0/db_1/rdbms/lib32/hormc.o /dot/oracle/product/10.2.0/db_1/rdbms/lib32/defopt.o /dot/oracle/product/10.2.0/db_1/rdbms/lib32/homts.o -lagtsh -lpls10 -lplp10 -lpthread -lclntsh -lsnls10 -lnls10 -lcore10 -lsnls10 -lnls10 -lcore10 -lsnls10 -lnls10 -lxml10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 /dot/oracle/product/10.2.0/db_1/lib32/libgeneric10.a `cat /dot/oracle/product/10.2.0/db_1/lib32/sysliblist` -Wl,-rpath,/dot/oracle/product/10.2.0/db_1/lib -lm `cat /dot/oracle/product/10.2.0/db_1/lib32/sysliblist` -ldl -lm -L/dot/oracle/product/10.2.0/db_1/lib -lvsn10
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
make[1]: Leaving directory `/dot/oracle/product/10.2.0/db_1/rdbms/lib'
make[1]: *** [/dot/oracle/product/10.2.0/db_1/rdbms/lib/extproc32] Error 1
make: *** [extproc32] Error 2


How can I rebuild this missing files 'crti.o' and 'crt1.o' so that I can complete the upgrade process and run Oracle Enterprise Manager ?
Re: Cannot create OEM repository [message #651145 is a reply to message #651134] Thu, 12 May 2016 02:56 Go to previous messageGo to next message
John Watson
Messages: 7150
Registered: January 2010
Location: Global Village
Senior Member
Are you trying to install 32 bit software on a 64 bit OS?

In general, I suspect that you are wasting your (or your client's) time: why install such old software? It is going to cause you endless grief.
Re: Cannot create OEM repository [message #651155 is a reply to message #651145] Thu, 12 May 2016 03:48 Go to previous messageGo to next message
devan0165
Messages: 27
Registered: September 2015
Location: Malaysia
Junior Member
I don't understand.

Where did I get the 32 bit software ?

I am installing from the oracle installer file 'p6810189_10204_Linux-x86-64.zip'
which downloaded from oracle site.
Re: Cannot create OEM repository [message #651156 is a reply to message #651155] Thu, 12 May 2016 03:57 Go to previous messageGo to next message
John Watson
Messages: 7150
Registered: January 2010
Location: Global Village
Senior Member
You say that you have already upgraded your database to release 10.2.0.4. OK - though why you would "upgrade" to a release that is eight years old is a mystery to me.

So what are you trying to install now?
Re: Cannot create OEM repository [message #651157 is a reply to message #651156] Thu, 12 May 2016 04:15 Go to previous messageGo to next message
devan0165
Messages: 27
Registered: September 2015
Location: Malaysia
Junior Member
I am trying to create OEM but got errors as shown below:-

<MPDDB@MPDDB:[/home/oracle/devan/emca]:1007> emca -config dbcontrol db -repos create

STARTED EMCA at May 12, 2016 5:12:49 PM
EM Configuration Assistant, Version 10.2.0.1.0 Production
Copyright (c) 2003, 2005, Oracle. All rights reserved.

Enter the following information:
Database SID: MPDDB
UnsatisfiedLinkError exception loading native library: njni10
Exception in thread "main" java.lang.UnsatisfiedLinkError: get
at oracle.net.common.NetGetEnv.get(Native Method)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.getEnvParams(SQLEngine.java:410)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.initialize(SQLEngine.java:238)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.<init>(SQLEngine.java:223)
at oracle.sysman.assistants.util.sqlEngine.SQLPlusEngine.<init>(SQLPlusEngine.java:106)
at oracle.sysman.emcp.util.GeneralUtil.initSQLEngine(GeneralUtil.java:352)
at oracle.sysman.emcp.DatabaseChecks.checkDbAvailabilityImpl(DatabaseChecks.java:104)
at oracle.sysman.emcp.DatabaseChecks.checkDbAvailability(DatabaseChecks.java:146)
at oracle.sysman.emcp.DatabaseChecks.isASMDb(DatabaseChecks.java:718)
at oracle.sysman.emcp.EMConfigAssistant.getParamsWarnsList(EMConfigAssistant.java:1812)
at oracle.sysman.emcp.EMConfigAssistant.getDisplayAndPromptWarnsParms(EMConfigAssistant.java:2295)
at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:947)
at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:470)
at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:419)

I found out that this got to do with the missing files that I mentioned earlier.
Re: Cannot create OEM repository [message #651160 is a reply to message #651157] Thu, 12 May 2016 04:28 Go to previous messageGo to next message
John Watson
Messages: 7150
Registered: January 2010
Location: Global Village
Senior Member
Now you have posted a completely different error! Did you solve the original one? Whatever it was you were doing them? On my Linux 6, those files exist no problem,
$
$ find / -name crt1.o
/usr/lib64/crt1.o
$
$ find / -name crti.o
/usr/lib64/crti.o
$
so perhaps youi have not installed the OS packages that are needed. Check your pre-requisites.However, why install such ancient software? You are running on a Linux release for which DB 10.2.0.4 was never certified, so you cannot ask Support for assistance.
Re: Cannot create OEM repository [message #651164 is a reply to message #651160] Thu, 12 May 2016 05:17 Go to previous messageGo to next message
devan0165
Messages: 27
Registered: September 2015
Location: Malaysia
Junior Member
Actually, I want to test the fulltext re-indexing performance in new version.

Till now, we don't pay any support maintenance to Oracle.

The same files exist on the test server:-

<MPDDB@MPDDB:[/home/oracle]:1006> ls -la /usr/lib64/crt*
-rw-r--r-- 1 root root 1648 Nov 1 2012 /usr/lib64/crt1.o
-rw-r--r-- 1 root root 1504 Nov 1 2012 /usr/lib64/crti.o
-rw-r--r-- 1 root root 760 Nov 1 2012 /usr/lib64/crtn.o

But, not in folder /usr/lib.

May I know what OS packages (RPM) that create the same files for 32-bit apps ?
Re: Cannot create OEM repository [message #651174 is a reply to message #651164] Thu, 12 May 2016 06:12 Go to previous messageGo to next message
John Watson
Messages: 7150
Registered: January 2010
Location: Global Village
Senior Member
If you are not paying for a support contract, your use of release 10.2.0.4 is illegal.

I do not talk to criminals. Good bye.
Re: Cannot create OEM repository [message #651204 is a reply to message #651174] Thu, 12 May 2016 10:32 Go to previous message
devan0165
Messages: 27
Registered: September 2015
Location: Malaysia
Junior Member
Thanks for your advice.

I will drop this tasks.

Previous Topic: Cannot start 12.1.0.4 OMS Cloud Control
Next Topic: Cannot start dbconsole after upgrade from 11.2.0.2 to 11.2.0.4 on windows server 2012 r2
Goto Forum:
  


Current Time: Fri Nov 24 23:32:19 CST 2017

Total time taken to generate the page: 0.01305 seconds