Home » Server Options » Streams & AQ » messages not consuming from MQ to AQ (Oracle 11g)
messages not consuming from MQ to AQ [message #632759] Thu, 05 February 2015 08:40 Go to next message
ramya_162
Messages: 107
Registered: August 2013
Location: Banglore
Senior Member
Hi All,


Messages are not flowing from IBM MQ to Oracle AQ.
I could see the following error in MGW log.


>>2015-02-05 05:30:55 MGW Engine 0 410 worker3
Errors occurred during processing of job JOB_WEB_MSG
oracle.mgw.common.GatewayException: [417] Missing log records in sending log queue for job JOB_WEB_MSG
        at oracle.mgw.common.MgwUtil.GatewayException(MgwUtil.java:733)
        at oracle.mgw.engine.Worker.commitMessages(Worker.java:852)
        at oracle.mgw.engine.Worker.processJob(Worker.java:1912)
        at oracle.mgw.engine.Worker.myRun(Worker.java:96)
        at oracle.mgw.engine.ManagedThr.run(ManagedThr.java:58)
 
 
>>2015-02-05 06:17:31 MGW Engine 0 51 ConfigNotifier
No missing logs for job JOB_WEB_MSG to process
>>2015-02-05 05:35:50 MGW Notif Handler 0 200 ConfigNotifier
 


I have done the below. Still the error persists.


begin
DBMS_MGWADM.CLEANUP_GATEWAY (action => DBMS_MGWADM.RESET_SUB_MISSING_LOG_REC,sarg => 'JOB_WEB_MSG');
end;
 


Please help me.


Thanks.
Re: messages not consuming from MQ to AQ [message #632961 is a reply to message #632759] Mon, 09 February 2015 02:53 Go to previous message
ramya_162
Messages: 107
Registered: August 2013
Location: Banglore
Senior Member
Hi All,

Even we have this error

[417] Missing log records in sending log queue for job JOB_WEB_MSG

Messages are coming to AQ for some time and suddenly stopping.
And also once the msg consumed by AQ the messages is not destructing from MQ
and same message is consuming by AQ multiple times.

Thanks.
Previous Topic: propagation between 3 queues( Oracle AQ)
Next Topic: Sql Statement for to see if the job is in Queue or not?
Goto Forum:
  


Current Time: Thu Nov 23 19:55:13 CST 2017

Total time taken to generate the page: 0.01436 seconds