Home » RDBMS Server » Server Utilities » Datapump import lower version to Higher version (oracle 10.2.0.4 - Windows server 2003)
Datapump import lower version to Higher version [message #622611] Thu, 28 August 2014 01:55 Go to next message
muktha_22
Messages: 397
Registered: December 2009
Senior Member
Hi,

Need help.


Usually there will not be any issue while Export and Import from Lower version to Higher version right?

But in my case:

I have exported some table in the DB version of 10.2.0.3.0.
And trying to Import in another server's DB of version 10.2.0.4.0.

But not allowed by showing the error "UDI-00018: Data Pump client is incompatible with database version 10.2.0.4.0".

Regards
Muktha
Re: Datapump import lower version to Higher version [message #622612 is a reply to message #622611] Thu, 28 August 2014 02:03 Go to previous messageGo to next message
Littlefoot
Messages: 19689
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Generally speaking:
- perform export with the lower (of two - source and target - databases) EXP(DP) version
- perform import with the target database's IMP(DP) version

So, you'd export with EXPDP 10.2.0.3 and import with IMPDP 10.2.0.4.
Re: Datapump import lower version to Higher version [message #622613 is a reply to message #622611] Thu, 28 August 2014 02:21 Go to previous messageGo to next message
Michel Cadot
Messages: 59414
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Post the 10 first lines of both export and import logs.

Re: Datapump import lower version to Higher version [message #622620 is a reply to message #622613] Thu, 28 August 2014 02:51 Go to previous messageGo to next message
muktha_22
Messages: 397
Registered: December 2009
Senior Member
Hi,

The export file Log file contains:

Export: Release 10.2.0.3.0 - 64bit Production on Saturday, 27 August, 2014 16:10:15

Copyright (c) 2003, 2005, Oracle.  All rights reserved.
;;; 
Connected to: Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bit Production
With the Partitioning, OLAP and Data Mining options
Starting "...."."SYS_EXPORT_TABLE_01":  ...../******** tables=('table1','table2') directory=BKP dumpfile=*******.dmp logfile=**************.log 
Estimate in progress using BLOCKS method...
Processing object type TABLE_EXPORT/TABLE/TABLE_DATA
Total estimation using BLOCKS method: 6.003 GB
Processing object type TABLE_EXPORT/TABLE/TABLE
Processing object type TABLE_EXPORT/TABLE/STATISTICS/TABLE_STATISTICS
. . exported "*******"            3.22 GB 22623594 rows
. . exported "*******"          1.8 GB 50294008 rows
Master table "*******"."SYS_EXPORT_TABLE_01" successfully loaded/unloaded
******************************************************************************
Dump file set for *******.SYS_EXPORT_TABLE_01 is:
  *******.DMP
Job "*******"."SYS_EXPORT_TABLE_01" successfully completed at 16:30



For the Import:
Log were not generated

Got a screen with the error of "UDI-00018: Data Pump client is incompatible with database version 10.2.0.4.0".

Thanks
Muktha
Re: Datapump import lower version to Higher version [message #622621 is a reply to message #622620] Thu, 28 August 2014 02:53 Go to previous messageGo to next message
muktha_22
Messages: 397
Registered: December 2009
Senior Member
Hi Little Foot,

I couldn't understand.

Even I tried the option of "version=10.2.0.3.0" while importing.
Still not done.

Regards
Muktha
Re: Datapump import lower version to Higher version [message #622624 is a reply to message #622621] Thu, 28 August 2014 03:03 Go to previous messageGo to next message
Michel Cadot
Messages: 59414
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Do not tell us, show us. Show the output.
The problem is not in the dump it is in the client version.

UDI-00018: Data Pump client is incompatible with database version %s
 *Cause:  The Import utility is at a higher version than the database
          version and is thereby incompatible.
 *Action: Use the same version of Import utility as the database.
Re: Datapump import lower version to Higher version [message #622625 is a reply to message #622611] Thu, 28 August 2014 03:06 Go to previous messageGo to next message
Lalit Kumar B
Messages: 2444
Registered: May 2013
Location: World Wide on the Web
Senior Member
muktha_22 wrote on Thu, 28 August 2014 12:25
"UDI-00018: Data Pump client is incompatible with database version 10.2.0.4.0"


Interesting, looking at the compatibility details here http://www.oracleracexpert.com/2013/06/datapump-exportimport-errors-ora-39142.html, import from 10.2.0.3 and export in 10.2.0.4 should be compatible. I checked MOS, and found Doc ID 1141173.1, but that talks about issue with Version 11.2.0.1.0. Was the database upgrade or install of 10.2.0.4 done correctly? As this is the cause mentioned.
Re: Datapump import lower version to Higher version [message #622652 is a reply to message #622625] Thu, 28 August 2014 04:57 Go to previous messageGo to next message
Michel Cadot
Messages: 59414
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Quote:
import from 10.2.0.3 and export in 10.2.0.4 should be compatible.


Which has nothing to with the problem as it is the opposite.
But as I said, it is not the DATABASE version that is the problem but the CLIENT one (on which we know nothing as OP never posted the output from impdp).

Re: Datapump import lower version to Higher version [message #622654 is a reply to message #622652] Thu, 28 August 2014 05:13 Go to previous messageGo to next message
Lalit Kumar B
Messages: 2444
Registered: May 2013
Location: World Wide on the Web
Senior Member
Michel Cadot wrote on Thu, 28 August 2014 15:27

Quote:
import from 10.2.0.3 and export in 10.2.0.4 should be compatible.


Which has nothing to with the problem as it is the opposite.


The connection lost between my mind and fingers while I was typing. I ended up jumbling import/export and it changed entire meaning, sorry. I wanted to say,

"export from 10.2.0.3 and import in 10.2.0.4 should be compatible." Like all, I too use the words "from" and "in" respectively for "export" and "import".
Re: Datapump import lower version to Higher version [message #622660 is a reply to message #622654] Thu, 28 August 2014 06:02 Go to previous messageGo to next message
Michel Cadot
Messages: 59414
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Quote:
"export from 10.2.0.3 and import in 10.2.0.4 should be compatible."


Yes, if the client is 10.2.0.4.
But I think we will never have any answer and feedback from OP as for many of his topics.

Re: Datapump import lower version to Higher version [message #622862 is a reply to message #622660] Mon, 01 September 2014 00:24 Go to previous messageGo to next message
muktha_22
Messages: 397
Registered: December 2009
Senior Member
Hi All,

Sorry for the late reply.

Finally I had to go with the old type of Export / Import method (IMP / EXP).

While using the EXPDP there were no problem.

But while using IMPDP I got the problem as below.

"UDI-00018: Data Pump client is incompatible with database version 10.2.0.4.0"


Regards
Muktha
Re: Datapump import lower version to Higher version [message #622865 is a reply to message #622862] Mon, 01 September 2014 00:35 Go to previous messageGo to next message
Michel Cadot
Messages: 59414
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

You still didn't answer to our question.

Re: Datapump import lower version to Higher version [message #622868 is a reply to message #622865] Mon, 01 September 2014 02:23 Go to previous messageGo to next message
muktha_22
Messages: 397
Registered: December 2009
Senior Member
Hi Michel,


I couldn't understand. If you ask me about the version, I already had mentioned.

EXPDP version 10.2.0.3 and IMPDP version 10.2.0.4.


Thanks and Regards
Muktha
Re: Datapump import lower version to Higher version [message #622870 is a reply to message #622868] Mon, 01 September 2014 02:45 Go to previous message
Michel Cadot
Messages: 59414
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

You mentioned DATABASE version, I asked you for CLIENT version.
And I also asked you:

Quote:
Do not tell us, show us. Show the output.


Previous Topic: sqlldr issue loading huge files
Next Topic: EXPORT DUMP File max size.
Goto Forum:
  


Current Time: Wed Oct 22 08:13:43 CDT 2014

Total time taken to generate the page: 0.05293 seconds