Home » Developer & Programmer » Forms » FRM-40353 error on Execute_Query (11G)
FRM-40353 error on Execute_Query [message #617639] Wed, 02 July 2014 07:55 Go to next message
RaShi.Raj
Messages: 33
Registered: May 2014
Location: Bangalore
Member
Hi,

I have a simple code - go_block('blk') follwed by execute_query;

After code executes 'Execute_query', i'm getting an error message 'frm-40353 - query cancelled'. Why is it so?? When I run select query on DB table on which block is based, i can see records.

Thanks,
Rashi


Re: FRM-40353 error on Execute_Query [message #617647 is a reply to message #617639] Wed, 02 July 2014 09:21 Go to previous messageGo to next message
Littlefoot
Messages: 19693
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Did you try to run the form in debug mode?
Re: FRM-40353 error on Execute_Query [message #617655 is a reply to message #617647] Wed, 02 July 2014 09:44 Go to previous messageGo to next message
RaShi.Raj
Messages: 33
Registered: May 2014
Location: Bangalore
Member
Yes, get that message after control executes 'Execute_Query'.
Re: FRM-40353 error on Execute_Query [message #617656 is a reply to message #617655] Wed, 02 July 2014 09:50 Go to previous messageGo to next message
RaShi.Raj
Messages: 33
Registered: May 2014
Location: Bangalore
Member
BTW, I tried creating new form with just that block and I can fetch records successfully.
Re: FRM-40353 error on Execute_Query [message #617659 is a reply to message #617656] Wed, 02 July 2014 10:04 Go to previous messageGo to next message
Littlefoot
Messages: 19693
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Probably won't help, but - try to recompile the form (Ctrl + Shift + K).
Re: FRM-40353 error on Execute_Query [message #617662 is a reply to message #617659] Wed, 02 July 2014 10:26 Go to previous messageGo to next message
RaShi.Raj
Messages: 33
Registered: May 2014
Location: Bangalore
Member
No joy Sad
Re: FRM-40353 error on Execute_Query [message #617704 is a reply to message #617662] Wed, 02 July 2014 14:53 Go to previous messageGo to next message
Littlefoot
Messages: 19693
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Is it a complex form? Can you afford creating a new one from scratch?
Re: FRM-40353 error on Execute_Query [message #617723 is a reply to message #617639] Thu, 03 July 2014 01:32 Go to previous messageGo to next message
azamkhan
Messages: 492
Registered: August 2005
Senior Member
Are you using different users when running this form. If yes then see if there a privilege problem.
Re: FRM-40353 error on Execute_Query [message #617729 is a reply to message #617723] Thu, 03 July 2014 01:56 Go to previous messageGo to next message
RaShi.Raj
Messages: 33
Registered: May 2014
Location: Bangalore
Member
@littlefoot - Yes, it's a complex form. Even I feel starting from scratch will fix this.
@Azamkhan - I don't think it'a problem with privileges. I created a simple form and could fetch records logged in as same user where i'm facing problem.

Btw, I get error "ORA-01013: user requested cancel of current operation" when I press ctrl+F1 after execute query in run time.

[Updated on: Thu, 03 July 2014 02:07]

Report message to a moderator

Re: FRM-40353 error on Execute_Query [message #617735 is a reply to message #617729] Thu, 03 July 2014 04:26 Go to previous messageGo to next message
Littlefoot
Messages: 19693
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
If it is specifically a 11g issue, I'm afraid I can't assist as I'm still on 10g. Sorry.
Re: FRM-40353 error on Execute_Query [message #617743 is a reply to message #617735] Thu, 03 July 2014 05:25 Go to previous messageGo to next message
RaShi.Raj
Messages: 33
Registered: May 2014
Location: Bangalore
Member
Getting this error on 6i as well as 11G.
Re: FRM-40353 error on Execute_Query [message #617753 is a reply to message #617743] Thu, 03 July 2014 06:14 Go to previous messageGo to next message
cookiemonster
Messages: 11074
Registered: September 2008
Location: Rainy Manchester
Senior Member
Try tracing the DB session and see if the form actually submits the query to the DB, and see if any error is returned.
Re: FRM-40353 error on Execute_Query [message #617891 is a reply to message #617639] Fri, 04 July 2014 04:38 Go to previous message
RaShi.Raj
Messages: 33
Registered: May 2014
Location: Bangalore
Member
Thanks guys,

I could able to fix the problem by changing "interacion mode" property of form from 'non-blocking' to 'blocking'.
Previous Topic: calendar.pll and stndard.olb
Next Topic: item property in pre_update trigger
Goto Forum:
  


Current Time: Thu Oct 23 11:10:00 CDT 2014

Total time taken to generate the page: 0.11964 seconds