Home » Applications » Oracle Fusion Apps & E-Business Suite » Problem installing EBS on linux box (12.2 (latest download as of 6/2014))
Problem installing EBS on linux box [message #616720] Thu, 19 June 2014 21:36 Go to next message
joelthompson
Messages: 3
Registered: June 2014
Location: United States
Junior Member
Hi,

I'm hoping that someone can give me some insight on how to proceed.

I was running the startCD/Disk1/rapidwiz/rapidwiz program, and doing a new single node installation.
I believe I downloaded all the appropriate zip files, and was prep'd w/ the prerequisites ok.. (all
except OS version, EBS 12.2 is not "certified" on CentOS release 6.5 - yet, I don't think that is
the problem. Anyhow, the installation just stopped in "adrunfmw.sh" script w/ the following:

/home/oracle/ebs/Stage122/startCD/Disk1/rapidwiz/jre/Linux_x64/1.6.0/bin/java -cp /home/d01/oracle/VIS/fs2/inst/apps/VIS_webcenterteam/temp/ASInstallHome/fnd/../j11067592_fnd.zip:/home/d01/oracle/VIS/fs2/inst/apps/V IS_webcenterteam/temp/ASInstallHome/fnd/java/3rdparty/stdalone/xmlparserv2.zip -Doracle.apps.fnd.txk.env_home=/home/d01/oracle/VIS/fs2/EBSapps/appl/admin/VIS_webcenterteam/ -Doracle.apps.fnd.txk.runtime.config=/home/d01/oracle/VIS/fs2/inst/apps/VIS_webcenterteam/temp/xmldocs/instToolPatches.xml oracle.apps.fnd.txk.config.InstallService
Fatal Error: TXK Install Service
oracle.apps.fnd.txk.config.ProcessStateException: FileSys OS COMMAND Failed : Exit=2 See log for details. CMD= sh /home/d01/oracle/VIS/fs2/inst/apps/VIS_webcenterteam/temp/patches/10152652/10152652/patch.sh ## Node=NodeId=850 Type=24 TypeName=filesys_patch_action Name= RefId=423 State=init ConfigDoc=APPS_C_HOME ParentDoc=null Topology=R12 Action=os_cmd

Cannot install Web Tier Utilities
RW-50010: Error: - script has returned an error: 1
RW-50004: Error code received when running external process. Check log file for details.
Running APPL_TOP Install Driver for VIS instance

Question I have in a general sense, is will I be able to complete the installation, by debugging and running "adrunfmw.sh" incrementally by hand, or should I scrap the entire installation (how to I uninstall this?), if I do it incrementally , then will I still be missing other scirpts that need to be run? Is there any docs on the scripts that are run (it is all hidden in the "rapidwiz" UI program.

What are some steps to take to verify what pieces already are installed properly?

Thanks guys/gals... any help is appreciated alot! Smile

-Joel
Re: Problem installing EBS on linux box [message #616725 is a reply to message #616720] Fri, 20 June 2014 00:53 Go to previous messageGo to next message
Littlefoot
Messages: 19653
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Although I have never even seen how EBS applications look like (not to mention installing it on Linux), I'd disagree with your statement, saying
Quote:

prerequisites ok.. (all except OS version, EBS 12.2 is not "certified" on CentOS release 6.5 - yet, I don't think that is the problem


I've, on the other hand, read numerous discussions, where people ask for help while installing Oracle Developer Suite on unsupported and never certified operating systems. True: there are chances that you'll eventually install that piece of software, but you can never be sure that it will properly work. For example, Forms users can't compile their forms; or, run a form but some functionalities fail, etc.

I'm sorry, I can't help. I do hope you'll finish the installation process and use EBS. By the way, why don't you use a certified Linux?
Re: Problem installing EBS on linux box [message #616791 is a reply to message #616725] Fri, 20 June 2014 12:16 Go to previous messageGo to next message
joelthompson
Messages: 3
Registered: June 2014
Location: United States
Junior Member
I guess that's the risk I take - I can say, that it's probably not the cause, since the software involves: oracle rdbms, weblogic server, and forms server. I already have stood up the db, and WLS on this type of machine (not so sure about the forms part yet).

In any event. I'm hoping someone on this forum has had same or similar problem w/ the installation failing midway through, and can give me some insight on what is a good way to proceed, give the circumstances, and fully acknowledging the compatibility exposure. Smile

Re: Problem installing EBS on linux box [message #616826 is a reply to message #616791] Fri, 20 June 2014 16:22 Go to previous messageGo to next message
Littlefoot
Messages: 19653
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Unfortunately, our forum lacks in experienced EBS users. I'm not trying to scare you off, but I wouldn't hold my breath if I were you. Consider visiting OTN forums as it is visited by more participants who might be able to assist.
Re: Problem installing EBS on linux box [message #616848 is a reply to message #616791] Sat, 21 June 2014 09:42 Go to previous messageGo to next message
John Watson
Messages: 4612
Registered: January 2010
Location: Global Village
Senior Member
Your problem may well be that you are missing certain OS utilities. The EBS install assumes the presence of an awful lot of utilities, sometimes in exact locations. Usually, I do not worry about whether an Oracle product is certified for a particular OS release, but when it come to EBS, you do need to get it right. Even if you do get it right, I have many times had to hack things (such as installing extra utilities or creating links to files in the "wrong" location or with the "wrong" name).
I would strongly advise you to get rid of Centos and install OEL. It is the same kernel, but packaged in the way EBS will expect.
Re: Problem installing EBS on linux box [message #616982 is a reply to message #616720] Mon, 23 June 2014 19:16 Go to previous message
joelthompson
Messages: 3
Registered: June 2014
Location: United States
Junior Member
i was able to get it running. turns out that I didn't have KSH and and glibc-devel
1) yum install ksh.x86_64
2) yum install glibc-devel.i686
I saw that it was failing to "compile" due to a missing header: stubs-32.h
so after #1,2 I basically shutdown all the services that it started, and
then ran all the detachHome.sh scripts I could find, so that it cleaned up
the "inventory.xml"
./oracle/VIS/fs2/FMW_Home/webtier/oui/bin/detachHome.sh
./oracle/VIS/fs2/FMW_Home/Oracle_EBS-app1/oui/bin/detachHome.sh
./oracle/VIS/11.2.0/oui/bin/detachHome.sh
Run ./oracle/VIS/fs2/FMW_Home/wlserver_10.3/uninstall/uninstall.sh
Stop opmn
ps efl | grep opmn
kill <pids>
I then found http://www.pythian.com/blog/step-by-step-installation-of-an-ebs-12-2-vision-instance/
article which talked about some kernel settings, so I did them.
removed all files under the /d01 dir that was created in installation.
and rebooted the machine
then restarted the rapidwiz program and it went through good ... yet I have one (hopefully, just this
one... ) problem now.

the JSP verification test failed http://mytestdomain.com:8000/OA_HTML/jtfTestCookie.jsp

Failure of server APACHE bridge:
___________________________________________________________________________
No backend server available for connection: timed out after 10 seconds or idempotent set to OFF or method not idempotent.


Apparently OHS has some plugin that is trying to talk with a service, and it can't ... not even sure which service it is trying to invoke - the service at 8000 is: "Web Listener Port" and "Active Web Port"

Any ideas?

Thanks,
Joel
Previous Topic: AR INVOICE API PUB error when creating single invoice
Next Topic: Who knows what form name of the Descriptive Flex?
Goto Forum:
  


Current Time: Thu Oct 02 12:31:24 CDT 2014

Total time taken to generate the page: 0.08932 seconds