Home » Developer & Programmer » Reports & Discoverer » REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. (11g)
REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613954] Tue, 13 May 2014 23:19 Go to next message
skumar16jan
Messages: 6
Registered: May 2014
Location: Malaysia
Junior Member

Dear All,

Am getting below error while calling from 11g form:
REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL.

But am able to run successfully from standalone 11g report builder.

Please do need full help ASAP, as I need to deliver all 304 rdf/rep at earliest.

Regards,
Satinder kumar
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613955 is a reply to message #613954] Wed, 14 May 2014 00:04 Go to previous messageGo to next message
Littlefoot
Messages: 21266
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Recompile that report (Ctrl + Shift + K) and see what happens.
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613957 is a reply to message #613955] Wed, 14 May 2014 00:42 Go to previous messageGo to next message
skumar16jan
Messages: 6
Registered: May 2014
Location: Malaysia
Junior Member

Hi,

Am able to Shift+Ctrl+K , Export to rep, and run get output from report builder 11g but when am placing the rep into server and trying to call report from 11g form then only above mentioned error is coming.

I have checked all the oracle object in backend(all objects are valid).


Even same reports (all 300) working fine in 10g (form and report builder).

Regards,
Satinder kumar

[Updated on: Wed, 14 May 2014 00:42]

Report message to a moderator

Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613959 is a reply to message #613957] Wed, 14 May 2014 01:12 Go to previous messageGo to next message
Littlefoot
Messages: 21266
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
  • your Reports version is 11g
  • there's no problem in compiling or running that report in Reports Builder 11g
  • when you port that report to application server, it fails with REP-1247
What (which version) application server do you use? Is it 11g as well? (I believe that it is - in 11g version - called WebLogic server, but terminology doesn't matter much here). Or is it 10g?
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613962 is a reply to message #613959] Wed, 14 May 2014 01:20 Go to previous messageGo to next message
skumar16jan
Messages: 6
Registered: May 2014
Location: Malaysia
Junior Member

Yes....its 11g only.

Moreover, when am creating new report with a single column query then it is working fine but all of those 300 reports giving above mention error.

Regards,
Satinder kumar
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613964 is a reply to message #613962] Wed, 14 May 2014 01:33 Go to previous messageGo to next message
Littlefoot
Messages: 21266
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Are there any attached libraries? If so, did you recompile them as well?
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613969 is a reply to message #613964] Wed, 14 May 2014 01:46 Go to previous messageGo to next message
skumar16jan
Messages: 6
Registered: May 2014
Location: Malaysia
Junior Member

No there is no libraries attached......Please refer attachment
  • Attachment: 1111.JPG
    (Size: 42.99KB, Downloaded 701 times)
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613971 is a reply to message #613969] Wed, 14 May 2014 01:53 Go to previous messageGo to next message
Littlefoot
Messages: 21266
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I'm afraid I'm out of ideas ... sorry. Wait for someone else who might assist, or - consider calling Oracle Support.
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #613974 is a reply to message #613971] Wed, 14 May 2014 02:01 Go to previous messageGo to next message
skumar16jan
Messages: 6
Registered: May 2014
Location: Malaysia
Junior Member

Hi,

New report (developed in 10 or 11g) working fine but none of the existing conventional report working in 11g

Since last two week am struggling with this error... Sad Sad Sad

I have tried all the possible way but still did not find solution.

Regards,
Satinder kumar
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #626010 is a reply to message #613974] Sun, 19 October 2014 04:37 Go to previous messageGo to next message
syed555
Messages: 1
Registered: October 2014
Junior Member

Please ignore if this reply is too late.
Have you tried running the report in Paper layout? I am sure there is some error.
Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #645913 is a reply to message #613954] Wed, 16 December 2015 04:03 Go to previous messageGo to next message
mahesh23810
Messages: 1
Registered: December 2015
Location: copenhagen
Junior Member
This issue is because of database connection might be wrong in the server, i mean report was to trying to connection wrong database then all program units became invalid..due to this you are getting rep-1247.

Solution : Provide correct database credentials from the server end.





Re: REP-1247: Uncompiled program units exist. REP-1247: The report contains uncompiled PL/SQL. [message #663551 is a reply to message #645913] Wed, 07 June 2017 23:28 Go to previous message
Lubna
Messages: 12
Registered: June 2017
Junior Member

If this is too late then ignore,

Use schema name reference with table name.
for example:
schemaname.mytable

There is a chance where you forget to mention schema reference with table name in any of the formula.

hope this will fix your problem.
Previous Topic: Report 11g field text padding
Next Topic: Oracle Reports 6i with Oracle DB 11g. Does it work?
Goto Forum:
  


Current Time: Thu Dec 14 17:04:16 CST 2017

Total time taken to generate the page: 0.01758 seconds