Home » Developer & Programmer » Reports & Discoverer » Batch file issues (Discoverer 9i, Win XP)
Batch file issues [message #607891] Thu, 13 February 2014 03:25 Go to next message
Sodge
Messages: 4
Registered: February 2014
Junior Member
I'm trying to write a batch file to run a query, but when I manually run the query I get a pop up ("Do you want to run the query for sheet "Sheet 1"? If you click no the sheet will be empty.")

How do I disable this or make it select 'Yes'?

I've googled extensivley and can't find anything about this Confused

Thanks in advance!

Joe

Batch file:
"C:\oracle\disc_9i_crime\discoverer902\bin\dis51usr.exe" /connect %USER/%PASS@%DATABASE /open "U:\folder\blahblah.dis" /export csv "U:\blah.csv" /batch
Re: Batch file issues [message #607911 is a reply to message #607891] Thu, 13 February 2014 07:19 Go to previous messageGo to next message
Sodge
Messages: 4
Registered: February 2014
Junior Member
For anyone else looking for a solution for this I found it.

Open discoverer>Tools>Options>General 'After Opening a workbook'=tick 'Run automatically.

Now I'm just getting the error 'Attempt to open workbook Failed' but it's a step forward! Smile
Re: Batch file issues [message #607919 is a reply to message #607911] Thu, 13 February 2014 08:22 Go to previous messageGo to next message
Sodge
Messages: 4
Registered: February 2014
Junior Member
For anyone that's struggling that's stummbled across this, I've got it working Smile I think it was just that I was trying to run it when I already had the worksheet open *doh*

"C:\oracle\disc_9i_crime\discoverer902\bin\dis51usr.exe" /connect user/passw@datab/open "U:\query.dis" /sheet "Sheet 1" /export csv

"U:\exportfolder\%date:~0,2%-%date:~3,2%-%date:~6,4%-%time:~0,2%-%time:~3,2%-%time:~6,2%geocoding.csv" /batch (the fancy bit in the file name is just variables that title the file with the date and time)

[Updated on: Thu, 13 February 2014 08:30]

Report message to a moderator

Re: Batch file issues [message #607938 is a reply to message #607919] Thu, 13 February 2014 11:59 Go to previous messageGo to next message
Littlefoot
Messages: 19476
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
One man show, eh? Thank you for your time and efforts you put into solving the problem and sharing the knowledge.

Because, OraFAQ Forum lacks in people who are experienced Discoverer users. I hope you've come to stay.
Re: Batch file issues [message #608003 is a reply to message #607938] Fri, 14 February 2014 02:50 Go to previous message
Sodge
Messages: 4
Registered: February 2014
Junior Member
I've been a victim often enough to want to break the chain

Laughing
Previous Topic: Discoverer Calculations - Not Working
Next Topic: one report contain (Add_Parameter(pl_id,'Q_OM',DATA_PARAMETER,rg_name)) doesn't work
Goto Forum:
  


Current Time: Fri Aug 22 09:27:19 CDT 2014

Total time taken to generate the page: 0.14630 seconds