Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » ORA-04067
ORA-04067 [message #607008] Sat, 01 February 2014 03:48 Go to next message
PraveenaKarri
Messages: 3
Registered: January 2014
Junior Member
We are migrating forms from 6i to 10g. while running forms in our local and save the data to database it is working fine but when we run same form from Application server
we get error ORA 04067
please get me out from this problem.Its urgent requirement
Re: ORA-04067 [message #607013 is a reply to message #607008] Sat, 01 February 2014 07:46 Go to previous messageGo to next message
BlackSwan
Messages: 22718
Registered: January 2009
Senior Member
04067, 00000, "not executed, %s does not exist"
// *Cause: Attempt to execute a non-existent stored procedure.
// *Action: Make sure that a correct name is given.
Re: ORA-04067 [message #607262 is a reply to message #607013] Tue, 04 February 2014 05:07 Go to previous messageGo to next message
PraveenaKarri
Messages: 3
Registered: January 2014
Junior Member
I noticed that the error is coming because i wrote a stored procedure in my form and that procedure did not have permissions to other user.so when i login with that user who doesnt have permissions it is throwing an error.And now i need to give permissions to another user to execute that form.So Please kindly suggest me with an example how to give permissions to stored procedure from one user to another user
kindly help me put from this prblm
Re: ORA-04067 [message #607268 is a reply to message #607262] Tue, 04 February 2014 06:20 Go to previous messageGo to next message
sarma.shp
Messages: 111
Registered: February 2012
Senior Member

It is very simple:

Say suppose there are two users scott and hr. When you have created the procedure under the scott schema and want to execute it from hr schema, then do this from scott user:
   CONN SCOTT IDENTIFIED BY PASSWORD 
   GRANT EXECUTE ON proc_name TO HR


Now you can execute your procedure from HR as follows:
   exec SCOTT.proc_name 
Re: ORA-04067 [message #607321 is a reply to message #607268] Tue, 04 February 2014 22:37 Go to previous message
PraveenaKarri
Messages: 3
Registered: January 2014
Junior Member
Thank u the Problem solved
Previous Topic: SetRoles in WebLogic
Next Topic: 9iAS icons
Goto Forum:
  


Current Time: Sat Aug 30 15:16:48 CDT 2014

Total time taken to generate the page: 0.10827 seconds