Home » Developer & Programmer » Reports & Discoverer » Reading BLOB Images takes long time (Report Builder 10.1.2.0.2)
Reading BLOB Images takes long time [message #601908] Wed, 27 November 2013 01:42 Go to next message
deepakmannazhi
Messages: 128
Registered: February 2010
Location: Dubai, UAE
Senior Member

Dear All,
How are you?

We are trying to display images in our report in two ways

1. Directly read blob field
2. read from location using formula column.

Both ways it is working.

Quote:
But the problem is, it is taking too much time to run the report.


could you please suggest a way to reduce the time?
do we need to set any parameters?

Thanks and regards
Deepak
Re: Reading BLOB Images takes long time [message #601926 is a reply to message #601908] Wed, 27 November 2013 06:50 Go to previous messageGo to next message
Littlefoot
Messages: 19329
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Note that these are binary large objects.

How many images do you display in the report at a time? Is it one image per report, or do you display tens, hundreds or thousands of them?

How large are these images (bytes / kilobytes, Megabytes)?

What is report's response time if you DO NOT display images?

Try to run a report in debug mode (Edit - Preferences - Runtime settings - Run debug). Or, trace the session (put SRW.DO_SQL ('ALTER SESSION SET SQL_TRACE=TRUE'); into the report, for example BEFORE REPORT trigger) and TKPROF the result.
Re: Reading BLOB Images takes long time [message #602008 is a reply to message #601926] Thu, 28 November 2013 12:05 Go to previous messageGo to next message
deepakmannazhi
Messages: 128
Registered: February 2010
Location: Dubai, UAE
Senior Member

Dear LittleFoot,

Sorry For late reply, I dont have net connection at office. Wink

At a time 4 or 5 reports are displaying (about 1.25 Mb total)

Without image it is coming properly.


I will try in debug mode and let you know the result.


Thanks a lot for your time Smile

Re: Reading BLOB Images takes long time [message #602060 is a reply to message #602008] Fri, 29 November 2013 02:50 Go to previous messageGo to next message
cookiemonster
Messages: 10853
Registered: September 2008
Location: Rainy Manchester
Senior Member
deepakmannazhi wrote on Thu, 28 November 2013 18:05

At a time 4 or 5 reports are displaying (about 1.25 Mb total)

Do you mean 4 or 5 images per report?

deepakmannazhi wrote on Thu, 28 November 2013 18:05

Without image it is coming properly.

How long does it take with and without?
Re: Reading BLOB Images takes long time [message #602302 is a reply to message #602060] Mon, 02 December 2013 22:16 Go to previous messageGo to next message
deepakmannazhi
Messages: 128
Registered: February 2010
Location: Dubai, UAE
Senior Member

Dear cookiemonster,

Yes, 4 or 5 Images per Report. Without image it is coming in 2,3 Seconds.

Dear all,

One more thing, in Report builder it is coming in 6 seconds (With image). But when i run this report in Application it is taking 1 minute . And application server is in linux.


Re: Reading BLOB Images takes long time [message #602318 is a reply to message #602302] Tue, 03 December 2013 03:10 Go to previous message
cookiemonster
Messages: 10853
Registered: September 2008
Location: Rainy Manchester
Senior Member
I think at this point you need to trace the session to see where the time is being spent.
Previous Topic: send .pdf as mail attachment
Next Topic: One report, Multiple Copies
Goto Forum:
  


Current Time: Tue Jul 29 22:22:55 CDT 2014

Total time taken to generate the page: 0.09245 seconds