Home » RDBMS Server » Networking and Gateways » opiino : Attach Failed due to ORA-12560 (ORACLE 12C Windows 2012 64B on Vmware Server)
icon4.gif  opiino : Attach Failed due to ORA-12560 [message #600500] Thu, 07 November 2013 07:28 Go to next message
bensniper
Messages: 8
Registered: November 2013
Location: Belgique
Junior Member
Hello, I just reinstall an oracle server in version oracle 12 c on a Windows 2012 64Bits on VMware Server.
The installation went smoothly, Ditto for the tests, so I went into production and since I have problems.
Wholesale after 6 h of use users know more to connect and I get the error "opiino: Attach Failed due to ORA-12560" in the logs. The weekend deadline passes at 20: 00. and in the evening 12 h.
To address the issue I raise the listner service and the database.
(So on weekdays I raise at 09 h 30-15 h 30-21 h 30-09 h 30 > > >..)
The client they have no just error that the sqlplus connection rotates in a vacuum for example.
Point of view Oracle support I had answered that it does not support VMware Confused
Thanks in advance for your help.
Re: opiino : Attach Failed due to ORA-12560 [message #600506 is a reply to message #600500] Thu, 07 November 2013 07:56 Go to previous messageGo to next message
gazzag
Messages: 388
Registered: November 2010
Location: Bristol, UK
Senior Member
Is the Oracle Service started and set to automatic?

Start -> Administrative Tools -> Services -> OracleService<Database_SID>
Re: opiino : Attach Failed due to ORA-12560 [message #600509 is a reply to message #600506] Thu, 07 November 2013 08:19 Go to previous messageGo to next message
bensniper
Messages: 8
Registered: November 2013
Location: Belgique
Junior Member
Yes, the service is automatic, and when I have the problem it is not stopped it's me following forced to restart it manually.
Re: opiino : Attach Failed due to ORA-12560 [message #600510 is a reply to message #600509] Thu, 07 November 2013 08:23 Go to previous messageGo to next message
gazzag
Messages: 388
Registered: November 2010
Location: Bristol, UK
Senior Member
Please post an excerpt of the alert log a few lines either side of when the service stops. Also the %ORACLE_HOME%\database\oradim.log
Re: opiino : Attach Failed due to ORA-12560 [message #600512 is a reply to message #600510] Thu, 07 November 2013 08:34 Go to previous messageGo to next message
bensniper
Messages: 8
Registered: November 2013
Location: Belgique
Junior Member
These are the lines of oradim.log hours corresponds to the moment where I relaunched services

oradim.log

Thx


[EDITED by LF: applied [spoiler] tags to cut a long story short]

[Updated on: Fri, 08 November 2013 03:08] by Moderator

Report message to a moderator

Re: opiino : Attach Failed due to ORA-12560 [message #600513 is a reply to message #600512] Thu, 07 November 2013 08:48 Go to previous messageGo to next message
BlackSwan
Messages: 23146
Registered: January 2009
Senior Member
00609, 00000, "could not attach to incoming connection"
// *Cause: Oracle process could not answer incoming connection
// *Action: If the situation described in the next error on the stack
// can be corrected, do so; otherwise contact Oracle Support.
Re: opiino : Attach Failed due to ORA-12560 [message #600514 is a reply to message #600513] Thu, 07 November 2013 08:56 Go to previous messageGo to next message
gazzag
Messages: 388
Registered: November 2010
Location: Bristol, UK
Senior Member
Are the two servers (test and production) identical? Anything in the Windows Event logs?
Re: opiino : Attach Failed due to ORA-12560 [message #600516 is a reply to message #600512] Thu, 07 November 2013 09:30 Go to previous messageGo to next message
John Watson
Messages: 4859
Registered: January 2010
Location: Global Village
Senior Member
If I understand your posts correctly, you are saying that you get erratic failures when the system has been running for a while and you have many sessions: no one can connect, with ora-12560. Then you restart the instance, and everything is fine.
Oracle Support could be right: it could be operating system issues. You need to look at your Windows and your VMware. But it could also be limits within Oracle. Can you post a statspack or AWR report from when the system is busy?
Re: opiino : Attach Failed due to ORA-12560 [message #600525 is a reply to message #600516] Thu, 07 November 2013 12:14 Go to previous messageGo to next message
bensniper
Messages: 8
Registered: November 2013
Location: Belgique
Junior Member
the machine test and production are the same!
and in the events log there is nothing at all Sad
Re: opiino : Attach Failed due to ORA-12560 [message #600526 is a reply to message #600525] Thu, 07 November 2013 12:15 Go to previous messageGo to next message
bensniper
Messages: 8
Registered: November 2013
Location: Belgique
Junior Member
What is a statspack or AWR report ?
Re: opiino : Attach Failed due to ORA-12560 [message #600527 is a reply to message #600526] Thu, 07 November 2013 12:24 Go to previous messageGo to next message
BlackSwan
Messages: 23146
Registered: January 2009
Senior Member
More often than not, ORA-12560 error results from OS/networking mis-configuration.
The root cause & fix are external to Oracle.
Oracle is the victim; not the culprit.
I SERIOUSLY doubt that content statspack or AWR report will get you closer to the solution to this mystery.
Re: opiino : Attach Failed due to ORA-12560 [message #600536 is a reply to message #600527] Thu, 07 November 2013 12:48 Go to previous messageGo to next message
bensniper
Messages: 8
Registered: November 2013
Location: Belgique
Junior Member
I want to, but if I don't know or I can watch (track or whatever) I do not know how I will find the solution.
It is already the third machine oracle on VMware I install the 1 with the new version 12 c (before it was 11), and it is the first time I encounter this problem.
Re: opiino : Attach Failed due to ORA-12560 [message #600540 is a reply to message #600536] Thu, 07 November 2013 12:59 Go to previous messageGo to next message
BlackSwan
Messages: 23146
Registered: January 2009
Senior Member
is Oracle 12c certified on Windows 2012?

>It is already the third machine oracle on VMware I install the 1 with the new version 12 c (before it was 11),
>and it is the first time I encounter this problem.

Are you reporting that you have two similar system that work without throwing ORA-12560 error?

In my experience ORA-12560 get throw when trying to start or connect to a local database.


what exactly & actually done that results in the ORA-12560 be thrown
Re: opiino : Attach Failed due to ORA-12560 [message #600545 is a reply to message #600540] Thu, 07 November 2013 13:38 Go to previous messageGo to next message
bensniper
Messages: 8
Registered: November 2013
Location: Belgique
Junior Member
sorry but my English is not super good

Yes oracle12c is certified for windows 2012

I still have a system that revolves and that I met the same problem once, but it was due to the size of log file from the listner. And it must be migrated to the new database who asks me problem.

Ditto for me, that is what I do not understand. Furthermore I did not the same behavior on weekends and week. So really looks like it is the number of connection to the database which saturates a moment.

The most bizarre as it is if I have a sqlplus from open and connected, when the system crashes, via this sqlplus can continue to query the database without problem, but if I disconnect I know to reconnect more me.
Re: opiino : Attach Failed due to ORA-12560 [message #600656 is a reply to message #600545] Mon, 11 November 2013 00:31 Go to previous message
bensniper
Messages: 8
Registered: November 2013
Location: Belgique
Junior Member
Hello
I may be found the solution, the listner services and oracle starts normally via a local account created during installation (created by the oracle Installer), I replace this user by "local system" account and since I meet more problem. Now I look again 1 week before throwing the problem.
Previous Topic: Oracle Database question
Next Topic: ORA-609 : opiodr aborting process unknown ospid
Goto Forum:
  


Current Time: Fri Dec 19 07:48:50 CST 2014

Total time taken to generate the page: 0.11454 seconds