Home » SQL & PL/SQL » Client Tools » SQL problem ( oracle 10 g , Windows7 )
SQL problem [message #598714] Wed, 16 October 2013 23:17 Go to next message
saturnel
Messages: 8
Registered: October 2013
Junior Member

I come here with an old question I saw in this Forum an another.
I work with oracle 10g, on windows 7. But something often happen. sometime when i try to start my sqlplus in prompt command this message display.
C:\Users\Sony>sqlplus
SP2-1503: Unable to initialize Oracle call interface
SP2-0152: ORACLE may not be functioning properly

But the solution people have proposed into the forum are:
1 - check the environment variable Oracle_home and modify if it ending by "\"
2 - or try tho run my promt command as Administrator.

I try the both, but only the second works. while now i don't understand why it works when i start the promt command as Administrator and why it no works when i don't run it like administrator. Another thing is i am the only user of my computer, i have only one session (administor session). Please somebody can try to explain me???
Re: SQL problem [message #598734 is a reply to message #598714] Thu, 17 October 2013 05:00 Go to previous messageGo to next message
Lalit Kumar B
Messages: 1826
Registered: May 2013
Location: World Wide on the Web
Senior Member
Are you sure you login as Administrator in Win7? If not then you have to explicitly select the option "Run as Administrator". In Win7 it has to be done.
Re: SQL problem [message #598776 is a reply to message #598734] Thu, 17 October 2013 11:18 Go to previous messageGo to next message
saturnel
Messages: 8
Registered: October 2013
Junior Member

Lalit Kumar B
thanks, yes when i run as Administrator it has done. But i want to know why it run only as administrator?
Re: SQL problem [message #598787 is a reply to message #598776] Thu, 17 October 2013 14:17 Go to previous messageGo to next message
Lalit Kumar B
Messages: 1826
Registered: May 2013
Location: World Wide on the Web
Senior Member
saturnel wrote on Thu, 17 October 2013 21:48
Lalit Kumar B
thanks, yes when i run as Administrator it has done. But i want to know why it run only as administrator?


Well, that's something related to Microsoft Windows. You can post to their appropriate forum.

I have one suggestion for you, if you frequently face a prompt message by UAC, and as you said that you are the only user, you can set to "Run as Administrator" for all users always.

Here are few links to help you :
http://technet.microsoft.com/en-us/magazine/ff431742.aspx
http://www.sevenforums.com/tutorials/11841-run-administrator.html

Regards,
Lalit
Re: SQL problem [message #598854 is a reply to message #598787] Fri, 18 October 2013 06:50 Go to previous message
saturnel
Messages: 8
Registered: October 2013
Junior Member

ok thanks for all Lalit
Previous Topic: Unsupported Oracle database version
Next Topic: Export to Excel by each group
Goto Forum:
  


Current Time: Sat Jul 26 04:13:03 CDT 2014

Total time taken to generate the page: 0.12045 seconds