Home » RDBMS Server » Enterprise Manager » EMCA repo create fails with Instance Unavailable (Oracle 11g.2.0 on Linux)
EMCA repo create fails with Instance Unavailable [message #597757] Tue, 08 October 2013 05:37
ajirvine
Messages: 1
Registered: October 2013
Location: Glasgow Scotland
Junior Member
I'm on a customer site and attempting to create the em repository.

While running the emca -config dbcontrol db -repos create command I get the following error 'Database Instance Unavailable'. There was permission issues on the sysman user prior to me being onsite so I dropped the repo prior to the attempted create - the -repos drop worked perfectly.

Can anyone help with this as I'm now stuck with what to try.

I've put details of my workings below

When I run the command

chalf002:~ # emca -config dbcontrol db -repos create
STARTED EMCA at 08-Oct-2013 11:29:10
EM Configuration Assistant, Version 11.2.0.0.2 Production
Copyright (c) 2003, 2005, Oracle.  All rights reserved.

Enter the following information:
Database SID: alf
Exception in thread "main" oracle.sysman.emcp.exception.DatabaseUnavailableException: Database instance unavailable.
        at oracle.sysman.emcp.DatabaseChecks.throwDBUnavailableException(DatabaseChecks.java:151)
        at oracle.sysman.emcp.DatabaseChecks.checkDbAvailabilityImpl(DatabaseChecks.java:144)
        at oracle.sysman.emcp.DatabaseChecks.checkDbAvailability(DatabaseChecks.java:163)
        at oracle.sysman.emcp.DatabaseChecks.getDbServiceName(DatabaseChecks.java:582)
        at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:1267)
        at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:573)
        at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:521)[/font] 


Instance is up and available

SQL> select instance_name, status, startup_time from v$instance;

INSTANCE_NAME    STATUS       STARTUP_T
---------------- ------------ ---------
alf              OPEN         09-SEP-13 


And the Database is registered with the listener..

chalf002:~ # lsnrctl status

LSNRCTL for Linux: Version 11.2.0.1.0 - Production on 08-OCT-2013 11:31:33

Copyright (c) 1991, 2009, Oracle.  All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1521)))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for Linux: Version 11.2.0.1.0 - Production
Start Date                09-SEP-2013 19:50:42
Uptime                    28 days 15 hr. 40 min. 51 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Parameter File   /opt/oracle/product/11g/nes_alf/network/admin/listener.ora
Listener Log File         /opt/oracle/diag/tnslsnr/chalf002/listener/alert/log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC1521)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=chalf002.nes.scot.XXX.uk)(PORT=1521)))
Services Summary...
Service "alf.nes.scot.XXX.uk" has 1 instance(s).
  Instance "alf", status READY, has 1 handler(s) for this service...
Service "alfXDB.nes.scot.XXX.uk" has 1 instance(s).
  Instance "alf", status READY, has 1 handler(s) for this service...
The command completed successfully 


The Environmental variables are set as follows.

chalf002:~ # env
ORA_CRS_HOME=/opt/oracle/product/11gR1/crs
HOSTNAME=chalf002
ORACLE_UNQNAME=alf
ORA_ASM_HOME=/opt/oracle/product/11gR1/asm
ORACLE_SID=alf
ORACLE_BASE=/opt/oracle
ORACLE_HOME=/opt/oracle/product/11g/nes_alf
_=/usr/bin/env 


No idea whats going on..

Any help please as this is becoming an issue.

Alison

[Updated on: Tue, 08 October 2013 06:46]

Report message to a moderator

Previous Topic: Server Connection Failed
Next Topic: EM deconfig is taking too long
Goto Forum:
  


Current Time: Tue Sep 30 14:30:04 CDT 2014

Total time taken to generate the page: 0.20658 seconds