Home » SQL & PL/SQL » Client Tools » SQL*Plus not SPOOLing (Windows 7 Enterprise, Oracle 11.2.0.2)
SQL*Plus not SPOOLing [message #592581] Fri, 09 August 2013 13:44 Go to next message
abnk
Messages: 30
Registered: January 2012
Location: US
Member
This is a new install.

This is what I have:

SQL> SPOOL c:\test.txt
SQL> SELECT 1 FROM dual;
         1
----------
         1
SQL> SPOOL OFF
SQL>


When I check C:\, there's nothing. I searched the entire drive.

Any ideas?


Thanks.
Re: SQL*Plus not SPOOLing [message #592582 is a reply to message #592581] Fri, 09 August 2013 13:47 Go to previous messageGo to next message
Michel Cadot
Messages: 59149
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
I did it and it works.
Any ideas?

Regards
Michel
Re: SQL*Plus not SPOOLing [message #592584 is a reply to message #592582] Fri, 09 August 2013 13:50 Go to previous messageGo to next message
abnk
Messages: 30
Registered: January 2012
Location: US
Member
I don't doubt that it works for you. Smile It worked for me too before my Windows 7 install.

[Updated on: Fri, 09 August 2013 13:50]

Report message to a moderator

Re: SQL*Plus not SPOOLing [message #592585 is a reply to message #592582] Fri, 09 August 2013 13:52 Go to previous messageGo to next message
Michel Cadot
Messages: 59149
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
An d to prove I don't lie:
C:\>dir test.txt
 Le volume dans le lecteur C s'appelle System
 Le numéro de série du volume est F0C9-0113

 Répertoire de C:\

Fichier introuvable

C:\>sqlplus michel/michel

SQL*Plus: Release 11.2.0.1.0 Production on Ven. Ao¹t 9 20:49:59 2013

Copyright (c) 1982, 2010, Oracle.  All rights reserved.


Connected to:
Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options

SQL> SPOOL c:\test.txt
SQL> SELECT 1 FROM dual;
         1
----------
         1

1 row selected.

SQL> SPOOL OFF
SQL> exit
Disconnected from Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 -
With the Partitioning, OLAP, Data Mining and Real Application Testing options

C:\>dir test.txt
 Le volume dans le lecteur C s'appelle System
 Le numéro de série du volume est F0C9-0113

 Répertoire de C:\

09/08/2013  20:50                99 test.txt
               1 fichier(s)               99 octets
               0 Rép(s)   8 191 705 088 octets libres

C:\>type test.txt
SQL> SELECT 1 FROM dual;
         1
----------
         1

1 row selected.

SQL> SPOOL OFF

Regards
Michel
Re: SQL*Plus not SPOOLing [message #592588 is a reply to message #592585] Fri, 09 August 2013 14:04 Go to previous messageGo to next message
Littlefoot
Messages: 19630
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
You might not have rights to write to root directory of your C disk (i.e. C:\). Try to spool to C:\users\your_own_directory instead.
Re: SQL*Plus not SPOOLing [message #592599 is a reply to message #592584] Fri, 09 August 2013 15:02 Go to previous messageGo to next message
Lalit Kumar B
Messages: 2348
Registered: May 2013
Location: World Wide on the Web
Senior Member
abnk wrote on Sat, 10 August 2013 00:20
I don't doubt that it works for you. Smile It worked for me too before my Windows 7 install.


Well, I am not sure if it is true in your case, but, with Win7, you need to explicitly select "Run as administrator" for all the tools and applications.
Re: SQL*Plus not SPOOLing [message #592606 is a reply to message #592599] Fri, 09 August 2013 17:00 Go to previous messageGo to next message
abnk
Messages: 30
Registered: January 2012
Location: US
Member
Littlefoot wrote on Fri, 09 August 2013 14:04
You might not have rights to write to root directory of your C disk (i.e. C:\). Try to spool to C:\users\your_own_directory instead.


I will try that. Thank you.

Edited to add: Actually, I have created folders and files in C:\, but I will try that anyway.


Lalit Kumar B wrote on Fri, 09 August 2013 15:02

Well, I am not sure if it is true in your case, but, with Win7, you need to explicitly select "Run as administrator" for all the tools and applications.


I needed an administrator to install Oracle for me, so this might be it. Confused Thank you.

[Updated on: Fri, 09 August 2013 17:04]

Report message to a moderator

Re: SQL*Plus not SPOOLing [message #593154 is a reply to message #592588] Wed, 14 August 2013 11:43 Go to previous message
abnk
Messages: 30
Registered: January 2012
Location: US
Member
Littlefoot wrote on Fri, 09 August 2013 14:04
You might not have rights to write to root directory of your C disk (i.e. C:\). Try to spool to C:\users\your_own_directory instead.


This worked. Thank you. Smile

[Updated on: Wed, 14 August 2013 11:44]

Report message to a moderator

Previous Topic: SQL PLUS Crashes
Next Topic: Sqlplus not found Message file sp1<lang>.msb not found
Goto Forum:
  


Current Time: Mon Sep 22 01:37:14 CDT 2014

Total time taken to generate the page: 0.05327 seconds