Home » Developer & Programmer » Reports & Discoverer » frm-41214 : Unable to run report (oracle 10g)
frm-41214 : Unable to run report [message #590697] Mon, 22 July 2013 05:59 Go to next message
samir2012
Messages: 10
Registered: May 2013
Junior Member
Hi,

I tried to run the report from form in oracle forms 10g,

The following error is coming when I click on Report Button.
frm-41214: unable to run report.

Please help.

Thanks & Regards,
Samir
Re: frm-41214 : Unable to run report [message #590703 is a reply to message #590697] Mon, 22 July 2013 06:22 Go to previous messageGo to next message
samir2012
Messages: 10
Registered: May 2013
Junior Member
I am calling report through Run_Report_object.
Following is my code

DECLARE
 
v_repid REPORT_OBJECT;
v_rep VARCHAR2(100);
v_rep_status VARCHAR2(100);
--v_param VARCHAR2(200) := NULL;
v_valor VARCHAR2(200);
v_url VARCHAR2(2000);
v_repserver varchar2(200) := 'rep_pbannerinb1';
 
v_report varchar2(100) := '/u01/banner/inb/TEST/reports/rdf/GZGCDSC.rdf';

 
BEGIN

v_repid := FIND_REPORT_OBJECT('REPORT206');
SET_REPORT_OBJECT_PROPERTY(v_repid, REPORT_FILENAME, v_report);
SET_REPORT_OBJECT_PROPERTY(v_repid, REPORT_EXECUTION_MODE, BATCH);
SET_REPORT_OBJECT_PROPERTY(v_repid, REPORT_COMM_MODE, SYNCHRONOUS);
SET_REPORT_OBJECT_PROPERTY(v_repid, REPORT_DESTYPE, cache);
SET_REPORT_OBJECT_PROPERTY(v_repid, REPORT_DESFORMAT, 'HTMLCSS' );
SET_REPORT_OBJECT_PROPERTY(v_repid, REPORT_DESNAME, v_report);
SET_REPORT_OBJECT_PROPERTY(v_repid, REPORT_SERVER, v_repserver);
SET_REPORT_OBJECT_PROPERTY(v_repid, REPORT_OTHER, 'paramform=no'||:DUAL.GZGCDSC_ID);
v_rep := RUN_REPORT_OBJECT(v_repid);
v_rep_status := REPORT_OBJECT_STATUS(v_rep);
WHILE v_rep_status IN ('RUNNING','OPENING_REPORT','ENQUEUED') LOOP
v_rep_status := REPORT_OBJECT_STATUS(v_rep);
END LOOP;
IF v_rep_status = 'FINISHED' THEN
message(v_rep);
message(v_rep);
WEB.SHOW_DOCUMENT(v_url||'/reports/rwservlet/getjobid'||
SUBSTR(v_rep, INSTR(v_rep,'_', -1)+1)||'?'||'server='||v_repserver, '_blank');
END IF;
 
END;
Re: frm-41214 : Unable to run report [message #590756 is a reply to message #590703] Mon, 22 July 2013 14:58 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Put URL (you pass to WEB.SHOW_DOCUMENT) into a form item so that you could see how it looks like. Copy/paste it into your browser's address line and run it. What happens?
Re: frm-41214 : Unable to run report [message #590773 is a reply to message #590756] Mon, 22 July 2013 15:56 Go to previous messageGo to next message
samir2012
Messages: 10
Registered: May 2013
Junior Member
I have put the URL under Web.Show_document.I compiled and run it.But the error remains the same.
WEB.SHOW_DOCUMENT('http://pbinb.xxxx.xxx:7777/reports/rwservlet/getjobid'||
SUBSTR(v_rep, INSTR(v_rep,'_', -1)+1)||'?'||'server='||v_repserver, '_blank');


Do I need to add User name and Password also?

Thanks & Regards,
Samir
Re: frm-41214 : Unable to run report [message #590796 is a reply to message #590773] Tue, 23 July 2013 00:18 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
What I meant to say was that you should copy the whole "http://..." line into your browser's address line and go to that address.
Re: frm-41214 : Unable to run report [message #591181 is a reply to message #590796] Thu, 25 July 2013 06:46 Go to previous message
samir2012
Messages: 10
Registered: May 2013
Junior Member
I run the URL in browser. It is displaying Oracle AS Reports Browser Page.

Regards,
Samir
Previous Topic: Error Code ORA-00918 Column ambiguosly defined
Next Topic: Reports to csv
Goto Forum:
  


Current Time: Fri Apr 18 08:46:19 CDT 2014

Total time taken to generate the page: 0.13602 seconds