Home » Infrastructure » Windows » Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 (Oracle 11g R2 Windows 7)
Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 [message #585776] Wed, 29 May 2013 13:50 Go to next message
Robs58
Messages: 15
Registered: May 2013
Junior Member
Greetings to All!

I am totally new to Oracle...TOTALLY new. Right out the gate, I experienced the problem of not being able to start the
DBCONSOLE immediately after installing Oracle 11G R2 onto my Windows 7 box. Here is what I have ran from the command line:


Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\sandifer>emctl start dbconsole
Environment variable ORACLE_UNQNAME not defined. Please set ORACLE_UNQNAME to database unique name.

C:\Users\sandifer>SET ORACLE_HOSTNAME=localhost

C:\Users\sandifer>SET ORACLE_UNQNAME=orcl

C:\Users\sandifer>emctl status dbconsole
OC4J Configuration issue. C:\app\sandifer\product\11.2.0\dbhome_1/oc4j/j2ee/OC4J_DBConsole_localhost_orcl not found.

I checked the above listed file path, and sure enough, OC4J_DBConsole_localhost_orcl is missing.

Would deeply appreciate it if someone would point me in the right direction.

Thanks,

Rob
Re: Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 [message #585777 is a reply to message #585776] Wed, 29 May 2013 14:25 Go to previous messageGo to next message
BlackSwan
Messages: 23157
Registered: January 2009
Senior Member
>OC4J Configuration issue. C:\app\sandifer\product\11.2.0\dbhome_1/oc4j/j2ee/OC4J_DBConsole_localhost_orcl not found.
>I checked the above listed file path, and sure enough, OC4J_DBConsole_localhost_orcl is missing.

what exists instead?
DIR C:\app\sandifer\product\11.2.0\dbhome_1/oc4j/j2ee/OC4J*
Re: Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 [message #585907 is a reply to message #585777] Thu, 30 May 2013 16:53 Go to previous messageGo to next message
Robs58
Messages: 15
Registered: May 2013
Junior Member
j2ee contains the following folders:

home
oc4j_applications
OC4J_DBConsole
OC4J_DBConsole_SANDIFER1.americas.hpqcorp.net_orcl
OC4J_Workflow_Component_Container
OC4J_Workflow_Management_Container
utilities

and also contains the file deploy_db_wf.ini
Re: Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 [message #585909 is a reply to message #585907] Thu, 30 May 2013 18:28 Go to previous messageGo to next message
BlackSwan
Messages: 23157
Registered: January 2009
Senior Member
>OC4J_DBConsole_SANDIFER1.americas.hpqcorp.net_orcl
above indicates that once upon a time the system had a hostname of "SANDIFER1.americas.hpqcorp.net" before it was re-christened "localhost".

you must re-create EM's repository before EM will start for you.
Re: Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 [message #585979 is a reply to message #585909] Fri, 31 May 2013 11:53 Go to previous messageGo to next message
Robs58
Messages: 15
Registered: May 2013
Junior Member
Thank you...

So now my task becomes recreating the repository... It looks as though I will be researching how to do that and come up on the repository
learning curve...

After the repository has been recreated...are there any other steps that I need to perform...or will I then be able to bring up OEM? Thanks!

Regards,

RobS
Re: Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 [message #585983 is a reply to message #585979] Fri, 31 May 2013 12:40 Go to previous messageGo to next message
John Watson
Messages: 4862
Registered: January 2010
Location: Global Village
Senior Member
Hi, Rob - you are doing OK for a beginner! And you have hit one of the most common issues: dbcontrol does not anything that hints of a hostname change. Try this:

emca -deconfig dbcontrol db -repos drop
emca -config dbcontrol db -repos create

And for the full sntax of the utility,

emca -h

Good luck. You'll need it.
Re: Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 [message #595331 is a reply to message #585983] Tue, 10 September 2013 04:09 Go to previous messageGo to next message
8939513598$
Messages: 103
Registered: July 2013
Location: chennai
Senior Member
Hi Rob, the listener must also be started before running EMCA utility.check the listener also, then only creating Enterprise Manager will be correct.
Re: Am unable to start DBCONSOLE after initial installation of Oracle 11g R2 [message #595843 is a reply to message #595331] Sat, 14 September 2013 10:43 Go to previous message
Robs58
Messages: 15
Registered: May 2013
Junior Member
Greetings To All Of You Again,

I apologize for taking so long to get back; I got too busy with my Oracle learning classes and so had to temporarily pause this project of getting
EM to work - but I am back and would very much like to continue this discussion so that I can get this thing up and working properly!

John,

I followed your instructions to rebuild the em; and during the course of doing so, I received the following message:

"SEVERE: Listener is not up or database service is not registered with it. Start the Listener and register database service and run EM C
onfiguration Assistant again ."

I checked the status of the listener and it is running; so do I take this to mean that the database service is not registered with the listener...and if so, is there a proper way to do this? Thanks again!

Regards,

Rob
Previous Topic: Cannot Configure Listener
Next Topic: "Copy a file to DB server from a remote machine using plsql+java"
Goto Forum:
  


Current Time: Sun Dec 21 02:52:23 CST 2014

Total time taken to generate the page: 0.10184 seconds