Home » RDBMS Server » Server Administration » deprecated parameter not in spfile and cannot reset in memory
deprecated parameter not in spfile and cannot reset in memory [message #581966] Fri, 12 April 2013 04:55 Go to next message
onkarbanerjee
Messages: 11
Registered: April 2013
Location: Bangalore
Junior Member
Hi,

i try to startup a database, and get that obsolete/deprecated parameter specified(ORA-32004: obsolete and/or deprecated parameter(s) specified)
so i try to reset the parameter, but it seems it is already reset(not in spfile), so maybe this is in memory. SO now i try to reset with scope = memory or both, it gives this error(ORA-32029: resetting with SCOPE=MEMORY or SCOPE=BOTH is currently not supported).

Please advise , what to do, because now i cannot reset with scope = memory and in spfile it is not there but still it comes in deprecated parameter.
Re: deprecated parameter not in spfile and cannot reset in memory [message #581967 is a reply to message #581966] Fri, 12 April 2013 04:58 Go to previous messageGo to next message
John Watson
Messages: 4555
Registered: January 2010
Location: Global Village
Senior Member
Which parameter?
Re: deprecated parameter not in spfile and cannot reset in memory [message #581968 is a reply to message #581967] Fri, 12 April 2013 05:00 Go to previous messageGo to next message
onkarbanerjee
Messages: 11
Registered: April 2013
Location: Bangalore
Junior Member
Deprecated system parameters with specified values:
log_archive_start
End of deprecated system parameter listing
Re: deprecated parameter not in spfile and cannot reset in memory [message #581969 is a reply to message #581968] Fri, 12 April 2013 05:04 Go to previous messageGo to next message
John Watson
Messages: 4555
Registered: January 2010
Location: Global Village
Senior Member
Are you using an spfile, and is that parameter specified?
sho parameter spfile
select isspecified,value from v$spparameter where name='log_archive_start';

--
update: typo

[Updated on: Fri, 12 April 2013 05:05]

Report message to a moderator

Re: deprecated parameter not in spfile and cannot reset in memory [message #581970 is a reply to message #581969] Fri, 12 April 2013 05:06 Go to previous messageGo to next message
onkarbanerjee
Messages: 11
Registered: April 2013
Location: Bangalore
Junior Member
yes using spfile and valie is false actually, so maybe need to make it true.
SQL> show parameter log_archive_start;

NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
log_archive_start boolean FALSE


and v$spparamter not exist it says,

Re: deprecated parameter not in spfile and cannot reset in memory [message #581972 is a reply to message #581970] Fri, 12 April 2013 05:09 Go to previous messageGo to next message
John Watson
Messages: 4555
Registered: January 2010
Location: Global Village
Senior Member
Please read How to use [code] tags and make your code easier to read and in future format your copy/pastes correctly. You didn't post the results of the query I asked you to run, but it would seem that you are not using an spfile. This is why your commands to reset the parameter fail. So find your pfile, and edit the parameter out of that.

Re: deprecated parameter not in spfile and cannot reset in memory [message #581984 is a reply to message #581972] Fri, 12 April 2013 07:23 Go to previous messageGo to next message
onkarbanerjee
Messages: 11
Registered: April 2013
Location: Bangalore
Junior Member
Hi John,

The DB is using SPFILE only and value of log_archive_start parameter was false only as i had mentioned previously, however i think i might have copied your sql wrongly in a hurry and posted that the v$spparameter not exist,whereas the it was existing, meaning to say the value was FALSE in it also, sorry for the miscommunication(was in a kind of a hurry for something).

Anyways, issue got resolved though by doing nothing about log_archive_start parameter value but now it got reset(did the same thing in the morning, but it wouldnt reset then, probably made a mistake then even)
>alter system reset log_archive_start scope=spfile sid='*';


ANyways, it solved now, and Thanks Smile
Re: deprecated parameter not in spfile and cannot reset in memory [message #581990 is a reply to message #581984] Fri, 12 April 2013 07:45 Go to previous message
Michel Cadot
Messages: 59105
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
value of log_archive_start parameter was false


This parameter is ignored in the current versions.

Regards
Michel
Previous Topic: Database Cold Cloning
Next Topic: Arabic language problem
Goto Forum:
  


Current Time: Wed Sep 17 07:12:24 CDT 2014

Total time taken to generate the page: 0.05683 seconds