Home » Developer & Programmer » Reports & Discoverer » REP-1401: 'afterpform': Fatal PL/SQL error occurred. (Report Builder 10.1.2.0.2)
REP-1401: 'afterpform': Fatal PL/SQL error occurred. [message #578866] Wed, 06 March 2013 00:30 Go to next message
marriswamy
Messages: 6
Registered: October 2011
Location: hydrabad
Junior Member
Hi,
i am getting below error while running Aging report.
Enter Password:
MSG-01001: inside beforepform
MSG-00100: p_reporting_level = p_reporting_entity_id =
MSG-00100: Get_Predicate calls complete
REP-1401: 'afterpform': Fatal PL/SQL error occurred.

this is my code in After parameter.



srw.message('100','Get_Predicate calls complete');

:p_reporting_entity_name := substrb(XLA_MO_REPORTING_API.get_reporting_entity_name,1,80);
srw.message('100','p_reporting_entity_name'||:p_reporting_entity_name);
:p_reporting_level_name := substrb(XLA_MO_REPORTING_API.get_reporting_level_name,1,30);
srw.message('100','p_reporting_entity_name'||:p_reporting_level_name);

if :p_in_customer_name_low is not null then
--:lp_customer_name_low := ' and cust.customer_name || '''' >= :p_in_customer_name_low '; --R12
:lp_customer_name_low := ' and hp.party_name || '''' >= :p_in_customer_name_low ';
end if;

if :p_in_customer_name_high is not null then
-- :lp_customer_name_high := ' and cust.customer_name || '''' <= :p_in_customer_name_high '; --R12
:lp_customer_name_high := ' and hp.party_name || '''' <= :p_in_customer_name_high ';
end if;


if :p_in_customer_num_low is not null then
-- :lp_customer_num_low := ' and cust.customer_number || '''' >= :p_in_customer_num_low '; --R12
:lp_customer_num_low := ' and hca.account_number || '''' >= :p_in_customer_num_low ';
end if;

if :p_in_customer_num_high is not null then
-- :lp_customer_num_high := ' and cust.customer_number || '''' <= :p_in_customer_num_high '; --R12
:lp_customer_num_high := ' and hca.account_number || '''' <= :p_in_customer_num_high ';
end if;

srw.message('103','Done setting Customer Name and Number');

if :p_in_Invoice_type_low is not null then
:lp_invoice_type_low := ' and ctt.name >= :p_in_invoice_type_low ';
end if;

if :p_in_Invoice_type_high is not null then
:lp_invoice_type_high := ' and ctt.name <= :p_in_invoice_type_high ';


if :p_rep_type in ('ARXAGL','ARXAGR') then
:p_label := ARP_STANDARD.fnd_message(:p_rep_type||'_LABEL');








-- :lp_agfs_where2 := ' and ps.customer_id+0 = cust.customer_id ' || --R12
:lp_agfs_where2 := ' and ps.customer_id+0 = hca.cust_account_id ' ||


:lp_agfs_where3 := 'and ps.cust_trx_type_id+0=ctt.cust_trx_type_id ' ||
-- 'and ps.customer_id+0=cust.customer_id ' || --R12


-- :lp_agfs_where4 := ' and ps.customer_id+0 = cust.customer_id ' ||--R12
:lp_agfs_where4 := ' and ps.customer_id+0 = hca.cust_account_id ' ||



-- define generic lexical parameters for use in both ARXAGL and ARXAGR
----------------------------------------------------------------------
if (:p_rep_type in('ARXAGL','ARXAGR')) then
-- :lp_aglr_where1 := ' and ps.customer_id = cust.customer_id '; --R12
:lp_aglr_where1 := ' and ps.customer_id = hca.cust_account_id ';

end if;



--:lp_agl_where1 := ' and cust_cp.customer_id = cust.customer_id '||
:lp_agl_where1 := ' and cust_cp.customer_id = hca.cust_account_id '|
Re: REP-1401: 'afterpform': Fatal PL/SQL error occurred. [message #578867 is a reply to message #578866] Wed, 06 March 2013 00:35 Go to previous messageGo to next message
marriswamy
Messages: 6
Registered: October 2011
Location: hydrabad
Junior Member
Hi ,

Anybody can help me on this error.
Re: REP-1401: 'afterpform': Fatal PL/SQL error occurred. [message #578870 is a reply to message #578867] Wed, 06 March 2013 00:57 Go to previous messageGo to next message
Littlefoot
Messages: 19824
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
You got the message "MSG-00100: Get_Predicate calls complete". The next 2 executable lines are
:p_reporting_entity_name := substrb(XLA_MO_REPORTING_API.get_reporting_entity_name,1,80);

srw.message('100','p_reporting_entity_name'||:p_reporting_entity_name);

As you didn't get the next message ("p_reporting_entity_name"), I'd say that error occured in the first line I posted above, here:
substrb(XLA_MO_REPORTING_API.get_reporting_entity_name,1,80)

I'm not familiar with a function your used here (XLA_whatever) so I can't tell whether it is responsible for the error or not.

On the other hand, as this looks like an Oracle Apps. question, maybe someone - who knows it - will be able to assist better than me.
Re: REP-1401: 'afterpform': Fatal PL/SQL error occurred. [message #578874 is a reply to message #578867] Wed, 06 March 2013 01:12 Go to previous message
marriswamy
Messages: 6
Registered: October 2011
Location: hydrabad
Junior Member
Hi team,

Could You please any solution on this?

thanks
Swamy
Previous Topic: web source
Next Topic: convert report to image programmatically
Goto Forum:
  


Current Time: Sat Nov 29 02:53:30 CST 2014

Total time taken to generate the page: 0.20953 seconds