Home » SQL & PL/SQL » Client Tools » Facing issue with & character while running compilation script (Oracle 11g)
Facing issue with & character while running compilation script [message #578334] Wed, 27 February 2013 01:45 Go to next message
Manoj.Gupta.91
Messages: 186
Registered: March 2008
Location: Delhi
Senior Member
Hi All,

I've all packages, procedures and functions in separate .sql files. I've created a driver script for that which runs each file on SQL prompt in Windows DOS. But in some of the procedures & character is present in comments. It is creating problem in execution. Whenever & character is found it asks to enter a value and procedure is not compiled properly.

Is there a way to ignore & character while compilation?

Thanks & Regards
Manoj
Re: Facing issue with & character while running compilation script [message #578335 is a reply to message #578334] Wed, 27 February 2013 01:52 Go to previous messageGo to next message
delna.sexy
Messages: 941
Registered: December 2008
Location: Surat, The Diamond City
Senior Member
did you try

SET DEFINE OFF

?

regards,
Delna
Re: Facing issue with & character while running compilation script [message #578350 is a reply to message #578335] Wed, 27 February 2013 03:54 Go to previous message
Manoj.Gupta.91
Messages: 186
Registered: March 2008
Location: Delhi
Senior Member
Hi,

I tried it and it solve my problem

Thanks alot.

Regards
Manoj
Previous Topic: Where can i download SQL*Plus?
Next Topic: load tables from sql server to oracle
Goto Forum:
  


Current Time: Fri Apr 18 16:10:17 CDT 2014

Total time taken to generate the page: 0.18857 seconds