Home » Developer & Programmer » Forms » Difficult photo question (Forms 10g)
Difficult photo question [message #576479] Tue, 05 February 2013 07:24 Go to next message
ahazin
Messages: 39
Registered: August 2010
Member
Hi guys, Ive had an issue with one of my forms for a few months now and have exhausted any ideas I have had in regards to fixing it. I am using oracle forms 10g and basically we have a system that takes over 300 photos on a daily basis, this all works fine and with no issues except for say maybe 2-3 photos a month. Occasionally we will get a 'corrupt photo' (it not actually corrupt, it displays in everything as it should except forms) . When we encounter these photos forms just crashes out and the user is unable to query the record with the associated photo until it is deleted and a new one is taken (or alternatively if we take the photo from the database open it in paint.net and just hit save it will then work). There is no difference that we can see in the photo which doesnt work and those that do work. I have tried using WRITE_IMAGE_FILE to save the photo to disk and Read_Image_File to read from the disk to see if that makes a difference. If i save the file as jpeg and no compression it still crashes, if i save it with low compression it works fine but we lose quality which we dont want to lose. Bitmap wont work at all. Saving as JFIF and GIF works fine without any compression but we still lose quality.

The photo will display fine if we use a javabean to display it but in this instance a javabean is not an option.

One weird thing we noticed is that when we are on the form that crashes with these photos and query back a working photo first, and THEN query the 'corrupt photo' the corrupt photo displays fine, but if we go into the form and query a corrupt photo first forms crashes as explained.

This is driving me crazy and any help would be GREATLY appreciated.



Re: Difficult photo question [message #576480 is a reply to message #576479] Tue, 05 February 2013 07:31 Go to previous message
cookiemonster
Messages: 10914
Registered: September 2008
Location: Rainy Manchester
Senior Member
Have you tried raising this with oracle support?
Previous Topic: Error when run report
Next Topic: Disabled list item will be enabled accordingly just by clicking.
Goto Forum:
  


Current Time: Wed Aug 27 18:32:43 CDT 2014

Total time taken to generate the page: 0.12651 seconds