Home » Developer & Programmer » Forms » FRM-41214 Unable to run the report!!! Please help (Oracle Forms 10g)
FRM-41214 Unable to run the report!!! Please help [message #572862] Tue, 18 December 2012 04:08 Go to next message
Kaustubh_30
Messages: 1
Registered: December 2012
Junior Member
We have a integration with rightfax to send fax from our application.
We have recently upgraded from oracle 6i to 10g.

When we try to click on the send fax button, we are getting an error FRM-41214 Unable to run the report
When send fax button is clicked, desired report opens up in a new tab with the correct data but I am not sure why this error is occuring.

Also,I went through the forum based on the above error, and have made most of the changes suggested by users but still the error exists.

Please help

Below is the code we are using
---Called on click of button
PROCEDURE REPORT_PROC IS
pl_id paramlist;

BEGIN
pl_id := get_parameter_list('TEMPDATA');

IF not id_null(pl_id) THEN
destroy_parameter_list(pl_id);
END IF;

pl_id := create_parameter_list('TEMPDATA');

ADD_PARAMETER(PL_ID,'P_UNIQUE_NUM',TEXT_PARAMETER,NAME_IN('PARA_UNIQUE_NUM'));
ADD_PARAMETER(PL_ID,'ARRAYSIZE',TEXT_PARAMETER,'45');
ADD_PARAMETER(PL_ID,'RUNDEBUG',TEXT_PARAMETER,'NO');
ADD_PARAMETER(PL_ID,'P_DESTINATION',TEXT_PARAMETER,:ctl_rpt.fax_number);
ADD_PARAMETER(PL_ID,'PARAMFORM',TEXT_PARAMETER,'NO');
ADD_PARAMETER(PL_ID,'BACKGROUND',TEXT_PARAMETER,'YES');

run_report_proc('report0001',pl_id);

END;
--called internally within the code
PROCEDURE RUN_REPORT_PROC(P_report_name IN VARCHAR2, P_PL_ID IN PARAMLIST) IS
repid REPORT_OBJECT;
jobidfull VARCHAR2(100);
jobidpart VARCHAR2(100);
repserver VARCHAR2(100);
rep_status VARCHAR2(20) DEFAULT '#';

/* GET These settings from the database table */

protocol VARCHAR2(10);
hostname VARCHAR2(50);
domain VARCHAR2(50);
port VARCHAR2(10);
virtual_dir VARCHAR2(200);

BEGIN
repid := FIND_REPORT_OBJECT('rp2rro');
GET_REPSERVER_SETTINGS(protocol,hostname,domain,port,repserver);

SET_REPORT_OBJECT_PROPERTY(repid, REPORT_EXECUTION_MODE, BATCH);
SET_REPORT_OBJECT_PROPERTY(repid, REPORT_COMM_MODE, SYNCHRONOUS);
SET_REPORT_OBJECT_PROPERTY(repid, REPORT_DESFORMAT, 'PDF');
SET_REPORT_OBJECT_PROPERTY(repid, REPORT_SERVER, repserver);
SET_REPORT_OBJECT_PROPERTY(repid, REPORT_FILENAME, P_report_name);
jobidfull := RUN_REPORT_OBJECT(repid, p_pl_id);
jobidPart := substr(jobidFull,length(repserver)+2,length(jobidFull));
virtual_dir := protocol || hostname || '.' || domain ||':'|| port;
web.show_document(virtual_dir||'/reports/rwservlet/getjobid'||jobidPart||'?server='||repserver,'_blank');

END;
Re: FRM-41214 Unable to run the report!!! Please help [message #573182 is a reply to message #572862] Sun, 23 December 2012 03:20 Go to previous message
Medo
Messages: 17
Registered: December 2012
Location: Qatar
Junior Member
Dear
I'm not exp. but
what you mean by run_report_proc
if you mean your procedure you have to remove run_

Form 10g
hopfully this help
regards
Previous Topic: PrtSn into Database Field
Next Topic: Port Number
Goto Forum:
  


Current Time: Sun Apr 20 04:38:47 CDT 2014

Total time taken to generate the page: 0.07736 seconds