Home » RDBMS Server » Backup & Recovery » RMAN-04002: ocipi failed, ORA--1
RMAN-04002: ocipi failed, ORA--1 [message #567562] Wed, 03 October 2012 06:02 Go to next message
neetesh87
Messages: 280
Registered: September 2011
Location: bhopal
Senior Member
hello experts,

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users>rman

Recovery Manager: Release 10.2.0.1.0 - Production on Wed Oct 3 16:24:38 2012

Copyright (c) 1982, 2005, Oracle. All rights reserved.

RMAN> connect target sys/@proddb

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-04002: ocipi failed, ORA--1

when i try to connect with the prod database by logging in the server,
then it raise the above error.

i want to aware you with what i have done before it--

(1) this database is running on the port 1526 not on 1521,
because of some reason new listner have to made.

(2) i can easily access this database without any error from my local machine, then
it doesnot raise-ORA-12154: TNS:could not resolve the connect identifier specified


now i am going to take backup from RMAN at my local machine of same database , then

C:\Users\Neetesh>rman target /@proddb

Recovery Manager: Release 11.2.0.1.0 - Production on Wed Oct 3 16:29:47 2012

Copyright (c) 1982, 2009, Oracle and/or its affiliates. All rights reserved.

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-00554: initialization of internal recovery manager package failed
RMAN-04005: error from target database:
ORA-12154: TNS:could not resolve the connect identifier specified

C:\Users\Neetesh>


thanks in advance....
Re: RMAN-04002: ocipi failed, ORA--1 [message #567567 is a reply to message #567562] Wed, 03 October 2012 06:16 Go to previous messageGo to next message
Michel Cadot
Messages: 58605
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-12154: TNS:could not resolve the connect identifier specified
 *Cause:  A connection to a database or other service was requested using
 a connect identifier, and the connect identifier specified could not
 be resolved into a connect descriptor using one of the naming methods
 configured. For example, if the type of connect identifier used was a
 net service name then the net service name could not be found in a
 naming method repository, or the repository could not be
 located or reached.
 *Action:
   - If you are using local naming (TNSNAMES.ORA file):
      - Make sure that "TNSNAMES" is listed as one of the values of the
        NAMES.DIRECTORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA)
      - Verify that a TNSNAMES.ORA file exists and is in the proper
        directory and is accessible.
      - Check that the net service name used as the connect identifier
        exists in the TNSNAMES.ORA file.
      - Make sure there are no syntax errors anywhere in the TNSNAMES.ORA
        file.  Look for unmatched parentheses or stray characters. Errors
        in a TNSNAMES.ORA file may make it unusable.
   - If you are using directory naming:
      - Verify that "LDAP" is listed as one of the values of the
        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA).
      - Verify that the LDAP directory server is up and that it is
        accessible.
      - Verify that the net service name or database name used as the
        connect identifier is configured in the directory.
      - Verify that the default context being used is correct by
        specifying a fully qualified net service name or a full LDAP DN
        as the connect identifier
   - If you are using easy connect naming:
      - Verify that "EZCONNECT" is listed as one of the values of the
        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA).
      - Make sure the host, port and service name specified
        are correct.
      - Try enclosing the connect identifier in quote marks.

   See the Oracle Net Services Administrators Guide or the Oracle
   operating system specific guide for more information on naming.

Regards
Michel
Re: RMAN-04002: ocipi failed, ORA--1 [message #567578 is a reply to message #567567] Wed, 03 October 2012 07:03 Go to previous messageGo to next message
neetesh87
Messages: 280
Registered: September 2011
Location: bhopal
Senior Member
thanks sir,
i have updated my local TNSNAMES.ORA file and now i can connect with the PRODDB from my local machine.

but i am not able to connect with this database by logging in the host machine(server) of this database.

it raise following error:-
RMAN-04002: ocipi failed, ORA--1

please tell me sir.

thanks again...
Re: RMAN-04002: ocipi failed, ORA--1 [message #567585 is a reply to message #567578] Wed, 03 October 2012 07:34 Go to previous messageGo to next message
Michel Cadot
Messages: 58605
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
There is a problem in the RMAN data, raise a SR to Oracle.

Regards
Michel
Re: RMAN-04002: ocipi failed, ORA--1 [message #567597 is a reply to message #567585] Wed, 03 October 2012 07:58 Go to previous messageGo to next message
neetesh87
Messages: 280
Registered: September 2011
Location: bhopal
Senior Member
SR means call to oracle support, am i right?

Re: RMAN-04002: ocipi failed, ORA--1 [message #567598 is a reply to message #567597] Wed, 03 October 2012 07:59 Go to previous messageGo to next message
Michel Cadot
Messages: 58605
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Yes, this is what it means: SR=Service Request.

Regards
Michel
Re: RMAN-04002: ocipi failed, ORA--1 [message #567604 is a reply to message #567598] Wed, 03 October 2012 08:10 Go to previous messageGo to next message
neetesh87
Messages: 280
Registered: September 2011
Location: bhopal
Senior Member
ok thanks sir,
i want to ask one more thing that, it is just because of creating the new listner on new port
and deleting the default listner.
Re: RMAN-04002: ocipi failed, ORA--1 [message #567606 is a reply to message #567604] Wed, 03 October 2012 08:12 Go to previous messageGo to next message
Michel Cadot
Messages: 58605
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
This seems to have no relation with the listener.

Regards
Michel
Re: RMAN-04002: ocipi failed, ORA--1 [message #567611 is a reply to message #567606] Wed, 03 October 2012 08:29 Go to previous messageGo to next message
BlackSwan
Messages: 22517
Registered: January 2009
Senior Member
>i want to ask one more thing that, it is just because of creating the new listner on new port
>and deleting the default listner.

It appears you broke a working configuration.
Why do you think a new listener is required on a different port?

Only ever 1 listener is required; which can support multiple DBs on different ORACLE_HOME, & even different ports.
Since you broke it, I suggest that you fix it.
Re: RMAN-04002: ocipi failed, ORA--1 [message #567619 is a reply to message #567611] Wed, 03 October 2012 09:59 Go to previous messageGo to next message
neetesh87
Messages: 280
Registered: September 2011
Location: bhopal
Senior Member
thanks to all,

>>It appears you broke a working configuration.
>>Why do you think a new listener is required on a different port?

sir,
can i rollback my work now,if yes then how?


>>Only ever 1 listener is required; which can support multiple DBs on different ORACLE_HOME, & even different ports.
>>Since you broke it, I suggest that you fix it.

means sir, we can configure one listner at different-different port?


thanks....
Re: RMAN-04002: ocipi failed, ORA--1 [message #567621 is a reply to message #567619] Wed, 03 October 2012 10:35 Go to previous messageGo to next message
BlackSwan
Messages: 22517
Registered: January 2009
Senior Member
TRACE_LEVEL_LISTENER = 0
SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (GLOBAL_DBNAME = VM)
      (ORACLE_HOME = C:\oracle\product\10.2.0)
      (SID_NAME = VM)
    )
    (SID_DESC =
      (GLOBAL_DBNAME = LT)
      (ORACLE_HOME = C:\oracle\product\10.2.0)
      (SID_NAME = LT)
    )
    (SID_DESC =
      (GLOBAL_DBNAME = LT2)
      (ORACLE_HOME = C:\oracle\product\10.2.0)
      (SID_NAME = LT2)
    )
    (SID_DESC =
      (GLOBAL_DBNAME = VM11)
      (ORACLE_HOME = C:\Oracle\Product\11.1.0)
      (SID_NAME = VM11)
    )
    (SID_DESC =
      (GLOBAL_DBNAME = VMTEST)
      (ORACLE_HOME = C:\Oracle\Product\11.1.0)
      (SID_NAME = VMTEST)
    )
  )
 
LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = 192.185.50.51)(PORT = 1521))
      (ADDRESS = (PROTOCOL = TCP)(HOST = 192.185.50.51)(PORT = 1526))
    )
  )
 
Re: RMAN-04002: ocipi failed, ORA--1 [message #567626 is a reply to message #567562] Wed, 03 October 2012 11:22 Go to previous message
John Watson
Messages: 4400
Registered: January 2010
Location: Global Village
Senior Member
You are using different versions of the RMAN executable. Your first attempt was release 10.2.0.1.0, your second attempt was 11.2.0.1. You cannot do this: you must use te version that correspionds with the release of the database.
Previous Topic: ORA-01031: insufficient privileges with RMAN
Next Topic: RMAN - archivelog deletion policy not working.
Goto Forum:
  


Current Time: Mon Jul 28 21:11:05 CDT 2014

Total time taken to generate the page: 0.12638 seconds