Home » Server Options » RAC & Failsafe » PRECONNECT vs BASIC (10.2.0.1)
PRECONNECT vs BASIC [message #567307] Wed, 26 September 2012 06:51
piotrtal
Messages: 152
Registered: June 2011
Location: Poland/Czestochowa
Senior Member

hi,

i expected that if i define service with TAF BASIC policy there is not possible to connect to this service with TAF PRECONNECT policy, but i failed.

this is my entry in tnsname.

CDBS1_TAF =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = rac1-vip)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = piodbserv2.world)
      (INSTANCE_NAME = piodb1)
      (FAILOVER_MODE=
      (BACKUP=CDBS2_TAF)
      (TYPE=SELECT)
      (METHOD=PRECONNECT)
     )
    )
  )


CDBS2_TAF =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = rac2-vip)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = piodbserv2.world)
      (INSTANCE_NAME = piodb2)
      (FAILOVER_MODE=
      (BACKUP=CDBS1_TAF)
      (TYPE=SELECT)
      (METHOD=PRECONNECT)
     )
    )
  )


and this is my log session:

[oracle@rac1 ~]$ srvctl config service -d piodb -s piodbserv2  -a
piodbserv2 PREF: piodb1 piodb2 AVAIL:  TAF: BASIC

SQL> SELECT inst_id, sid, serial#, username, failover_type, failover_method, service_name FROM gv$session
  2  WHERE username = 'PIOTRTAL'
  3  ;
 
   INST_ID        SID    SERIAL# USERNAME                       FAILOVER_TYPE FAILOVER_METHOD SERVICE_NAME
---------- ---------- ---------- ------------------------------ ------------- --------------- ----------------------------------------------------------------
         1        148        412 PIOTRTAL                       SELECT        PRECONNECT      piodbserv2
         2        142        144 PIOTRTAL                       NONE          NONE            piodbserv2
 



why do i have two session and connection is made using PRECONNECT method instead of BASIC. i remind you that this service TAF policy is set as BASIC.

thanks in advance
Previous Topic: Fail Safe multi-subnet
Next Topic: Bad magic number in superblock while opening device
Goto Forum:
  


Current Time: Tue Sep 30 01:38:27 CDT 2014

Total time taken to generate the page: 0.12992 seconds