Home » RDBMS Server » Server Utilities » Impdp - Packge Body Import taking Huge Time (Oracle 11R2, HP Unix)
Impdp - Packge Body Import taking Huge Time [message #566396] Thu, 13 September 2012 23:46 Go to next message
sap_arul
Messages: 27
Registered: November 2005
Location: BANGALORE
Junior Member
Hi,

I am try to import 4G dump in Oracle 11R2 version, in that we have around 9000+ Package Body which is taking huge time than other objects (about 8 to 12 hrs) and also it is expecting lots of system space (roughly about 10GB).

I have tried both parallel and non-parallel.

Please advice, how to improve speed of the package body import.

Details about the Schema & Import

No. of objects in Schema
SQL> select object_type,count(1) from user_objects GROUP BY ROLLUP( object_type);

OBJECT_TYPE           COUNT(1)
------------------- ----------
FUNCTION                   248
INDEX                     5161
JAVA CLASS                 471
JAVA RESOURCE                1
JAVA SOURCE                 16
LIBRARY                      1
LOB                        131
MATERIALIZED VIEW            1
PACKAGE                   9605
PACKAGE BODY              9526
PROCEDURE                  491

OBJECT_TYPE           COUNT(1)
------------------- ----------
SEQUENCE                 17684
SYNONYM                  15699
TABLE                     5795
TABLE PARTITION             18
TRIGGER                    377
TYPE                       105
VIEW                      2707
                         68037


Impdp Parameter
userid=USERID/PASSWORD
logfile=IMPORT.LOG
dumpfile = DATA_FINAL.DMP
directory=IMPORT_DUMP_DIR 
job_name = IMPORT_JOB_imp
REMAP_TABLESPACE = SOURCE:DEST
remap_schema = SOURCE:DEST
EXCLUDE=GRANT,STATISTICS



Regards,
Arul.
Re: Impdp - Packge Body Import taking Huge Time [message #566410 is a reply to message #566396] Fri, 14 September 2012 04:50 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10629
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Please post the parameters used with expdp and log.
Re: Impdp - Packge Body Import taking Huge Time [message #566981 is a reply to message #566396] Fri, 21 September 2012 14:34 Go to previous messageGo to next message
LKBrwn_DBA
Messages: 440
Registered: July 2003
Location: WPB, FL
Senior Member
What Mahesh is looking for is: if you used the "CONTENT=METADATA_ONLY" for your export.
Othewise (if you did full/schema export) then impdp has to read the full dump file even if it will not import the data or anything else.

Now, if you want to speed the import of procedures/packages, use the said export parameter and take another export.

[Updated on: Fri, 21 September 2012 14:47] by Moderator

Report message to a moderator

Re: Impdp - Packge Body Import taking Huge Time [message #569457 is a reply to message #566981] Fri, 26 October 2012 08:06 Go to previous message
sap_arul
Messages: 27
Registered: November 2005
Location: BANGALORE
Junior Member
Hi Mahesh,

We have taken full backup, didnt mention Metadata_only option.

This is my export parameter.

DIRECTORY=EXPIMP 
DUMPFILE=DATA_FINAL.DMP
LOGFILE=DATA_FINAL.LOG 
SCHEMAS=SOURCE


Regards,Arul
Previous Topic: SERVICE NAME vs NET SERVICE NAME
Next Topic: About sql loader
Goto Forum:
  


Current Time: Sat Oct 25 00:37:50 CDT 2014

Total time taken to generate the page: 0.08286 seconds