Home » Server Options » Streams & AQ » Streams propagate error (Oracle 10g 10.2.0)
Streams propagate error [message #565262] Sun, 02 September 2012 07:35
genmadow
Messages: 1
Registered: September 2012
Junior Member
Hi All,
I'm somehow newbie in Oracle, we have Oracle Stream working between Production DB/server "source" (Oracle 10g "10.2.0", Win server 2003 64 bit, 16 GB RAM memory) and a reporting DB/server "target" (Oracle 10g "10.2.0", Win server 2003 32 bit, 3 GB RAM memory), The streams was working fine between them form the source DB/server to the target DB/server for a long of time, we were used to make this setup easily with no problems, until we decided to re-setup the Oracle Stream again between these 2 servers because of some improper human intervention in the target db, we made the regular setup steps, and run the streams for the first time after this Stream re-setup, the Capture process changed status form "Capturing Changes" to "Paused for Flow Control" and we suddenly got this error in the Propagate process:

ORA-04030: out of process memory when trying to allocate bytes (,)

And nothing is moved from the Capture to Apply.

The weirdest thing is that we didn't change anything in the servers or the streams setup scripts however no mass changes in the replicated data.
I surfed the Internet and found that I had to increase those 2 parameters:
1- pga_aggregate_target Increased it form 500 MB to 1 GB. (on the source server)
2- STREAMS_POOL_SIZE increased form 500MB to 750MB. (on the source server)

PS: The Capture and Propagate processes are on the Production (source) server and the Apply process is on the Reporting (target) server...
I really appreciate your kind help.
Thanks in advance...
Previous Topic: Oracle Streams 11g , not working
Next Topic: Capture logminer process very slow
Goto Forum:
  


Current Time: Wed Oct 22 08:52:13 CDT 2014

Total time taken to generate the page: 0.09546 seconds