Home » Server Options » RAC & Failsafe » downgrade problem (11gR2 on Linux)
downgrade problem [message #564042] Mon, 20 August 2012 13:54 Go to next message
bruce_odo
Messages: 6
Registered: August 2012
Location: London
Junior Member
Hi, please I need help. I wanted to downgrade our 2 node RAC 11.2.0.3 to previous version11.2.0.2 on our test environment, so i could prepare to upgrade production later.
I followed oracle documentation and issued '/u01/app/11.2.0.3/grid/crs/install/rootcrs.pl -downgrade -oldcrshome /u01/app/11.2.0/grid -version 11.2.0.2.0' and both nodes and manually removed file in upgraded oracle home (rm -r u01/app/11.2.0.3).

This seems to have caused havoc and ASM and srvctl are no working. lsinvemntory lsinventory still poitns to removed oracle 11.2.0.3

I tried to set

export ORACLE_HOME=$ORACLE_HOME
.oraenv
+ASM1
srvctl config ##n

srvctl config
PRCR-1119 : Failed to look up CRS resources of database type
PRCR-1115 : Failed to find entities of type resource that match filters (TYPE == ora.database.type) and contain attributes DB_UNIQUE_NAME,ORACLE_HOME,VERSION
Cannot communicate with crsd
###
Any help how to proceed in downgrading to 11.2.0.2 please?
Re: downgrade problem [message #564043 is a reply to message #564042] Mon, 20 August 2012 14:02 Go to previous messageGo to next message
John Watson
Messages: 4515
Registered: January 2010
Location: Global Village
Senior Member
Welcome to the forum. Please read our OraFAQ Forum Guide and How to use [code] tags and make your code easier to read

I can't advise on your downgrade because I've never tried to do it. However, there are some clear mistakes in what you have posted:

This,
export ORACLE_HOME=$ORACLE_HOME
will achieve nothing. You should use the oraenv script to set you environment instead. But this,
.oraenv
will not set your environment because you have missed a space between the dot and the file name.
Re: downgrade problem [message #564044 is a reply to message #564043] Mon, 20 August 2012 15:07 Go to previous messageGo to next message
bruce_odo
Messages: 6
Registered: August 2012
Location: London
Junior Member
sorry, it was a typo error while i was pasting here. The environment was set properly. Issue is just the fact that oracle inventory still points to deleted 11.2.0.3

export ORACLE_HOME=/u01/app/11.2.0/grid
. oraenv
ORACLE_SID = [grid] ? +ASM1
The Oracle base has been set to /u01/app/grid
olsnodes
PRCO-19: Failure retrieving list of nodes in the cluster
PRCO-2: Unable to communicate with the clusterware
.
.
asmcmd
Connected to an idle instance.
ASMCMD> ls
ASMCMD-08102: no connection to ASM; command requires ASM to run
ASMCMD> exit

Re: downgrade problem [message #564047 is a reply to message #564044] Mon, 20 August 2012 16:08 Go to previous messageGo to next message
John Watson
Messages: 4515
Registered: January 2010
Location: Global Village
Senior Member
The inventory will be aware of both versions. You need to confirm which Oracle Home you are connected to, so echo $PATH and $ORACLE_HOME. And please read the guidelines, and use copy/paste with [code] tags to show the result. If you want to know what release is currently running, use
crsctl query crs activeversion
crsctl query crs releaseversion
crsctl query crs softwareversion


Re: downgrade problem [message #564064 is a reply to message #564047] Tue, 21 August 2012 03:17 Go to previous messageGo to next message
bruce_odo
Messages: 6
Registered: August 2012
Location: London
Junior Member
Thanks for you response. Please find attached the output
  • Attachment: upload.txt
    (Size: 0.66KB, Downloaded 71 times)
Re: downgrade problem [message #564069 is a reply to message #564064] Tue, 21 August 2012 03:45 Go to previous messageGo to next message
John Watson
Messages: 4515
Registered: January 2010
Location: Global Village
Senior Member
It wold be polite to follow the guidelines, and use copy/paste formatted with [code] tags when you want to post something.
It looks as though you haven't actually started any of the clusterware processes. What happens when you try to start them? And what does
crsctl stat res -t -init
show?
Re: downgrade problem [message #564276 is a reply to message #564069] Wed, 22 August 2012 08:26 Go to previous messageGo to next message
bruce_odo
Messages: 6
Registered: August 2012
Location: London
Junior Member
Hi John

I had attempted to start the clusterware processes before to no avail. When i tried to start clusterware processes, please find below the error messages received

[root@rac_node_1 ~]# export PATH=$PATH:/usr/local/bin
[root@rac_node_1 ~]# crsctl start cluster -all
CRS-4404: The following nodes did not reply within the allotted time:
rac_node_1,rac_node_2
CRS-4705: Start of Clusterware failed on node rac_node_1.
CRS-4705: Start of Clusterware failed on node rac_node_2.
CRS-4000: Command Start failed, or completed with errors.
[root@rac_node_1 ~]#


Please find below the outcome of crsctl stat res -t -init on both nodes since there isn't cluster-wide view

From first node (rac_node_1), please find below the output

crsctl stat res -t -init
--------------------------------------------------------------------------------
NAME TARGET STATE SERVER STATE_DETAILS
--------------------------------------------------------------------------------
Cluster Resources
--------------------------------------------------------------------------------
ora.asm
1 ONLINE OFFLINE
ora.cluster_interconnect.haip
1 ONLINE OFFLINE
ora.crf
1 ONLINE ONLINE rac_node_1
ora.crsd
1 ONLINE OFFLINE
ora.cssd
1 ONLINE OFFLINE STARTING
ora.cssdmonitor
1 ONLINE ONLINE rac_node_1
ora.ctssd
1 ONLINE OFFLINE
ora.diskmon
1 ONLINE ONLINE rac_node_1
ora.drivers.acfs
1 ONLINE OFFLINE
ora.evmd
1 OFFLINE OFFLINE
ora.gipcd
1 ONLINE ONLINE rac_node_1
ora.gpnpd
1 ONLINE ONLINE rac_node_1
ora.mdnsd
1 ONLINE ONLINE rac_node_1
[grid@rac_node_1 cssd]$


#from second node (rac_node_2 )

[grid@rac_node_2 bin]$ ./crsctl stat res -t

CRS-4535: Cannot communicate with Cluster Ready Services
CRS-4000: Command Status failed, or completed with errors.

[grid@rac_node_2 bin]$ ./crsctl stat res -t -init
--------------------------------------------------------------------------------
NAME TARGET STATE SERVER STATE_DETAILS
--------------------------------------------------------------------------------
Cluster Resources
--------------------------------------------------------------------------------
ora.asm
1 ONLINE OFFLINE
ora.cluster_interconnect.haip
1 ONLINE OFFLINE
ora.crf
1 ONLINE ONLINE rac_node_2
ora.crsd
1 ONLINE OFFLINE
ora.cssd
1 ONLINE OFFLINE STARTING
ora.cssdmonitor
1 ONLINE ONLINE rac_node_2
ora.ctssd
1 ONLINE OFFLINE
ora.diskmon
1 ONLINE ONLINE rac_node_2
ora.drivers.acfs
1 ONLINE OFFLINE
ora.evmd
1 ONLINE OFFLINE
ora.gipcd
1 ONLINE ONLINE rac_node_2
ora.gpnpd
1 ONLINE ONLINE rac_node_2
ora.mdnsd
1 ONLINE ONLINE rac_node_2
[grid@rac_node_2 bin]$

#############
No clusterware processes running

[root@rac_node_1 ~]# ps -ef|egrep 'lgwr|oclskd.bin|crsd.bin|ocssd.bin|evmd.bin|tns'|grep -v grep|wc -l
0

##
[grid@rac_node_2 bin]$ ps -ef|egrep 'lgwr|oclskd.bin|crsd.bin|ocssd.bin|evmd.bin|tns'|grep -v grep|wc -l
0
##

Please note, I have uploaded output of same command for better readability. Thanks for your time

[Updated on: Wed, 22 August 2012 08:40]

Report message to a moderator

Re: downgrade problem [message #564279 is a reply to message #564276] Wed, 22 August 2012 08:32 Go to previous messageGo to next message
John Watson
Messages: 4515
Registered: January 2010
Location: Global Village
Senior Member
I've asked you three times to follow the guidelines. Good bye.
Re: downgrade problem [message #564289 is a reply to message #564279] Wed, 22 August 2012 08:47 Go to previous messageGo to next message
bruce_odo
Messages: 6
Registered: August 2012
Location: London
Junior Member
I am so sorry boss!

Just can't see the guidelines,didn't mean to be unpolite. Just under pressure. Apologies
Re: downgrade problem [message #564294 is a reply to message #564289] Wed, 22 August 2012 08:55 Go to previous messageGo to next message
Michel Cadot
Messages: 58938
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
He meant How to use [code] tags and make your code easier to read ("It would be polite to follow the guidelines, and use copy/paste formatted with [code] tags when you want to post something").
Not formatted code is hard to read and so after a while we are tired to extract information and prefer to leave, after all it is not mandatory to help.
So even if you are under pressure help us to help you.

Regards
Michel
Re: downgrade problem [message #564406 is a reply to message #564294] Thu, 23 August 2012 09:00 Go to previous messageGo to next message
bruce_odo
Messages: 6
Registered: August 2012
Location: London
Junior Member
Thanks anyway, have raised SR with oracle and it's been fixed.
Re: downgrade problem [message #564417 is a reply to message #564406] Thu, 23 August 2012 10:22 Go to previous message
Michel Cadot
Messages: 58938
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
How? Have you a bug number or a MOS note number?

Regards
Michel
Previous Topic: Quality of Service
Next Topic: theoretic question
Goto Forum:
  


Current Time: Sat Aug 30 21:32:22 CDT 2014

Total time taken to generate the page: 0.14947 seconds