Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-5 (Oracle forms and report 10G)
REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-5 [message #559642] Thu, 05 July 2012 04:34 Go to next message
annuar85
Messages: 7
Registered: July 2012
Location: Malaysia
Junior Member
Hello All,

When i try to run a report in the Apps Server through a client machine, i get this error:

REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-56033: Job 422101 does not exist..

I can run other reports , they do not have a error.
What may be the problem ?

My forms button to call report code:
declare
report_id report_object;
report_job_id varchar2( 128 );
parm_list ParamList;
paramlist_name varchar2( 11 ) := 'REPPARMLIST';
report_status varchar2( 100 );
alert number;
begin
report_id := find_report_object('CT1001');
if not id_null( parm_list ) then
destroy_parameter_list( parm_list );
end if;
parm_list := create_parameter_list( paramlist_name );
report_job_id := run_report_object( report_id, parm_list );
if report_job_id is not null then
report_status := Report_Object_Status( report_job_id );
if report_status = 'FINISHED' then
Web.Show_Document( '/reports/rwservlet/getjobid' ||
substr( report_job_id, instr( report_job_id, '_', -1 ) + 1 ),
'_blank' );
else
message( 'Report failed with error message ' || report_status );
end if;
else
message( 'Report id is null!' );
end if;

if not id_null( parm_list ) then
destroy_parameter_list( parm_list );
end if;

end;

Please help me solved this problem since i'm new in oracle..
Re: REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-5 [message #559690 is a reply to message #559642] Thu, 05 July 2012 09:50 Go to previous messageGo to next message
joy_division
Messages: 4504
Registered: February 2005
Location: East Coast USA
Senior Member
Go to the reports server queue status page and see what it says. It's something like :

http://[app server name]:[port]/reports/rwservlet/showjobs?queuetype=past&server=[report server name]

and then click on the red X for the job.

[Updated on: Thu, 05 July 2012 09:51]

Report message to a moderator

Re: REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-5 [message #559753 is a reply to message #559690] Thu, 05 July 2012 20:51 Go to previous messageGo to next message
annuar85
Messages: 7
Registered: July 2012
Location: Malaysia
Junior Member
Hi Mr joy,

Im already go thru Reports Server Queue Status,but im cant find "the red X" as you say..

Any idea Sir.
Re: REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-5 [message #559754 is a reply to message #559753] Thu, 05 July 2012 21:31 Go to previous messageGo to next message
annuar85
Messages: 7
Registered: July 2012
Location: Malaysia
Junior Member
Sir,

im also cant find the job id 422101 in Reports Server Queue Status,and after im investigate,my site have 2 report server name,rep_tcmsapp2_OraDb10g_home1 and rep_tcmsapp2_OraDb10g_home3..but report rep_tcmsapp2_OraDb10g_home3 is down and after click start got a error like this:

An error occurred while starting "Reports Server: rep_tcmsapp2_OraDb10g_home3".
An error occurred while talking to OPMN. Could not find entity for "rep_tcmsapp2_OraDb10g_home3".
For more information, look at the logs using the related link below.
Related Link Error Logs
Re: REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-5 [message #559783 is a reply to message #559754] Fri, 06 July 2012 02:26 Go to previous messageGo to next message
annuar85
Messages: 7
Registered: July 2012
Location: Malaysia
Junior Member
Sir,

Now im found the causes,my site currently use 2 ip for 1 app system..10.0.2.168 and 10.0.2.169 and after im rename the report,supposed at 10.0.2.168 cant call the report,but still report can progress with that error,and after im rename report at 10.0.2.169 the report cant generate and after more investigate Reports Server Queue Status the job id at server 10.0.2.169 supposed at 10.0.2.168...how i can change puff for that report....sorry for my bad English sir..
Re: REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-5 [message #559817 is a reply to message #559783] Fri, 06 July 2012 09:46 Go to previous messageGo to next message
joy_division
Messages: 4504
Registered: February 2005
Location: East Coast USA
Senior Member
I am sorry, this is now beyond the minimal knowledge I have of the problem. I'd put this question up on Oracle support as the app server forum here gets very little action.
Re: REP-52251: Cannot get output of job ID 422101 you requested on Thu Jul 05 17:04:46 MYT 2012.<P>REP-5 [message #560026 is a reply to message #559817] Mon, 09 July 2012 22:17 Go to previous message
annuar85
Messages: 7
Registered: July 2012
Location: Malaysia
Junior Member
Sir,

Sorry for the late replay,actually im already find the solutions.Im just change report server name at forms from 10.0.2.169 to read at 10.0.2.168..

Thanks for the help..appreciate so much... Very Happy
Previous Topic: ORA-12154: TNS: could not resolve service name
Next Topic: Question about configuration OAS
Goto Forum:
  


Current Time: Sat Aug 23 02:39:30 CDT 2014

Total time taken to generate the page: 0.09142 seconds