Home » Infrastructure » Windows » Oracle 11g in windows 7 (window 7)
Oracle 11g in windows 7 [message #559346] Mon, 02 July 2012 12:43 Go to next message
ramtin
Messages: 37
Registered: November 2008
Member
Hi All,

I instaledl Oracle Database 11g in my PC and try to login to it. I am able to log to it via SQLDeveloper but I can not login via SQLPLUS and I got ORA-12154. Here is my TNSname.ora and SQLplus.ora

# sqlnet.ora Network Configuration File: C:\app\mhakimjavadi\product\11.2.0\dbhome_1\network\admin\sqlnet.ora
# Generated by Oracle configuration tools.

# This file is actually generated by netca. But if customers choose to
# install "Software Only", this file wont exist and without the native
# authentication, they will not be able to connect to the database on NT.

TRACE_LEVEL_CLIENT = OFF

NAMES.DIRECTORY_PATH= (TNSNAMES)

AUTOMATIC_IPC = OFF


# tnsnames.ora Network Configuration File: C:\app\mhakimjavadi\product\11.2.0\dbhome_1\network\admin\tnsnames.ora
# Generated by Oracle configuration tools.

ORACLR_CONNECTION_DATA =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
)
(CONNECT_DATA =
(SID = CLRExtProc)
(PRESENTATION = RO)
)
)

LISTENER_DEV =
(ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

DEV =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = MARK-HAK.loyalist.com)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = DEV)
)
)

Please advise.

Thank you in advance.
Re: Oracle 11g in windows 7 [message #559347 is a reply to message #559346] Mon, 02 July 2012 12:53 Go to previous messageGo to next message
Michel Cadot
Messages: 58954
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-12154: TNS:could not resolve the connect identifier specified
 *Cause:  A connection to a database or other service was requested using
 a connect identifier, and the connect identifier specified could not
 be resolved into a connect descriptor using one of the naming methods
 configured. For example, if the type of connect identifier used was a
 net service name then the net service name could not be found in a
 naming method repository, or the repository could not be
 located or reached.
 *Action:
   - If you are using local naming (TNSNAMES.ORA file):
      - Make sure that "TNSNAMES" is listed as one of the values of the
        NAMES.DIRECTORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA)
      - Verify that a TNSNAMES.ORA file exists and is in the proper
        directory and is accessible.
      - Check that the net service name used as the connect identifier
        exists in the TNSNAMES.ORA file.
      - Make sure there are no syntax errors anywhere in the TNSNAMES.ORA
        file.  Look for unmatched parentheses or stray characters. Errors
        in a TNSNAMES.ORA file may make it unusable.
   - If you are using directory naming:
      - Verify that "LDAP" is listed as one of the values of the
        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA).
      - Verify that the LDAP directory server is up and that it is
        accessible.
      - Verify that the net service name or database name used as the
        connect identifier is configured in the directory.
      - Verify that the default context being used is correct by
        specifying a fully qualified net service name or a full LDAP DN
        as the connect identifier
   - If you are using easy connect naming:
      - Verify that "EZCONNECT" is listed as one of the values of the
        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA).
      - Make sure the host, port and service name specified
        are correct.
      - Try enclosing the connect identifier in quote marks.

   See the Oracle Net Services Administrators Guide or the Oracle
   operating system specific guide for more information on naming.
Re: Oracle 11g in windows 7 [message #559356 is a reply to message #559347] Mon, 02 July 2012 14:56 Go to previous messageGo to next message
BlackSwan
Messages: 22725
Registered: January 2009
Senior Member
>I am able to log to it via SQLDeveloper but I can not login via SQLPLUS and I got ORA-12154.
SQL Developer default to use JDBC thin to connect to the DB; which does NOT use tnsnames.ora

ORA-12154 ALWAYS only occurs on SQL Client & no SQL*Net packets ever leave client system
ORA-12154 NEVER involves the listener, the database itself or anything on the DB Server.
ORA-12154 occurs when client requests a connection to some DB server system using some connection string.
The lookup operation fails because the name provided can NOT be resolved to any remote DB.
The analogous operation would be when you wanted to call somebody, but could not find their name in any phonebook.
The most frequent cause for the ORA-12154 error is when the connection alias can not be found in tnsnames.ora.
The lookup operation of the alias can be impacted by the contents of the sqlnet.ora file; specifically DOMAIN entry.
TROUBLESHOOTING GUIDE: ORA-12154 & TNS-12154 TNS:could not resolve service name [ID 114085.1]
http://edstevensdba.wordpress.com/2011/02/26/ora-12154tns-03505/


Re: Oracle 11g in windows 7 [message #559358 is a reply to message #559356] Mon, 02 July 2012 15:08 Go to previous messageGo to next message
ramtin
Messages: 37
Registered: November 2008
Member
I sent you my sqlnet.ora and TNSnames.ora but I could not find where I have mistake on those and that is my problem. Please review those file and tell me what should I do to find the problem.

Thank you
Re: Oracle 11g in windows 7 [message #559359 is a reply to message #559358] Mon, 02 July 2012 15:16 Go to previous messageGo to next message
BlackSwan
Messages: 22725
Registered: January 2009
Senior Member
Please read and follow the forum guidelines, to enable us to help you:

http://www.orafaq.com/forum/t/88153/0/

I don't know what you do.
I don't know what you see.
It is really, Really, REALLY difficult to fix a problem that can not be seen.
use COPY & PASTE so we can see what you do & how Oracle responds.
Re: Oracle 11g in windows 7 [message #559361 is a reply to message #559358] Mon, 02 July 2012 16:08 Go to previous messageGo to next message
ramtin
Messages: 37
Registered: November 2008
Member
I have Oracle Database install in my PC and I am able to login via SQLDeveloper and everything is fine. Now I tried to connect to DB via sqlPlus or MS ODBC and I got Ora-12541. Please advise. do you did any other information?

Thanks
Re: Oracle 11g in windows 7 [message #559367 is a reply to message #559361] Mon, 02 July 2012 17:13 Go to previous message
BlackSwan
Messages: 22725
Registered: January 2009
Senior Member
>I am able to log to it via SQLDeveloper but I can not login via SQLPLUS and I got ORA-12154.
above is from original post in this thread & below is from your last post.
> Now I tried to connect to DB via sqlPlus or MS ODBC and I got Ora-12541.

Did the error really change from ORA-12154 to ORA-12541 or do you have a problem using COPY & PASTE?

Please read and follow the forum guidelines, to enable us to help you:

http://www.orafaq.com/forum/t/88153/0/

Previous Topic: Problem in installing oracle 10g on windows 2008r2 64 bit on a HP ML110 G7 machine
Next Topic: Any Easier Way?
Goto Forum:
  


Current Time: Mon Sep 01 19:15:48 CDT 2014

Total time taken to generate the page: 0.13290 seconds