Home » Developer & Programmer » Forms » Browser error (windos 7)
icon11.gif  Browser error [message #558691] Mon, 25 June 2012 22:41 Go to next message
pakpolic@gmail.com
Messages: 23
Registered: June 2012
Location: Peshawar
Junior Member
my Dear friends i am using oracle 10g forms but face browser error to run forms "plugin are required "
i have been use different types of browsers like enternet explorer, opera, firefox, google chroom burt not working.
please solve this problem with detail .
and which type of JRE and Jintiator are required
and how can it configure ???

hussainkhan201@yahoo.com
Re: Browser error [message #558719 is a reply to message #558691] Tue, 26 June 2012 02:09 Go to previous message
modi911
Messages: 16
Registered: June 2012
Junior Member

you have three choice start one by one until will working
first one:
open formsweb.cfg then open server then open form
then find basejini.htm, then change baseHTMLjinitiator=basejpi.htm

Be carefully take fast copy from all file, becouse if change will effect in oracle forms

seconde choice
Running a form from the Forms Builder requires a little setup. Typically, it only requires you to installed the right JInitiator (version 1.3.1.22). However, depending on the browser you are using, you may need to use the Oracle/Sun JRE 1.6.0 (or Java Plug-in). To use the JRE, you will need to modify the formsweb.cfg file found in the \DevSuiteHome_1\Forms\Server directory. Typically, you need to change the following lines:
/* The changes listed allow you to use any update of the JRE 1.6.0 */
# System parameter: base HTML file for use with JInitiator client
#baseHTMLjinitiator=basejini.htm
baseHTMLjinitiator=basejpi.htm

#jpi_classid=clsid:CAFEEFAC-0014-0002-0006-ABCDEFFEDCBA
jpi_classid=clsid:CAFEEFAC-0016-0000-FFFF-ABCDEFFEDCBA

#jpi_mimetype=application/x-java-applet;jpi-version=1.4.2_06
jpi_mimetype=application/x-java-applet;jpi-version=1.6.0

These settings will work if you are using Internet Explorer as your default browser.

If you are using a different browser (like Firefox) then make the following change instead:
#jpi_mimetype=application/x-java-applet;jpi-version=1.4.2_06
jpi_mimetype=application/x-java-applet

Additionally, you will need to make sure the directory where your form resides is listed in the FORMS_PATH environment variable so the runtime can find the Forms executable. For this, you will need to modify the default.env located in the same directory as the formsweb.cfg. For example, if your form is in a folder called "MyDevelopment\Forms" you would make the following addition:
FORMS_PATH=D:\DevSuiteHome_1\forms;D:\MyDevelopment\Form_Libs;D:\MyDevelopment\Form_Menus;D:\MyDevelopment\Forms

In the above example, you will also see that I have two additional directories in my FORMS_PATH for PL/SQL Libraries (.pll/plx) and for Menu Modules (.mmb/mmx). I also recommend you make this same change to your FORMS_PATH Windows Registry entry as well.


third choice
http://www.oratraining.com/blog/2010/04/internet-explorer-has-closed-this-webpage-to-help-protect-your-computer/



Previous Topic: how i can use class
Next Topic: ORA-03114 in Forms 6I
Goto Forum:
  


Current Time: Sat Dec 27 16:16:32 CST 2014

Total time taken to generate the page: 0.05482 seconds