Home » Developer & Programmer » Forms » problem with list menu not work
problem with list menu not work [message #558203] Wed, 20 June 2012 04:20 Go to next message
modi911
Messages: 16
Registered: June 2012
Junior Member
dear all,

i want use two list menu with diffrent table, i made this code but one it is working but seconde one not working.

can any body see what is the problem.

i but this code under (WHEN-NEW-FORM-INSTANCE) trigger: (Note:two list with two diffrent tabCanvas)

declare
RR recordgroup;
RG recordgroup;
n number;
num number;
begin
RR:=create_group_from_query('QQ','SELECT NAME,DNAME from EMP');
RG:=create_group_from_query('QU','SELECT BLOOD_GROUP from BLOOD_GROUPS');
n:=populate_group(RR);
num:=populate_group(RG);
populate_list('RECEP.DOCNAME','QQ');
populate_list('FILE.BLOOD','QU');
end;
Re: problem with list menu not work [message #558214 is a reply to message #558203] Wed, 20 June 2012 05:40 Go to previous messageGo to next message
modi911
Messages: 16
Registered: June 2012
Junior Member
no answer??????????????????
Re: problem with list menu not work [message #558238 is a reply to message #558214] Wed, 20 June 2012 06:33 Go to previous messageGo to next message
cookiemonster
Messages: 11076
Registered: September 2008
Location: Rainy Manchester
Senior Member
You need to learn some patience. There's only a few of use here who know forms and we aren't just sat around waiting to answer your questions.
Before you next post code can you please read and follow How to use [code] tags and make your code easier to read?

List items require two columns in the group query. One for the value displayed and one for the value stored.
Your 2nd query only selects one column.
If you want the value displayed and the value stored to be the same then you need to select the same column twice in the query.
Re: problem with list menu not work [message #558248 is a reply to message #558203] Wed, 20 June 2012 06:52 Go to previous messageGo to next message
modi911
Messages: 16
Registered: June 2012
Junior Member
Ok, thank you


declare
RR recordgroup;
RG recordgroup;
n number;
num number;
begin
RR:=create_group_from_query('QQ','SELECT DOCTORNAME,DOCCODE from DOCTORS');
RG:=create_group_from_query('QU','SELECT BLOOD_GROUP from XXCLINIC_BLOOD_GROUPS');
n:=populate_group(RR);
num:=populate_group(RG);
populate_list('XXCLINIC_RECEPTION1.DOCNAME','QQ');
populate_list('XXCLINIC_RECEPTION1.DOCNAME2','QQ');
populate_list('XXCLINIC_MEDICAL_FILE.BLOOD',RG);

end;


Re: problem with list menu not work [message #558249 is a reply to message #558248] Wed, 20 June 2012 06:54 Go to previous message
cookiemonster
Messages: 11076
Registered: September 2008
Location: Rainy Manchester
Senior Member
You haven't done the fix I told you to do.
Previous Topic: get a live connection to a database
Next Topic: Migrating from 6i to 10g
Goto Forum:
  


Current Time: Fri Oct 24 07:54:33 CDT 2014

Total time taken to generate the page: 0.17472 seconds