Home » Developer & Programmer » Forms » Problem with forms debugging (Oracle Forms 11g, Linux RedHat 64bit)
Problem with forms debugging [message #556193] Thu, 31 May 2012 15:52 Go to next message
p_pml
Messages: 15
Registered: February 2012
Junior Member
Hello,
I notified some strange behaviour of my forms debugger. When I insert debug.attach piece of code into ma form and fired them on Windows machine after inserting into Oracle forms builder debugger dialog box server name (usualy ip) and given port from oracle forms window then everything works fine, breakpoint is catched. But when I changed my OS to RedHat then I am not able to come into all kind of trigger form code. Only program units could be debugged. What could be the reason of such strange behaviour ? Is there any solution ?
Re: Problem with forms debugging [message #556194 is a reply to message #556193] Thu, 31 May 2012 15:56 Go to previous messageGo to next message
Littlefoot
Messages: 19697
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Reason? No idea (apart from this: is Forms 11g certified with Red Hat Linux you use? If not, that might be the reason).

Solution? Possibly: move code from triggers to procedures, then call procedures from those triggers. Although, if debugger doesn't enter triggers at all, I'm afraid that won't help either.
Re: Problem with forms debugging [message #556195 is a reply to message #556193] Thu, 31 May 2012 15:58 Go to previous messageGo to next message
p_pml
Messages: 15
Registered: February 2012
Junior Member
Sorry I make some mistake, when I was writing about OS I meant OS of server where Weblogic with oracle forms is hosted !!! not my local OS. So summarizing when Weblogic is hosted on Windows then I am able to debug all forms code, when on RedHat only program units (all triggers are neglected by debugger beside existing brekpoints).
Re: Problem with forms debugging [message #556196 is a reply to message #556194] Thu, 31 May 2012 16:01 Go to previous messageGo to next message
p_pml
Messages: 15
Registered: February 2012
Junior Member
Yes this version of RedHat is dscribed as compatible by Oracle Corporation.

By the way, Oracle Linux is nothing else as RedHat distribution under other name.
Re: Problem with forms debugging [message #556200 is a reply to message #556196] Thu, 31 May 2012 16:04 Go to previous messageGo to next message
p_pml
Messages: 15
Registered: February 2012
Junior Member
Moving code from trigger into program units obviously is some solution, but forms are inherited during project and additionaly owner of this application do not agree with that huge changes. Moreover number of forms is to big.
Re: Problem with forms debugging [message #556201 is a reply to message #556200] Thu, 31 May 2012 16:06 Go to previous messageGo to next message
Littlefoot
Messages: 19697
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Sorry, no further ideas.

Did you check My Oracle Support? If there's nothing there, perhaps you should contact Oracle and see what they say.
Re: Problem with forms debugging [message #556207 is a reply to message #556201] Thu, 31 May 2012 16:39 Go to previous messageGo to next message
p_pml
Messages: 15
Registered: February 2012
Junior Member
Unfortunately I didn't find any related topic on My Oracle Support
Re: Problem with forms debugging [message #556219 is a reply to message #556207] Fri, 01 June 2012 00:02 Go to previous messageGo to next message
Littlefoot
Messages: 19697
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
If that's so, create a service request.
Re: Problem with forms debugging [message #605227 is a reply to message #556195] Wed, 08 January 2014 03:34 Go to previous message
xiaoyuandlg
Messages: 2
Registered: January 2014
Junior Member
p_pml wrote on Thu, 31 May 2012 15:58
Sorry I make some mistake, when I was writing about OS I meant OS of server where Weblogic with oracle forms is hosted !!! not my local OS. So summarizing when Weblogic is hosted on Windows then I am able to debug all forms code, when on RedHat only program units (all triggers are neglected by debugger beside existing brekpoints).


I've faced a parallel situation, hope your problem get fixed soon.

[Updated on: Wed, 08 January 2014 08:36] by Moderator

Report message to a moderator

Previous Topic: what does small red color arraw indicate in forms icon in oracle forms?
Next Topic: MONTHS_BETWEEN problem in Oracle Form 6i
Goto Forum:
  


Current Time: Sat Oct 25 04:48:58 CDT 2014

Total time taken to generate the page: 0.10230 seconds