Home » Server Options » Data Guard » setting up Dataguard (AIX 6.1 Oracle 11203)
setting up Dataguard [message #548847] Mon, 26 March 2012 12:50 Go to next message
BeefStu
Messages: 192
Registered: October 2011
Senior Member
I am trying to setup DG in a test enviorment. My primary DB (dev1) and my stdby DB (dev2).


my config parameters

initdev1.ora
*.log_archive_config='DG_CONFIG=(dev1,dev2)'
*.log_archive_dest_1='LOCATION=/u02/arch/dev1/ VALID_FOR=(ALL_LOGFILES,ALL_ROLES
) DB_UNIQUE_NAME=dev1'
*.log_archive_dest_2='SERVICE=dev2 ASYNC VALID_FOR=(ONLINE_LOGFILES,PRIMARY_ROLE
) DB_UNIQUE_NAME=dev2'
*.log_archive_dest_state_1=ENABLE
*.log_archive_dest_state_2=ENABLE
*.fal_client=dev1
*.fal_server=dev2


initdev2.ora
============

*.log_archive_dest_1='LOCATION=/u02/arch/dev2 VALID_FOR=(ALL_LOGFILES,ALL_ROLES)
 DB_UNIQUE_NAME=dev2'
*.LOG_ARCHIVE_DEST_2='SERVICE=dev1 ASYNC VALID_FOR=(ONLINE_LOGFILES,PRIMARY_ROLE
) DB_UNIQUE_NAME=dev1'
*.log_archive_dest_state_1=ENABLE
*.log_archive_dest_state_2=ENABLE
*.fal_server=dev1
*.fal_client=dev2


When I bounce the servers I get the following:


SQL> select name, open_mode, protection_mode, database_role, dataguard_broker, force_logging from v$database;

NAME      OPEN_MODE            PROTECTION_MODE      DATABASE_ROLE    DATAGUAR
--------- -------------------- -------------------- ---------------- --------
FOR
---
DEV1      READ WRITE           MAXIMUM PERFORMANCE  PRIMARY          DISABLED
NO

SQL> select name, open_mode, protection_mode, database_role, dataguard_broker, force_logging from v$database;

NAME      OPEN_MODE            PROTECTION_MODE      DATABASE_ROLE    DATAGUAR
--------- -------------------- -------------------- ---------------- --------
FOR
---
DEV2      READ WRITE           MAXIMUM PERFORMANCE  PRIMARY          DISABLED
NO



I see that DATAGAURD is disabled on both DB's. In additon, I create a simple
table on dev1, add a few rows and commit, switch logfile and I dont' see the
changes come across.

It looks like I a missing something, does anybody know what?

Thanks in advance to all who answer
Re: setting up Dataguard [message #548853 is a reply to message #548847] Mon, 26 March 2012 13:09 Go to previous messageGo to next message
John Watson
Messages: 4693
Registered: January 2010
Location: Global Village
Senior Member
Quote:
It looks like I a missing something, does anybody know what?
log_archive_config on thr standby?
Re: setting up Dataguard [message #548857 is a reply to message #548847] Mon, 26 March 2012 13:18 Go to previous messageGo to next message
BeefStu
Messages: 192
Registered: October 2011
Senior Member
I added the parameter and the query on both the primary (dev1) and stdby (dev2) show the same results..

Is there a command I need to run to enabled data guard on both DB's What about force logging, does that need to be set to YES? I went through the documenation several times and could not see what I am missing to get this to work.
Re: setting up Dataguard [message #548858 is a reply to message #548847] Mon, 26 March 2012 13:20 Go to previous messageGo to next message
John Watson
Messages: 4693
Registered: January 2010
Location: Global Village
Senior Member
Quote:
It looks like I a missing something, does anybody know what?
db_unique_name parameter?
Re: setting up Dataguard [message #548864 is a reply to message #548858] Mon, 26 March 2012 14:21 Go to previous messageGo to next message
BeefStu
Messages: 192
Registered: October 2011
Senior Member
I am going to redo the process... so please hold on answering

thanks for all your help
Re: setting up Dataguard [message #551430 is a reply to message #548864] Wed, 18 April 2012 04:27 Go to previous message
ceocio
Messages: 1
Registered: April 2012
Junior Member
I must say first an awesome website www.orafaq.com. I am new to this. @BeefStu, may I have a step by step guide to set up DataGuard.
Any other one is also most welcomed.
Previous Topic: How to convert the primary control file for standby ?
Next Topic: Data Guard
Goto Forum:
  


Current Time: Sat Oct 25 15:54:59 CDT 2014

Total time taken to generate the page: 0.07833 seconds