Home » Infrastructure » Windows » Oracle don't start (10.2.0)
Oracle don't start [message #548129] Tue, 20 March 2012 08:22 Go to next message
mhmfikri
Messages: 7
Registered: March 2012
Junior Member
Dear all,

I got the following message when I tried to logon to my Oracle
version 10.2.0 from C:\oraclexe\app\oracle\product\10.2.0\server\dbs directory by typing sqlplus.

1. logon as SYSTEM
2. logon as / as sysdba

Can anyone tell me what's wrong with this?

Thank you.
- Fikri -


C:\oraclexe\app\oracle\product\10.2.0\server\dbs>sqlplus

SQL*Plus: Release 10.2.0.1.0 - Production on Tue Mar 20 20:15:19 2012

Copyright (c) 1982, 2005, Oracle. All rights reserved.

Enter user-name: SYSTEM
Enter password:
ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist


Enter user-name: / as sysdba
Connected to an idle instance.

SQL>

Re: Oracle don't start [message #548133 is a reply to message #548129] Tue, 20 March 2012 08:27 Go to previous messageGo to next message
cookiemonster
Messages: 10961
Registered: September 2008
Location: Rainy Manchester
Senior Member
check your ORACLE_SID environment variable is set correctly.
Re: Oracle don't start [message #548136 is a reply to message #548133] Tue, 20 March 2012 08:35 Go to previous messageGo to next message
mhmfikri
Messages: 7
Registered: March 2012
Junior Member
@cookiemonster
by the way I am using Oracle 10.2.0 for windows xp. I don't see %ORACLE_SID% in the environment variable. Should I add it?
Re: Oracle don't start [message #548141 is a reply to message #548129] Tue, 20 March 2012 08:52 Go to previous messageGo to next message
Michel Cadot
Messages: 59162
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
Connected to an idle instance.


The database/instance is not started.

Regards
Michel
Re: Oracle don't start [message #548145 is a reply to message #548141] Tue, 20 March 2012 08:59 Go to previous messageGo to next message
mhmfikri
Messages: 7
Registered: March 2012
Junior Member
Michel Cadot,

what should I do, in the meantime I've just added ORACLE_SID env var and set it to "ORA10", and typed "STARTUP", but the the response is the following:


Copyright (c) 1982, 2005, Oracle. All rights reserved.

SQL> connect sys/zxcvbn as sysdba
Connected to an idle instance.
SQL> startup
ORA-01506: missing or illegal database name
SQL> exit
Disconnected

What should I do more?

Regards,
Fikri
Re: Oracle don't start [message #548146 is a reply to message #548145] Tue, 20 March 2012 09:00 Go to previous messageGo to next message
Michel Cadot
Messages: 59162
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-01506: missing or illegal database name
 *Cause:  No db_name INIT.ORA aprameter was specified.
 *Action:  The database name must be given in the db_name
            INIT.ORA parameter.

Regards
Michel
Re: Oracle don't start [message #548148 is a reply to message #548146] Tue, 20 March 2012 09:11 Go to previous messageGo to next message
BlackSwan
Messages: 22796
Registered: January 2009
Senior Member
It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/
Re: Oracle don't start [message #548149 is a reply to message #548146] Tue, 20 March 2012 09:17 Go to previous messageGo to next message
mhmfikri
Messages: 7
Registered: March 2012
Junior Member
Michael Cadot,

db_name in init.ora is specified , that is "db_name=XE", however file init.ora is located on C:\oraclexe\app\oracle\product\10.2.0\server\config\scripts. Is this the problem? I have also file "initXE.ora" in /database directory!

Thank you.

Regards,
Fikri

@BlackSwan, thanks your info !
Re: Oracle don't start [message #548150 is a reply to message #548149] Tue, 20 March 2012 09:23 Go to previous messageGo to next message
cookiemonster
Messages: 10961
Registered: September 2008
Location: Rainy Manchester
Senior Member
Then ORACLE_SID should be set to XE.
Re: Oracle don't start [message #548151 is a reply to message #548145] Tue, 20 March 2012 09:24 Go to previous messageGo to next message
BlackSwan
Messages: 22796
Registered: January 2009
Senior Member
>what should I do, in the meantime I've just added ORACLE_SID env var and set it to "ORA10",

who, what, how did database ORA10 get created?
Re: Oracle don't start [message #548153 is a reply to message #548151] Tue, 20 March 2012 09:40 Go to previous messageGo to next message
mhmfikri
Messages: 7
Registered: March 2012
Junior Member
I set now ORACLE_SID to XE and tried it again, but still not working. See system response :


C:\oraclexe\app\oracle\product\10.2.0\server\database>sqlplus /nolog

SQL*Plus: Release 10.2.0.1.0 - Production on Tue Mar 20 21:36:41 2012

Copyright (c) 1982, 2005, Oracle. All rights reserved.

SQL> connect sys/zxcvbn as sysdba
Connected to an idle instance.
SQL> startup nomount
ORA-01506: missing or illegal database name
SQL>

what to do next?
Re: Oracle don't start [message #548157 is a reply to message #548153] Tue, 20 March 2012 09:47 Go to previous messageGo to next message
Michel Cadot
Messages: 59162
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
What's inside %ORACLE%\database?

Regards
Michel
Re: Oracle don't start [message #548159 is a reply to message #548157] Tue, 20 March 2012 09:55 Go to previous messageGo to next message
mhmfikri
Messages: 7
Registered: March 2012
Junior Member


Here is the inside %ORACLE%/database:

C:\oraclexe\app\oracle\product\10.2.0\server\database>dir
Volume in drive C is System
Volume Serial Number is 240E-A1BD

Directory of C:\oraclexe\app\oracle\product\10.2.0\server\database

03/20/2012 09:09 PM <DIR> .
03/20/2012 09:09 PM <DIR> ..
03/20/2012 05:35 PM 106 core_xe_pid_5292_tid_xA54_2012_3_19_22_46
_30.log
03/18/2012 04:07 PM 2,048 hc_xe.dat
03/20/2012 09:09 PM 2,434 init.ora
03/20/2012 09:06 PM 2,434 initXE.ora
02/02/2006 12:42 AM 31,744 oradba.exe
03/20/2012 09:35 PM 1,731 oradim.log
03/18/2012 04:02 PM 2,560 PWDgrms.ORA
03/18/2012 01:01 PM 1,536 PWDXE.ora
03/18/2012 04:02 PM 2,560 SPFILEXE.ORA
9 File(s) 47,153 bytes
2 Dir(s) 45,636,464,640 bytes free

C:\oraclexe\app\oracle\product\10.2.0\server\database>dir /Q
Volume in drive C is System
Volume Serial Number is 240E-A1BD

Directory of C:\oraclexe\app\oracle\product\10.2.0\server\database

03/20/2012 09:09 PM <DIR> BUILTIN\Administrators .
03/20/2012 09:09 PM <DIR> BUILTIN\Administrators ..
03/20/2012 05:35 PM 106 BUILTIN\Administrators core_xe_pid_5292_t
id_xA54_2012_3_19_22_46_30.log
03/18/2012 04:07 PM 2,048 BUILTIN\Administrators hc_xe.dat
03/20/2012 09:09 PM 2,434 USER-DB7E88948E\User init.ora
03/20/2012 09:06 PM 2,434 USER-DB7E88948E\User initXE.ora
02/02/2006 12:42 AM 31,744 BUILTIN\Administrators oradba.exe
03/20/2012 09:35 PM 1,731 BUILTIN\Administrators oradim.log
03/18/2012 04:02 PM 2,560 USER-DB7E88948E\User PWDgrms.ORA
03/18/2012 01:01 PM 1,536 USER-DB7E88948E\User PWDXE.ora
03/18/2012 04:02 PM 2,560 USER-DB7E88948E\User SPFILEXE.ORA
9 File(s) 47,153 bytes
2 Dir(s) 45,636,399,104 bytes free

C:\oraclexe\app\oracle\product\10.2.0\server\database>


Regards,
Fikri
Re: Oracle don't start [message #548164 is a reply to message #548159] Tue, 20 March 2012 10:09 Go to previous messageGo to next message
Littlefoot
Messages: 19633
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
(I'm afraid I can't help, but how on earth did you manage to screw up XE installation? It is more or less <next> - <next> - <next> clicking ...)
Re: Oracle don't start [message #548166 is a reply to message #548164] Tue, 20 March 2012 10:18 Go to previous messageGo to next message
BlackSwan
Messages: 22796
Registered: January 2009
Senior Member
>03/18/2012 04:02 PM 2,560 USER-DB7E88948E\User SPFILEXE.ORA
It appears that at some point in time somebody did like below

SET ORACLE_SID="User "

consider reformatting the disk & starting over.
Re: Oracle don't start [message #548169 is a reply to message #548166] Tue, 20 March 2012 10:28 Go to previous messageGo to next message
mhmfikri
Messages: 7
Registered: March 2012
Junior Member
@BlackSwan

ERROR:
ORA-12560: TNS:protocol adapter error
Re: Oracle don't start [message #548170 is a reply to message #548169] Tue, 20 March 2012 10:31 Go to previous message
cookiemonster
Messages: 10961
Registered: September 2008
Location: Rainy Manchester
Senior Member
What exactly is that a response to?
Previous Topic: Detect oracle version and platform installed ?
Next Topic: Unable to install oracle 11gR2 on Windows 7 Professional.
Goto Forum:
  


Current Time: Mon Sep 22 10:05:46 CDT 2014

Total time taken to generate the page: 0.22824 seconds