Home » Developer & Programmer » Forms » sudden error (unable to run form)- frm-92101 (Oracle 10g R2)
sudden error (unable to run form)- frm-92101 [message #546239] Mon, 05 March 2012 22:05 Go to next message
7anona
Messages: 57
Registered: February 2012
Member
once I run my form I get an error FRM-92101:There was a failure in the Forms Server during startup. This could happen due to invalid configuration. Please look into the web-server log file for details.

however, I haven't change anything in my form, it was working just fine last day can anyone help in tell me the reason behind this message (all my forms are working fine except for one form)

[Updated on: Mon, 05 March 2012 23:55]

Report message to a moderator

Re: sudden error (unable to run form)- frm-92101 [message #546286 is a reply to message #546239] Tue, 06 March 2012 01:54 Go to previous messageGo to next message
Littlefoot
Messages: 19314
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Try to recompile it (Ctrl + Shift + K).
Re: sudden error (unable to run form)- frm-92101 [message #546316 is a reply to message #546286] Tue, 06 March 2012 02:38 Go to previous messageGo to next message
7anona
Messages: 57
Registered: February 2012
Member
I compiled. The problem is still there
Re: sudden error (unable to run form)- frm-92101 [message #546448 is a reply to message #546239] Tue, 06 March 2012 14:14 Go to previous messageGo to next message
mughals_king
Messages: 351
Registered: January 2012
Location: pakistan
Senior Member
It sounds like you are on a Windows server. The fix is to change a registry key.

Launch regedit
go to HKEY_LOCAL_MACHINE
->System
->Current Control Set
->Control
->Session Manager
->SubSystems

In the Windows key change the last value in the "SharedSection=" to 1024.

Then:
From the control panel ( Middle tier) , click on the OPMN for middle tier -> LOG ON ->
Check Allow Service to Interact with Desktop

You'll need to reboot after that.

Goog Luck
Mughal Cool

[Updated on: Tue, 06 March 2012 14:16]

Report message to a moderator

Re: sudden error (unable to run form)- frm-92101 [message #546449 is a reply to message #546448] Tue, 06 March 2012 14:26 Go to previous messageGo to next message
mughals_king
Messages: 351
Registered: January 2012
Location: pakistan
Senior Member
if your confusing given detaila as above then in easy way

From the HKEY_LOCAL_MACHINE sub tree, go to the following key:

\System\CurrentControlSet\Control\Session Manager\SubSystems

The default values are 1024,3072,512
modified values are 1024,20480,5112

Then:

From the control panel ( Middle tier) , click on the OPMN for middle tier -> LOG ON ->
Check Allow Service to Interact with Desktop

You'll need to reboot after that.



Thanks
Re: sudden error (unable to run form)- frm-92101 [message #546466 is a reply to message #546449] Tue, 06 March 2012 21:59 Go to previous messageGo to next message
7anona
Messages: 57
Registered: February 2012
Member
thank you mughals_king
I just read your post. I work in windows7, I was compiling the form and running it through IE with out running the OC4J instance
once I opened it the error disappeared
thanks again
Re: sudden error (unable to run form)- frm-92101 [message #569249 is a reply to message #546466] Tue, 23 October 2012 12:01 Go to previous messageGo to next message
bigtanko
Messages: 1
Registered: October 2012
Junior Member
7anona and mughals_king, Am also having the same FRM-92101 error and am running Win7. How do I get the OC4J instance?
Re: sudden error (unable to run form)- frm-92101 [message #569251 is a reply to message #546448] Tue, 23 October 2012 12:46 Go to previous message
olalkn
Messages: 2
Registered: February 2008
Location: london
Junior Member
mughals_king wrote on Tue, 06 March 2012 20:14
It sounds like you are on a Windows server. The fix is to change a registry key.

Launch regedit
go to HKEY_LOCAL_MACHINE
->System
->Current Control Set
->Control
->Session Manager
->SubSystems

In the Windows key change the last value in the "SharedSection=" to 1024.

Then:
From the control panel ( Middle tier) , click on the OPMN for middle tier -> LOG ON ->
Check Allow Service to Interact with Desktop

You'll need to reboot after that.

Goog Luck
Mughal Cool


Dear Mughai
Thanks for giving you solution,Could you please explain how to get this

Then:
From the control panel ( Middle tier) , click on the OPMN for middle tier -> LOG ON ->
Check Allow Service to Interact with Desktop


I am a newbie and i just installed Oracle EBS 12i on window server 2008 and i am the problem.
Many thanks

Ola
Previous Topic: templates or themes for oracle forms application ?
Next Topic: i have master - details form
Goto Forum:
  


Current Time: Fri Jul 25 16:11:15 CDT 2014

Total time taken to generate the page: 0.27239 seconds