Home » RDBMS Server » Server Administration » Archivelog Every 30 Seconds (Oracle 10gR2 SUSE Linux)
Archivelog Every 30 Seconds [message #545687] Thu, 01 March 2012 12:34 Go to next message
Rektanocrit
Messages: 24
Registered: September 2011
Location: Philippines
Junior Member

Our database was generating archivelog(50MB) every 30seconds! I think this is not normal because what I did is open our database, I was the only one who is connected, I'm not running anything, but our database is still generating archivelogs!

Our redo logs: 6groups 3members.

This are the things I saw on our alert logs:
- advanced to log sequence
- cannot allocate new log, sequence
- checkpoint not complete
- private strand flush not complete

What I did is change the log mode of our database to noarchivelog then open the database, then returned it to archivelog mode then that fixed the problem. But the thing is after 6hours its abnormal behavior goes back again.
Re: Archivelog Every 30 Seconds [message #545688 is a reply to message #545687] Thu, 01 March 2012 12:40 Go to previous messageGo to next message
John Watson
Messages: 4611
Registered: January 2010
Location: Global Village
Senior Member
It isn't a problem, Oracle generates as much redo as is necessary to protect your database. I would replace those tiny 50M files with 1G files. That should give you a log switch every ten minutes.

[update: typo]

[Updated on: Thu, 01 March 2012 12:41]

Report message to a moderator

Re: Archivelog Every 30 Seconds [message #545869 is a reply to message #545687] Fri, 02 March 2012 19:27 Go to previous messageGo to next message
Rektanocrit
Messages: 24
Registered: September 2011
Location: Philippines
Junior Member

@John Watson: Thanks!

I've checked the crontab of the server and it only runs Export and RMAN Backup. Then I checked the DBA_JOBS and saw that there were two jobs. SYS runs the DBMS_STATS.gather_schema_stats and SYSMAN runs EXECUTE_EM_DBMS_JOB_PROCS. A senior DBA told me to run the 10.2.0.5 patch set and stop/disable the EXECUTE_EM_DBMS_JOB_PROCS because this is the one causing the problem.

I'll share if this is the solution to our problem.
Re: Archivelog Every 30 Seconds [message #547404 is a reply to message #545687] Wed, 14 March 2012 03:33 Go to previous message
Rektanocrit
Messages: 24
Registered: September 2011
Location: Philippines
Junior Member

Problem solved.

There was a module in our system that causes continues generation of archive log, it has an infinite loop in it. Thanks everyone!
Previous Topic: Tns protocol adaptor error
Next Topic: ORA-00054 resource busy and acquire with NOWAIT specified or timed expired
Goto Forum:
  


Current Time: Wed Oct 01 20:05:04 CDT 2014

Total time taken to generate the page: 1.52206 seconds