Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » Application Server Installation
Application Server Installation [message #545241] Tue, 28 February 2012 01:47 Go to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Dear Memebers
I am new to work on application server.
Dear members i have database server d1 on which Oracle 10g release 2 is running windows 2003 server. Now i want develop application in oracle forms 10.1.2 for front end development and want to install application server on separate server computer. So i put the forms on it. I want to know which version is suitable for this scenario. Oracle Application Server 10g Release 2
(10.1.2) is suitable for it or any other choice is there in case of form implementation. Please provide the answer in detail.

Thanks & Regards.
Re: Application Server Installation [message #545294 is a reply to message #545241] Tue, 28 February 2012 04:50 Go to previous messageGo to next message
Littlefoot
Messages: 19608
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Quote:
So i put the forms on it
On what? Application server? Why? You won't develop forms on application server but on your own PC. Install application server software on the application server computer. How to do that? I believe that everything is described in Installation Guide. I never did that, but - from what I heard - that is not a simple task.

As of iAS version: I guess that the one you mentioned is OK.
Re: Application Server Installation [message #545366 is a reply to message #545294] Tue, 28 February 2012 22:23 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Thanks for reply,

Yes i want develop forms on Application Server. I want to know that for this purpose Oracle Application Server 10g Release 2
(10.1.2) is the only option or any other option is still there.

Thanks & Regards.

[Updated on: Tue, 28 February 2012 22:24]

Report message to a moderator

Re: Application Server Installation [message #545881 is a reply to message #545366] Fri, 02 March 2012 23:38 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Dear members i have database server d1 on which Oracle 10g release 2 is running on windows 2003 server. Now i want to install application server 10g release 2 on 2nd server like D2 and want to use database of d1 server. I have plan to install this option
Business Intelligence and Forms Developer Topology (includes OracleAS Infrastructure). will i have to install the database on the 2nd server d2.

Please provide answer in detail how i install the application server 10g that uses the database on another server.

Thanks & Regards.

Re: Application Server Installation [message #545886 is a reply to message #545881] Sat, 03 March 2012 01:41 Go to previous messageGo to next message
John Watson
Messages: 4557
Registered: January 2010
Location: Global Village
Senior Member
Have you read the AS 10.1.2 installation guides yet? And of course the Concepts?
http://docs.oracle.com/cd/B14099_19/nav/docindex.htm
It is not clear whether when you say "database" you mean the customer database that stores your application data, or the infrastructure database that is part of AS Enterprise Edition.
You can distribute all these components across different machnes, or on one machine. There is a High Availability Guide that describes this.
Re: Application Server Installation [message #545889 is a reply to message #545886] Sat, 03 March 2012 02:52 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Thanks for reply
Quote:
It is not clear whether when you say "database" you mean the customer database that stores your application data


yes it is custom database on server1 you can say db1. And i want to install application server and infrastructure on another server named db2. Does i need to install database that is part of AS Enterprise Edition on db2 server as well.

Please explain the main points how to configure application server that i will install on db2 server, with custom database(10g rel 2) that is already installed on db1 server.

Thanks & Regards
Re: Application Server Installation [message #545890 is a reply to message #545889] Sat, 03 March 2012 03:00 Go to previous messageGo to next message
John Watson
Messages: 4557
Registered: January 2010
Location: Global Village
Senior Member
You seem to have decided that entire AS installation, both Infrastructure instance and Middle Tier instance, will reside on one machine, and the customer database will reside on another. OK. Which part of the installation guide are you having trouble with?
Re: Application Server Installation [message #546503 is a reply to message #545890] Wed, 07 March 2012 04:03 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Dear Members

i have installed application server and infrastructure on server named DB2 with database that is part of AS Enterprise Edition.
Now i have put the forms and reports on this server and access them from remote computers. All the forms and reports run fine and they used the database that is part of AS Enterprise Edition on DB2.

Now i want to use the custom database(10g rel 2) that is installed on server DB1.
Please tell me how can i achieve this task.

Thanks & Regards.

[Updated on: Wed, 07 March 2012 04:04]

Report message to a moderator

Re: Application Server Installation [message #546549 is a reply to message #546503] Wed, 07 March 2012 06:05 Go to previous messageGo to next message
Littlefoot
Messages: 19608
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
If I understood it correctly, you need to update TNSNAMES.ORA and insert DB1's database alias in there.

Users would specify it when connecting to the application (username, password, database (which wouldn't be DB2 any more, but DB1)).
Re: Application Server Installation [message #546837 is a reply to message #546549] Fri, 09 March 2012 04:37 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Dear Members
I have solved the database problem.
Now i want my Single Sign-On authentication be disable when i get a new report.
i have made the following changes in
BI_ORACLE_HOME/reports/conf/<report_server_name>.conf
look for <security> --- </security> and comment it.
After changes it would look like

<!--security>
-
-
-
</security-->

But when i restart the report server it did not up and it show the status down. I have also restart the application server but same results.

Please tell me how to resolve this problem.

Thanks & Regards.
Re: Application Server Installation [message #546875 is a reply to message #546837] Fri, 09 March 2012 08:47 Go to previous messageGo to next message
joy_division
Messages: 4513
Registered: February 2005
Location: East Coast USA
Senior Member
Is this the same question as eskandar?

http://www.orafaq.com/forum/t/179496/66800/
Re: Application Server Installation [message #546916 is a reply to message #546875] Fri, 09 March 2012 23:12 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Dear Members
I have solved the problem. Instead of commenting I have just remove the security entry from BI_ORACLE_HOME/reports/conf/<report_server_name>.conf file. Now the report server is up and Single Sign on authentication is not shown when the report is running.

Thanks & Regards
Re: Application Server Installation [message #546920 is a reply to message #546916] Sat, 10 March 2012 00:17 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Dear Members
I have made the "projects folder" on application server and give complete sharing to remote systems. All the forms and reports run from that "project folder". The problem is that when a remote user "A" run a form like abc.fmx and the other user "B" at the same time make some changes in the abc.fmb and compile it and replace the file on the "project folder" on application server. It gives the error
" Cannot copy abc: The requested operation cannot be performed on a file with a user-mapped section open." and file is not replaced. I want when remote user "B" replaces the form. The form should be replaced. The remote user "A" will see the changed form when he run the form next time.

Thanks & Regards.
Re: Application Server Installation [message #546922 is a reply to message #546920] Sat, 10 March 2012 02:55 Go to previous messageGo to next message
Littlefoot
Messages: 19608
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
User A holds the form (as he uses it). It is expected that it can not be replaced at that time (something similar to a locked record; another user can't update or delete it until the one who locked it releases it). Basically, you should do the maintaining when people do not work on a system (for example, 01:00 AM). I understand that there are systems that run 24/7, but they also have to be maintained. I don't know whether your system is the same (I hope not). If it is, I don't know how updates are handled as I have never worked on such a system (moreover, it is not what I normally do). Hopefully, someone else will know.
Re: Application Server Installation [message #546923 is a reply to message #546922] Sat, 10 March 2012 03:06 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Thanks Littlefoot,
In our environment more than one user uses the same form for transaction. It is not possible every time that i want to update the form and i request those users to close the form.
Please tell me how to achieve this task.


Thanks & Regards
Re: Application Server Installation [message #546952 is a reply to message #546923] Sat, 10 March 2012 12:41 Go to previous messageGo to next message
Littlefoot
Messages: 19608
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
As far as I can tell (which I already did), there must be a maintenance "window" when nobody uses the application. There's no way to replace a form that is being used.
Re: Application Server Installation [message #547641 is a reply to message #546952] Thu, 15 March 2012 06:07 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

dear Littlefoot

I have added FORMS_MMAP=FALSE in my default.env file and it has solved my problem.
It is used to disabled the user mapped section.
Not much familiar with it but it has solved my problem.

Thanks and Regards
Re: Application Server Installation [message #547643 is a reply to message #547641] Thu, 15 March 2012 06:19 Go to previous messageGo to next message
sweetkhaliq
Messages: 189
Registered: April 2006
Senior Member

Dear Members,

Now i have made two folder on my application server named db2
1. Source folder (that includes fmb, mmb, rdf files)
2. Runtim folder. (that includes fmx,mmx files)
and give the desired sharing to developers.

I want developer load froms in form builder from source folder that is on application server, make necessary changes and after running and testing the form he replaced the fmx files from source folder to runtime folder.

problem is that when i run the form, from source folder in form builder it gives the error

"FRM-40010: can not read form"
\\db2\source\abc.fmx

i have also added the runtime path in default.env like forms_path=d:\source

Please tell me how i can run the form from source folder.

Thanks & Regards

[Updated on: Thu, 15 March 2012 06:20]

Report message to a moderator

Re: Application Server Installation [message #547647 is a reply to message #547643] Thu, 15 March 2012 06:51 Go to previous message
Littlefoot
Messages: 19608
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
About FORMS_MMAP: thank you for the information, I didn't know that it exists.

However: Googling around (such as here), it appears that - in production systems - it should be set to TRUE. Well, regarding the fact that I know nothing about it, I suppose that I shouldn't complain about your solution as long as you're happy with it. Hopefully, someone who knows better will say a word or two (too bad that such people don't stop by very often).

As of your new problem:
Oracle

FRM-40010: Cannot read form %s.

Cause:  One of the following:
1. You entered a nonexistent form name.
2. You typed an incomplete path.
3. You do not have the proper privileges to run the form.
4. You do not have a compiled copy of the form.

Action:  Retype the form name correctly, provide the proper path name, compile the form, or contact the DBA.

Obviously, you can open the form from that directory. But, do you have privileges to WRITE in it?
Previous Topic: 10g Application Server
Next Topic: Report Server
Goto Forum:
  


Current Time: Wed Sep 17 21:26:41 CDT 2014

Total time taken to generate the page: 0.07541 seconds