Home » Applications » Oracle Fusion Apps & E-Business Suite » Issue in passing FND_STANDARD_DATE to a concurrent program using CONCSUB (RDBMS : 11.2.0.2.0, Oracle Applications : 12.1.3)
Issue in passing FND_STANDARD_DATE to a concurrent program using CONCSUB [message #542034] Sat, 04 February 2012 01:25 Go to next message
Nshan
Messages: 62
Registered: February 2009
Member
Hi All,

I am having one concurrent program of type HOST which is having one parameter of date type. for that i am using FND_STANDARD_DATE value set.

From this concurrent program (Shell) i am invoking another one using CONCSUB command.

Accepted value for that date parameter is - "2011/09/29 00:00:00"

My call to 2nd program is as below

CONCSUB APPS/$USER_PWD $RESP_SHORT_NAME "$RESP_NAME" $USER WAIT=Y CONCURRENT $VAL_RESP_SHORT_NAME XXG_AR_AUTOCASH_VAL "$REQUEST_ID" "$TRANSMISSION_NAME" "$TRANSMISSION_FORMAT_ID" "$ORG_ID" "$FILE_TYPE" "${GL_OVER_DATE}">$SRC_DIR/XXGAR2190_VALIDATE_LOCKBOX_$DATE.out

Whenever date value is passed to a 2nd program it is getting passed as below

88578006, CA823110817011374, 75020, 249, 823, 2011/09/29, 00:00:00

because of space between date and mins it is going as an additional parameter with comma.
I have tried with brackets also it is not working.
Because of this issue my program is erroring out saying wrong number of arguments to the concurrent program.

Any help on this issue is appreciated.
Thanks in advance.


Thanks,
Nshan.
Re: Issue in passing FND_STANDARD_DATE to a concurrent program using CONCSUB [message #542131 is a reply to message #542034] Sat, 04 February 2012 13:29 Go to previous messageGo to next message
vamsi kasina
Messages: 2089
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
Some one has already asked (resolved on own) the similar question just few threads down.
Please check the link.

By
Vamsi
Re: Issue in passing FND_STANDARD_DATE to a concurrent program using CONCSUB [message #542135 is a reply to message #542131] Sun, 05 February 2012 00:40 Go to previous message
Nshan
Messages: 62
Registered: February 2009
Member
Hi Vamsi,

Issue is resolved as per notes in the link you have mentioned.
Thanks a lot.

By,
Nshan
Previous Topic: operating units, 11i to r12
Next Topic: Failing to create invoice using ar_invoice_api_pub.create_single_invoice
Goto Forum:
  


Current Time: Sat Apr 19 20:22:54 CDT 2014

Total time taken to generate the page: 0.07549 seconds