Home » Applications » Oracle Fusion Apps & E-Business Suite » No data for View during run time !!! (Forms 10g)
No data for View during run time !!! [message #541167] Sun, 29 January 2012 01:05 Go to next message
eshta
Messages: 33
Registered: February 2006
Location: Saudi Arabia
Member

Hello,

There is a view from Oracle APPS related to Purhcasing Module which I want to uses it fetch the data to the form.

from back end it is needed to execute the command to view its contents:

dbms_application_info.set_client_info('0')

I tried to do that in the form under When-new-form-instance trigger even when-new-block-instance trigger but alway showing the message:

FRM-40350: Query Caused no records to be retrieved.

Please adivse.

[Updated on: Sun, 29 January 2012 13:52] by Moderator

Report message to a moderator

Re: No data for View during run time !!! [message #541202 is a reply to message #541167] Sun, 29 January 2012 13:51 Go to previous messageGo to next message
vamsi kasina
Messages: 2096
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
What is the version of Oracle Apps?
What is the Purchasing view?
Are you using single org structure or multiple?
What is the org_id?

By
Vamsi
Re: No data for View during run time !!! [message #541205 is a reply to message #541202] Sun, 29 January 2012 23:13 Go to previous messageGo to next message
eshta
Messages: 33
Registered: February 2006
Location: Saudi Arabia
Member

The view is PO_HEADER_INQ_V from purchasing.

Oracle Application EBS 11i

in the Oracle forms 10g I am trying to query this view. no data retreived.
Re: No data for View during run time !!! [message #541206 is a reply to message #541205] Sun, 29 January 2012 23:28 Go to previous messageGo to next message
vamsi kasina
Messages: 2096
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
Still waiting forQuote:
Are you using single org structure or multiple?
What is the org_id?
By
Vamsi
Re: No data for View during run time !!! [message #541209 is a reply to message #541206] Sun, 29 January 2012 23:59 Go to previous messageGo to next message
eshta
Messages: 33
Registered: February 2006
Location: Saudi Arabia
Member

Dear, I don't know the relation between the issue and your questions?

Because in sql it is running find, but form level this command which activate the view is not working.

By the way, we are using single orgniazation structre. but what orgnization id you are asking?
Re: No data for View during run time !!! [message #541329 is a reply to message #541209] Mon, 30 January 2012 08:30 Go to previous messageGo to next message
vamsi kasina
Messages: 2096
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
Quote:
dbms_application_info.set_client_info('0')
Because you have used zero as org_id, I just wanted to confirm you are using single organization structure.

May be the form is having extra logic somewhere else (in between the new instance and query) to revert your settings, which you are using in the above code.
Try the same in PRE-QUERY trigger.

By
Vamsi
Re: No data for View during run time !!! [message #541330 is a reply to message #541329] Mon, 30 January 2012 08:48 Go to previous messageGo to next message
eshta
Messages: 33
Registered: February 2006
Location: Saudi Arabia
Member

Yes confirmed it is single orgnization structe.

I used it in pre-query but also didn't work.

Also, i hvae tried to use:

fnd_global.apps_initialize(0,20420,1);

from sql it working but form level the same issue.

Thank you very much for your replies and support.
Re: No data for View during run time !!! [message #541494 is a reply to message #541330] Tue, 31 January 2012 12:56 Go to previous message
vamsi kasina
Messages: 2096
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
Tried checking the code for the view.Quote:
Got doubt on the following.
1. NVL's on org_id
2. USERENV('CLIENT_INFO')
3. USERENV('LANG')
As it is working from back end sql, CLIENT_INFO and NVL's should not be an issue.
So, I suspect on the LANG setting.
Please crosscheck the above USERENV's from Help -> Diagnostics -> Examine.

By
Vamsi
Previous Topic: personalization on HTML page
Next Topic: operating units, 11i to r12
Goto Forum:
  


Current Time: Sun Dec 21 13:31:36 CST 2014

Total time taken to generate the page: 0.05687 seconds