Home » Developer & Programmer » Reports & Discoverer » Incorrect page number at Oracle Reports (2 threads merged by bb) (Reports Builder 10.1.2 Oracle 11.2.0)
Incorrect page number at Oracle Reports (2 threads merged by bb) [message #539547] Tue, 17 January 2012 00:34 Go to next message
sourajit_seth
Messages: 38
Registered: November 2005
Location: India
Member
Hi,
I am working on the Reports Builder 10.1.2 at the Database Oracle 11.2.0. I have developed a report , which shows the page number at top right cornet. So I have selected a field and set the Source as "page Number". While I run the report through Reports Builder,it is properly displayed the page number. But while I copied the report to unix and run thorugh "$ORACLE_INSTANCE/config/reports/bin/rwrun.sh", the page number is showing as 65536 . By changing the Source of the field to "Total Page" or "Physical page Number" make no difference. Every times It is showing the page number 65536 in the pdf output of the report. Please help.

Thanks and Regards
Sourajit
Re: Incorrect page number at Oracle Reports (2 threads merged by bb) [message #539557 is a reply to message #539547] Tue, 17 January 2012 02:36 Go to previous messageGo to next message
Littlefoot
Messages: 19351
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Try to recompile the report on Unix (choose "Compile All" - Ctrl + Shift + K).
Re: Incorrect page number at Oracle Reports (2 threads merged by bb) [message #539699 is a reply to message #539557] Wed, 18 January 2012 02:53 Go to previous messageGo to next message
sourajit_seth
Messages: 38
Registered: November 2005
Location: India
Member
Hi
Thanks for your response. Earlier we used rwcon60 to compile
the report in UNIX. Now in Report 10G , how can I compile it ? I tried to compile using following command, but it is not working.'

rwconverter.sh scott/tiger@mydb stype=rdffile source=inven1.rdf dtype=rdffile dest=inven1_new.rdf compile_all=YES

Regards
Sourajit
Re: Incorrect page number at Oracle Reports (2 threads merged by bb) [message #539705 is a reply to message #539699] Wed, 18 January 2012 03:19 Go to previous messageGo to next message
Littlefoot
Messages: 19351
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I wouldn't know how to do that using the command prompt; I compile my reports in Reports Developer. Hopefully, someone else will know.
Re: Incorrect page number at Oracle Reports (2 threads merged by bb) [message #539892 is a reply to message #539705] Thu, 19 January 2012 02:04 Go to previous messageGo to next message
sourajit_seth
Messages: 38
Registered: November 2005
Location: India
Member
Hi,
It is resolved by compiling the Report at Reports Builder 11.1.1.

Regards
Sourajit
Re: Incorrect page number at Oracle Reports (2 threads merged by bb) [message #539894 is a reply to message #539892] Thu, 19 January 2012 02:14 Go to previous messageGo to next message
Littlefoot
Messages: 19351
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
On what machine?
icon14.gif  Re: Incorrect page number at Oracle Reports (2 threads merged by bb) [message #578585 is a reply to message #539894] Fri, 01 March 2013 10:04 Go to previous message
hemant42
Messages: 1
Registered: March 2013
Junior Member
Hi,

I had the same problem.
While developing I used Oracle Reports Builder 10 the generated reports that were working on the server with Reports 10.
After upgrade of the Server to Reports 11g the pages were starting at 65536 and increasing by more than one number per page.

After installing the Reports Builder 11 and opening the saving the corresponding .rdf file the problem disappears on the server.
You will notice the change of file size of the .rdf file after saving with Reports Builder 11.
Reports generated with Reports Builder 10 do not work correct on Oracle Report Server 11.

Regards

Hemant
Previous Topic: using a cursor
Next Topic: i want to convert layout oracle graph direction from left to right
Goto Forum:
  


Current Time: Sat Aug 02 04:28:54 CDT 2014

Total time taken to generate the page: 0.07464 seconds