Home » Developer & Programmer » Forms » Navigation problem using go item
Navigation problem using go item [message #538719] Mon, 09 January 2012 03:45 Go to next message
Phom
Messages: 8
Registered: January 2012
Location: Durban
Junior Member
Help please guys; I'm using go_item to open the canvas but the cursor doesnt want to focus on the item. I have to mouse click the item before I can enter any data or tab through it.
Re: Navigation problem using go item [message #538727 is a reply to message #538719] Mon, 09 January 2012 03:59 Go to previous messageGo to next message
Littlefoot
Messages: 19525
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Is that item keyboard navigable?
Re: Navigation problem using go item [message #538728 is a reply to message #538727] Mon, 09 January 2012 04:06 Go to previous messageGo to next message
Phom
Messages: 8
Registered: January 2012
Location: Durban
Junior Member
Yes it is.
Re: Navigation problem using go item [message #538729 is a reply to message #538728] Mon, 09 January 2012 04:09 Go to previous messageGo to next message
Littlefoot
Messages: 19525
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Is there any difference if you specify a block name? Such as
go_item('block_name.that_item');
Re: Navigation problem using go item [message #538730 is a reply to message #538729] Mon, 09 January 2012 04:13 Go to previous messageGo to next message
Phom
Messages: 8
Registered: January 2012
Location: Durban
Junior Member
thats exactly how I wrote it. I have...
go_block('block_name');
execute_query/
go_item('block_name.item_name');
Re: Navigation problem using go item [message #538732 is a reply to message #538730] Mon, 09 January 2012 04:17 Go to previous messageGo to next message
Littlefoot
Messages: 19525
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Is there any SET_ITEM_PROPERTY that modifies item's (you are trying to navigate to) properties? If so, when is it set?
Re: Navigation problem using go item [message #538733 is a reply to message #538730] Mon, 09 January 2012 04:17 Go to previous messageGo to next message
cookiemonster
Messages: 10929
Registered: September 2008
Location: Rainy Manchester
Senior Member
What trigger is that code in?
Are you in enter-query mode when it's fired?
Are both blocks the same block?
What's the canvases raise on entry property set to?
Re: Navigation problem using go item [message #538734 is a reply to message #538733] Mon, 09 January 2012 04:18 Go to previous messageGo to next message
cookiemonster
Messages: 10929
Registered: September 2008
Location: Rainy Manchester
Senior Member
Where does the cursor end up after that code is run?
Re: Navigation problem using go item [message #538735 is a reply to message #538732] Mon, 09 January 2012 04:25 Go to previous messageGo to next message
Phom
Messages: 8
Registered: January 2012
Location: Durban
Junior Member
No set item properties fot that specific item but I do have for other items. data blocks are diff. the code is in WHEN-NEW-ITEM-INSTANCE of the from item. the form is not in the query mode. Canvas raised on entry is a NO as for destination of the cursor am not sure but I can tell you its in that item i'm navigating to, the item is selected(changed color to show that cursor should focus there) but I cnt update until I click on it.
Re: Navigation problem using go item [message #538737 is a reply to message #538735] Mon, 09 January 2012 04:32 Go to previous messageGo to next message
cookiemonster
Messages: 10929
Registered: September 2008
Location: Rainy Manchester
Senior Member
Set raise on entry to yes and see what happens.
Re: Navigation problem using go item [message #538742 is a reply to message #538735] Mon, 09 January 2012 04:40 Go to previous messageGo to next message
Phom
Messages: 8
Registered: January 2012
Location: Durban
Junior Member
No diff, you know what really strange abt this, I have two ways to get to my item:
1. when I tab into my FROM item, its goes to my TO item, thats works fine, I can update the TO item without having to mouse click first.
2. when I click my FROM item still opens my TO item but this time it doesnt allow me to update without having to click the item first...hope you get what I'm trying to say.
Re: Navigation problem using go item [message #538745 is a reply to message #538742] Mon, 09 January 2012 04:48 Go to previous messageGo to next message
Phom
Messages: 8
Registered: January 2012
Location: Durban
Junior Member
I changed raise on entry, still doesnt work. Thanks a lot for your times guys.
Re: Navigation problem using go item [message #538779 is a reply to message #538719] Mon, 09 January 2012 07:03 Go to previous messageGo to next message
azamkhan
Messages: 492
Registered: August 2005
Senior Member
You should check your code. I think that your navigation/focus is send to a different item.
Re: Navigation problem using go item [message #538782 is a reply to message #538779] Mon, 09 January 2012 07:09 Go to previous messageGo to next message
Phom
Messages: 8
Registered: January 2012
Location: Durban
Junior Member
FROM item runs the same code for both cases,
WHEN-NEW-ITEM-INSTANCE has go_item('TO_item_name') meaning when you tab into the FROM item it takes you to my TO item even when you click the FROM item its still going to run the same code.
Re: Navigation problem using go item [message #538793 is a reply to message #538782] Mon, 09 January 2012 08:54 Go to previous messageGo to next message
cookiemonster
Messages: 10929
Registered: September 2008
Location: Rainy Manchester
Senior Member
Can you run the form in debug mode and see if any other triggers are firing?
Re: Navigation problem using go item [message #539100 is a reply to message #538793] Wed, 11 January 2012 05:27 Go to previous messageGo to next message
aallan
Messages: 150
Registered: October 2011
Senior Member
try to use Go_Record
Re: Navigation problem using go item [message #539111 is a reply to message #539100] Wed, 11 January 2012 06:23 Go to previous message
Phom
Messages: 8
Registered: January 2012
Location: Durban
Junior Member
go_record doesnt work...thanks
Previous Topic: List forms global variables at runtime
Next Topic: Commit_Form issue in Oracle Forms
Goto Forum:
  


Current Time: Sat Aug 30 01:56:37 CDT 2014

Total time taken to generate the page: 0.25410 seconds