Home » Developer & Programmer » Application Express & MOD_PLSQL » Strange error on tabular form (Application Express, 4.0, windows 7)
Strange error on tabular form [message #534703] Thu, 08 December 2011 09:25
abarnybox
Messages: 49
Registered: November 2011
Member
Hi,

I'm not actually entounterring an 'Error' as such but there is a problem. I have created a wizard and on one of the pages there is a tabular form. I changed the SUBMIT label to 'next>' and deleted the NEXT button and swapped a few other processes to new buttons, no problem there. The problem comes when I try and go back to edit it for the second time. It deletes the previously created records...
So I enter the record click next and it enters the database fine, I click previous, it displays, I click next and then come back to it again, and the records are gone...
now I checked the database after each click and it actually gets deleted the second time I click 'next'
so yeh...anyone know what the problem is? a problem with the update process maybe?
it may be worth noting that this only happens if I don't actually edit the records, if I do edit the records I do get an error - Error in mru internal routine: ORA-20001: Error in MRU: row= 1, ORA-20001:ORA-20001: Current version of data in database has changed since user initiated update process.

regards
abarnybox

EDIT: OK, I fixed the error but the deleting thing is still happening...:/

[Updated on: Thu, 08 December 2011 09:30]

Report message to a moderator

Previous Topic: Validating fields in a table
Next Topic: Email attachment help
Goto Forum:
  


Current Time: Sun Dec 28 07:50:54 CST 2014

Total time taken to generate the page: 0.03678 seconds