Home » SQL & PL/SQL » Client Tools » Unsupported Oracle database version (sql developer 1.5.1 windows XP)
Unsupported Oracle database version [message #534692] Thu, 08 December 2011 08:30 Go to next message
9390512774
Messages: 97
Registered: January 2011
Location: hyd
Member
Hi experts ,
when i am trying to connect to the database using sqldeveloper i am not able to connect to database. its giving me an error
"Unsupported Oracle database version"
but with plsql developer I am able to connecting. please let me the solution for this issues.
your help is greatly appreciated.
Re: Unsupported Oracle database version [message #534693 is a reply to message #534692] Thu, 08 December 2011 08:32 Go to previous messageGo to next message
BlackSwan
Messages: 22790
Registered: January 2009
Senior Member
SELECT * FROM V$VERSION

post results from SQL above
Re: Unsupported Oracle database version [message #534694 is a reply to message #534692] Thu, 08 December 2011 08:35 Go to previous messageGo to next message
Michel Cadot
Messages: 59142
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You are trying to connect to which version number?.
Try to download a newer version of SQL Developer, yours is really old:
http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html

Regards
Michel
Re: Unsupported Oracle database version [message #534695 is a reply to message #534694] Thu, 08 December 2011 08:48 Go to previous messageGo to next message
9390512774
Messages: 97
Registered: January 2011
Location: hyd
Member
my database is oracle 8i version.
Re: Unsupported Oracle database version [message #534696 is a reply to message #534695] Thu, 08 December 2011 08:52 Go to previous messageGo to next message
BlackSwan
Messages: 22790
Registered: January 2009
Senior Member
I see you do not read & follow simple directions.
newer Oracle version do not inter-operate with older Oracle versions.
Please join 21st Century at your earliest convenience.

It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/
Re: Unsupported Oracle database version [message #534697 is a reply to message #534695] Thu, 08 December 2011 08:52 Go to previous messageGo to next message
Michel Cadot
Messages: 59142
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
As far as I know, SQL Developer does not connect to database lower than 8i.
Anyway, download a newer version.

Regards
Michel
Re: Unsupported Oracle database version [message #534741 is a reply to message #534697] Thu, 08 December 2011 15:30 Go to previous messageGo to next message
Littlefoot
Messages: 19619
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
This will probably NOT help; however (talking from my own experience - reality might be different for someone who went deeper into it): TOAD requires Oracle Client to be installed in order to connect to an Oracle database. Having a brand new computer running under MS Windows 7 lead to an idea: install the newest (and supported) Oracle Client - 11g! That wasn't a very good idea - recent (10.x) TOAD version refuses to connect to Oracle 8i (similarly to SQL Developer), so I thought I'd install a lower Client version - let it be 10g. The truth is: instead of a client software, I installed a database (10g Express Edition), and TOAD connected smoothly to 8.1.7.

I'm not sure whether SQL Developer requires Oracle Client or not. If it does, try with 10g (actually, never mind - try to install 10g Client (or 10g XE; experiment a little bit) in any case! You'll get access to useful SQL*Loader, export & import utilities and similar features).
Re: Unsupported Oracle database version [message #598721 is a reply to message #534741] Thu, 17 October 2013 02:35 Go to previous messageGo to next message
rwiener
Messages: 1
Registered: September 2013
Location: Prague, Czech Republic
Junior Member
Hi,

SQL Developer version 1.2.1 is able to connect to 8.1.7 with limited functionality (prepared reports and browser for objects could not work)..

Next version (tested with 3.2 64-bit) of SQL developer could be "hacked" to connect to 8.1.7 by simply copy file C:\oracle\product\10.2.0\client_1\jdbc\lib\classes12.zip from Oracle client prior 11
into appropriate jdk\jre\lib\ext folder.
Re: Unsupported Oracle database version [message #598732 is a reply to message #598721] Thu, 17 October 2013 04:09 Go to previous message
John Watson
Messages: 4565
Registered: January 2010
Location: Global Village
Senior Member
rwiener wrote on Thu, 17 October 2013 08:35
Hi,

SQL Developer version 1.2.1 is able to connect to 8.1.7 with limited functionality (prepared reports and browser for objects could not work)..

Next version (tested with 3.2 64-bit) of SQL developer could be "hacked" to connect to 8.1.7 by simply copy file C:\oracle\product\10.2.0\client_1\jdbc\lib\classes12.zip from Oracle client prior 11
into appropriate jdk\jre\lib\ext folder.
Wow! That is a brilliant first post, Richard (assuming that it is correct Razz ). Please keep posting.

And to do the moderator bit:

Welcome to the forum. Please read our OraFAQ Forum Guide and please read How to use [code] tags and make your code easier to read

Previous Topic: ORA_ROWSCN and SCN_TO_TIMESTAMP - in Toad
Next Topic: SQL problem
Goto Forum:
  


Current Time: Fri Sep 19 11:01:36 CDT 2014

Total time taken to generate the page: 0.12881 seconds