Home » Developer & Programmer » Application Express & MOD_PLSQL » ORA-01403: no data found (Application Express, 4.0, windows 7)
ORA-01403: no data found [message #533749] Thu, 01 December 2011 04:20 Go to next message
abarnybox
Messages: 49
Registered: November 2011
Member
Hi,

I've encountered this error a number of times on all my forms,
ORA-01403: aucune donnée trouvée
unable to fetch row
It happens before the page is loaded.
What I did was just delete the 'Fetch row from TABLE NAME' process which happens after header and that stopped it...
I was wondering what that process actually means? Do I need it or is deleting it ok?
If I do need it how do I stop the error?

thanks
abarnybox


ORA-01403: aucune donnée trouvée = ORA-01403: no data found

[Updated on: Thu, 01 December 2011 04:31]

Report message to a moderator

Re: ORA-01403: no data found [message #533756 is a reply to message #533749] Thu, 01 December 2011 04:37 Go to previous messageGo to next message
Littlefoot
Messages: 19516
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Run it in debug mode and you'll most probably find the culprit.
Re: ORA-01403: no data found [message #533762 is a reply to message #533756] Thu, 01 December 2011 04:48 Go to previous messageGo to next message
abarnybox
Messages: 49
Registered: November 2011
Member
it says no data found...unless i'm doing it wrong
click on 'debug' to activate then 'view debug' to view it?
Re: ORA-01403: no data found [message #533763 is a reply to message #533762] Thu, 01 December 2011 04:49 Go to previous messageGo to next message
Littlefoot
Messages: 19516
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Yes.
Re: ORA-01403: no data found [message #533767 is a reply to message #533762] Thu, 01 December 2011 04:53 Go to previous messageGo to next message
abarnybox
Messages: 49
Registered: November 2011
Member
Wait no I was doing it wrong, I got it though I have no idea what it means:
View Identifier    Session            User      Application  Page   Entries   Timestamp         Seconds 
501                2100539737622706   X149302   128          2      46        61 seconds ago    0.3990 

and then when I click on the 501 a big table comes up with lots of confusing nonsense as far as I can tell Razz

[Updated on: Thu, 01 December 2011 04:54]

Report message to a moderator

Re: ORA-01403: no data found [message #533770 is a reply to message #533767] Thu, 01 December 2011 04:55 Go to previous messageGo to next message
Littlefoot
Messages: 19516
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Well, you'll have to read that nonsense until you find NO-DATA-FOUND and what is causing it.
Re: ORA-01403: no data found [message #533775 is a reply to message #533770] Thu, 01 December 2011 05:00 Go to previous messageGo to next message
abarnybox
Messages: 49
Registered: November 2011
Member
its not there...
Re: ORA-01403: no data found [message #533788 is a reply to message #533775] Thu, 01 December 2011 05:32 Go to previous messageGo to next message
Littlefoot
Messages: 19516
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
In that case, no further ideas, sorry.
Re: ORA-01403: no data found [message #533790 is a reply to message #533788] Thu, 01 December 2011 05:34 Go to previous messageGo to next message
abarnybox
Messages: 49
Registered: November 2011
Member
ok.
What does the Fetch row from TABLE_NAME actually do?
Re: ORA-01403: no data found [message #534026 is a reply to message #533790] Fri, 02 December 2011 04:32 Go to previous message
abarnybox
Messages: 49
Registered: November 2011
Member
I sorted it, needed to clear the page cache.
Previous Topic: Set X with Y when Branching
Next Topic: How do I pass arguments between pages
Goto Forum:
  


Current Time: Thu Aug 28 04:37:45 CDT 2014

Total time taken to generate the page: 0.11916 seconds