Home » RDBMS Server » Networking and Gateways » Problem with ORACLE_HOME (Windows xp VM with Oracle 10g + tools)
Problem with ORACLE_HOME [message #532769] Thu, 24 November 2011 09:40 Go to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Hi,

I've recently installed Oracle 10g Database onto a Windows XP Virtual Machine. The installation directory is C:\oracle\product\10.2.0\db_1.

After resolving a few issues with the listener and TNSNames.ora i've managed to access SQL Plus and entered a few tables etc.

I wanted to install oracle forms and reports so I installed the "Complete" package which installed to C:\DevSuiteHome_1\.

I've created a form etc, but I can't run the OC4J instance because ORACLE_HOME is pointing to C:\oracle\product\10.2.0\db_1.

When I point it to C:\DevSuiteHome_1\ then restart the VM, the listener and SQL Plus services fail to start.

What is my way around this? Is there any way of using both?

Thanks,

Jon
Re: Problem with ORACLE_HOME [message #532774 is a reply to message #532769] Thu, 24 November 2011 09:52 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
When reading other forum topics it appears other users are using ORACLE_HOME for both the Database and the Devsuite, but I dont see how this is possible with two different directories?
Re: Problem with ORACLE_HOME [message #532782 is a reply to message #532774] Thu, 24 November 2011 11:45 Go to previous messageGo to next message
BlackSwan
Messages: 21945
Registered: January 2009
Senior Member
> I dont see how this is possible with two different directories?
open two different sessions/windows
Re: Problem with ORACLE_HOME [message #532840 is a reply to message #532782] Fri, 25 November 2011 02:56 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Thanks for the reply, I'm confused, as I only set one ORACLE_HOME environment, opening a second window will just cause the same issue?
Re: Problem with ORACLE_HOME [message #532843 is a reply to message #532840] Fri, 25 November 2011 03:03 Go to previous messageGo to next message
John Watson
Messages: 4082
Registered: January 2010
Location: Global Village
Senior Member
In one window,

set ORACLE_HOME=C:\oracle\product\10.2.0\db_1
set PATH=%ORACLE_HOME%\bin;%PATH%

and in the other,

set ORACLE_HOME=C:\DevSuiteHome_1
set PATH=%ORACLE_HOME%\bin;%PATH%

Does that help?
Re: Problem with ORACLE_HOME [message #532847 is a reply to message #532843] Fri, 25 November 2011 03:17 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Do you mean in CMD.exe? If so, I tried it, but I still get the error when opening Oracle Forms. I have ORACLE_HOME listed in my Environment Variables in Control Panel > System > Advanced. Do I need to remove this first?
Re: Problem with ORACLE_HOME [message #532853 is a reply to message #532847] Fri, 25 November 2011 03:34 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Bit of a rhetorical question, I've done that and it works Smile Thanks very much for you help, I have another problem now where I've started the OC4j Instance, but I cant access localhost:8888 (where localhost is the hostname) I just receive a "Internet Explorer cannot display the webpage".

localhost:5560 works fine for SQL Plus.

Any ideas?

http://img265.imageshack.us/img265/3843/oracleh.png

Uploaded with ImageShack.us

[Updated on: Fri, 25 November 2011 03:43]

Report message to a moderator

Re: Problem with ORACLE_HOME [message #532856 is a reply to message #532847] Fri, 25 November 2011 03:43 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
What happens if you leave ORACLE_HOME "as is" (i.e. to point to the database directory: C:\oracle\product\10.2.0\db_1), and edit OC4J.PROPERTIES file (located here: C:\Oracle\DevSuiteHome\j2ee\DevSuite\config)? What's in there now? Backup that value (in a case you'll want/need to restore it). Set the "oracle.home" line to
oracle.home=C:\Oracle\DevSuiteHome_1
and start OC4J. Any improvement?
Re: Problem with ORACLE_HOME [message #532857 is a reply to message #532856] Fri, 25 November 2011 03:46 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Ah, you got it! OK then, next problem: go to Forms' Edit menu, choose Preferences, go to Runtime tab. Reset Application server URL to default and try again.

Also, in Internet Explorer, go to Tools, Internet Options, Advanced - verify whether "Allow active content to run in files on My Computer" is checked (should be).
Re: Problem with ORACLE_HOME [message #532859 is a reply to message #532857] Fri, 25 November 2011 03:49 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Thanks for your suggestion, I've already done this, but I think its still a problem with the OC4J instance as I get the "FRM-10142: The HTTP Listener is not running..." error and I cant access Localhost:8888. You'll see above though that my instance is running!

Any other ideas?

It might be worth noting that I have a C:\DevsuiteHome\j2ee\home as well as a C:\Devsuitehome\j2ee\devsuite

The config files were originally in the home directory and I copied these out to the devsuite directory where the batch file is.

[Updated on: Fri, 25 November 2011 03:51]

Report message to a moderator

Re: Problem with ORACLE_HOME [message #532863 is a reply to message #532859] Fri, 25 November 2011 03:59 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Is port 8888 OK? If it is, what happens if you substitute "localhost" with your computer's name (such as "jonnypc:8888")?
Re: Problem with ORACLE_HOME [message #532865 is a reply to message #532863] Fri, 25 November 2011 04:02 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Hi Littlefoot,

Thanks again for the reply, I've tried substituting with the hostname already but to no avail. Without sounding too amateur, how can I check to see if port 8888 is ok? I'm using a Virtual Machine.

Thanks,

Jon
Re: Problem with ORACLE_HOME [message #532868 is a reply to message #532865] Fri, 25 November 2011 04:14 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
See what's in oracle_home/install/portlist.ini file.
Re: Problem with ORACLE_HOME [message #532869 is a reply to message #532868] Fri, 25 November 2011 04:22 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
The file doesn't exist in DevSuitHome, but it does in the database location and contains:

iSQL*Plus HTTP port number =5560
Re: Problem with ORACLE_HOME [message #532872 is a reply to message #532869] Fri, 25 November 2011 04:27 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
That's, obviously, not the one.

Default Forms ports are 8888 and 8889. What happens if you modify it to this value?
Re: Problem with ORACLE_HOME [message #532876 is a reply to message #532872] Fri, 25 November 2011 04:41 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Do you mean on the oracle_home/install/portlist.ini file.

The iSQL*Plus HTTP port number =5560 entry is for the SQLPlus on the database. Am I meant to have a portlist.ini file in C:\Devsuitehome\install?

Re: Problem with ORACLE_HOME [message #532877 is a reply to message #532876] Fri, 25 November 2011 04:46 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Sorry, I meant to set port 8889 in Forms - Preferences - Runtime.
Re: Problem with ORACLE_HOME [message #532897 is a reply to message #532877] Fri, 25 November 2011 05:54 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Sorry for the late reply, the port is already set to 8889, I think its a problem with the OC4J settings maybe?

In the C:\DevSuiteHome_1\j2ee\DevSuite\config\http-web-site.xml

It's target point 8888, or I might be looking in the wrong place:

<web-site port="8888" display-name="OC4J 10g (10.0.2) HTTP Web Site">
Re: Problem with ORACLE_HOME [message #532902 is a reply to message #532897] Fri, 25 November 2011 06:10 Go to previous messageGo to next message
John Watson
Messages: 4082
Registered: January 2010
Location: Global Village
Senior Member
Quote:
"FRM-10142: The HTTP Listener is not running..." e
I hope this isn't a foolish comment, but is this message telling you the problem? You do need an HTTP listener, do you have one? Usually I would use the Apache web listener with Forms, it should be running under a Windows service. Does your release of Developer Suite come with opmn? If so, connect to your Dev Suite home and run
%ORACLE_HOME%\opmn\bin\opmnctl status -l
to see what is running and on what ports.
Re: Problem with ORACLE_HOME [message #532903 is a reply to message #532902] Fri, 25 November 2011 06:13 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Hmmm I have opmn in the Database directory but no opmnctl, in the Devsuite there isn't an opmn directory.

I thought the OC4J instance was meant to provide a http listener? This is my first time installing Oracle so I may have misunderstood!

[Updated on: Fri, 25 November 2011 06:14]

Report message to a moderator

Re: Problem with ORACLE_HOME [message #532906 is a reply to message #532903] Fri, 25 November 2011 06:19 Go to previous messageGo to next message
John Watson
Messages: 4082
Registered: January 2010
Location: Global Village
Senior Member
Oh. What I was describing is how it works with a BI & Forms AS 10.1.2 instance. I guess you are using a chopped down version. I know that OC4J as shipped with 10.1.3 can listen for HTTP, I did not think that OC4J as shipped with 10.1.2 could. Are you sure there is no Apache provided? Do you have %ORACLE_HOME%\Apache\Apache and the rest? And if no opmnctl, perhaps the apachectl utility?
Re: Problem with ORACLE_HOME [message #532907 is a reply to message #532906] Fri, 25 November 2011 06:24 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
In Devsuite there is an Apache\Apache\conf\dms.conf.sbs but nothing else in the Apache folders.

Did I miss something in the install maybe?
Re: Problem with ORACLE_HOME [message #532939 is a reply to message #532906] Fri, 25 November 2011 08:40 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
John Watson wrote on Fri, 25 November 2011 12:19
Oh. What I was describing is how it works with a BI & Forms AS 10.1.2 instance. I guess you are using a chopped down version. I know that OC4J as shipped with 10.1.3 can listen for HTTP, I did not think that OC4J as shipped with 10.1.2 could. Are you sure there is no Apache provided? Do you have %ORACLE_HOME%\Apache\Apache and the rest? And if no opmnctl, perhaps the apachectl utility?


I'm using 10.2.0 I believe
Re: Problem with ORACLE_HOME [message #533078 is a reply to message #532939] Mon, 28 November 2011 02:47 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Sorry to bump, anyone know why my Http listener is not working?
Re: Problem with ORACLE_HOME [message #533090 is a reply to message #533078] Mon, 28 November 2011 04:12 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I don't.

Anyway: I use Oracle database + Developer Suite on the same computer for years (actually, every now and then it is a new computer, and these products are installed again and again). Everything worked, works (hopefully, will be working) without any problems. I just don't know what you might have done wrong so that it doesn't work.
Re: Problem with ORACLE_HOME [message #533096 is a reply to message #533090] Mon, 28 November 2011 04:56 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
I'll try removing it, installing again and let you know what happens.
Re: Problem with ORACLE_HOME [message #533099 is a reply to message #533096] Mon, 28 November 2011 05:05 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Do that using Universal Installer. Once it is done, reboot. Go to Windows registry, find ORACLE (under HKEY-LOCAL-MACHINE / SOFTWARE) and delete it. Reboot again. Try to install it again - database first, Developer Suite next. Problems you might have should consider two TNSNAMES.ORA files (but that can be easily solved; Search the forum for TNS_ADMIN environment variable). Everything else that's already been suggested here is still valid (IE settings, Forms Properties settings).

Good luck!
Re: Problem with ORACLE_HOME [message #533107 is a reply to message #533099] Mon, 28 November 2011 05:40 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
I had a non working version of Oracle previously, I removed it but didn't do the registry bit which I think has caused my error above. I've removed the database now, but DevSuite still exists and doesn't show up in the uninstaller, any ideas how to remove this properly?
Re: Problem with ORACLE_HOME [message #533114 is a reply to message #533107] Mon, 28 November 2011 05:56 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Delete its directory (using Windows Explorer); if you already deleted Oracle registry entry, OK - if you didn't, do it now.
Re: Problem with ORACLE_HOME [message #533131 is a reply to message #533114] Mon, 28 November 2011 07:05 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Thanks its all gone now, before I begin installing again, should I remove the Environment variable "Path"? As its currently set to :

C:\DevSuiteHome_1\jdk\jre\bin\client;C:\DevSuiteHome_1\jlib;C:\DevSuiteHome_1\bin;C:\DevSuiteHome_1\jdk\jre\bin\client;C:\DevSuiteHom e_1\jre\1.4.2\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem
Re: Problem with ORACLE_HOME [message #533133 is a reply to message #533131] Mon, 28 November 2011 07:09 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Don't remove it! Just clean it from "Oracle"-related directories. From what you posted, its new look would be
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem
Re: Problem with ORACLE_HOME [message #533142 is a reply to message #533133] Mon, 28 November 2011 07:43 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
While Im waiting for Development suite to install, I just wanted to confirm that i'm running on a standalone VM and using a microsoft loopback adapter, should that make any difference.
Re: Problem with ORACLE_HOME [message #533148 is a reply to message #533142] Mon, 28 November 2011 08:23 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Can't believe it, a clean install fixed the problem. I didn't even have to specify an oracle home. I'm getting a "Data Execution Prevention" issue at the moment with IE 8, but I'll search around for a resolution. Many thanks for your help
Re: Problem with ORACLE_HOME [message #533157 is a reply to message #532769] Mon, 28 November 2011 08:53 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
I followed these steps to resolve my issue, I now need to update to a newer version of JLInitiator.

Quote:
The proper way to switch to Sun's Java VM which worked for me is by changing this
baseHTMLjinitiator=basejini.htm

to this
baseHTMLjinitiator=basejpi.htm

in the formsweb.cfg file.
Re: Problem with ORACLE_HOME [message #533163 is a reply to message #533157] Mon, 28 November 2011 09:41 Go to previous messageGo to next message
Jonnyboybick
Messages: 21
Registered: November 2011
Location: UK
Junior Member
Hmmm in the end couldnt get it to work so I just undid my steps in the above post and reverted back to IE7
Re: Problem with ORACLE_HOME [message #533166 is a reply to message #533163] Mon, 28 November 2011 10:18 Go to previous message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I'm glad you made it work!
Previous Topic: PMON register problem
Next Topic: Temporary Error ORA-12505/ORA-12521
Goto Forum:
  


Current Time: Sat Apr 19 00:39:17 CDT 2014

Total time taken to generate the page: 0.20236 seconds