Home » RDBMS Server » Networking and Gateways » DB not registered with listener (11gR2 on AIX 6.1)
DB not registered with listener [message #530652] Wed, 09 November 2011 08:44 Go to next message
caprikar
Messages: 222
Registered: March 2007
Senior Member
Hi,
I have standalone 11.2.0.2 database on AIX 6.1, after I installed I created a database called TEST using dbca and when I do listener status i dont see the database TEST registered in the listener. I tried
SQL> alter system register;

System altered.

then I deleted and recreated the listener using netca, the database still not registered in the listener. then I deleted the listner using netca and then added listener using
srvctl add listener -l LISTENER -p TCP:1521 -o /ora01/app/oracle/product/11.2.0.2 

and stared it using
srvctl start listener -l LISTENER

But again the DB is not getting registed, I verified the ORACLE_HOME, ORACLE_SID environment variables and they are all set right. Here is the listener status
LSNRCTL for IBM/AIX RISC System/6000: Version 11.2.0.2.0 - Production on 09-NOV-2011 09:39:56

Copyright (c) 1991, 2010, Oracle.  All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for IBM/AIX RISC System/6000: Version 11.2.0.2.0 - Production
Start Date                09-NOV-2011 09:35:26
Uptime                    0 days 0 hr. 4 min. 29 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      ON
Listener Parameter File   /ora01/grid/network/admin/listener.ora
Listener Log File         /ora01/grid/log/diag/tnslsnr/avvpdb01/listener/alert/log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=LISTENER)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=192.27.51.121)(PORT=1521)))
Services Summary...
Service "+ASM" has 1 instance(s).
  Instance "+ASM", status READY, has 1 handler(s) for this service...
The command completed successfully


I tried this both from ORACLE HOME as well as GI HOME and both times the database is not getting registered with the listener, can someone tell me what could be the reason?
Re: DB not registered with listener [message #530656 is a reply to message #530652] Wed, 09 November 2011 08:47 Go to previous messageGo to next message
BlackSwan
Messages: 21951
Registered: January 2009
Senior Member
https://forums.oracle.com/forums/thread.jspa?threadID=2307999&tstart=0

the SID keeps changing.

I am not sure what to believe
Re: DB not registered with listener [message #530657 is a reply to message #530652] Wed, 09 November 2011 08:51 Go to previous messageGo to next message
John Watson
Messages: 4091
Registered: January 2010
Location: Global Village
Senior Member
You probably need to set your local_listener instance parameter, so that the instance will find the listener:
alter system set local_listener='(ADDRESS=(PROTOCOL=tcp)(HOST=192.27.51.121)(PORT=1521))';

Re: DB not registered with listener [message #530659 is a reply to message #530657] Wed, 09 November 2011 08:58 Go to previous message
caprikar
Messages: 222
Registered: March 2007
Senior Member
thanks, that worked
Previous Topic: ORA-01031: insufficient privileges
Next Topic: Help Required in accessing MSACCESS from Oracle using heterogeneous Service Agents
Goto Forum:
  


Current Time: Sun Apr 20 15:23:09 CDT 2014

Total time taken to generate the page: 0.09032 seconds