Home » SQL & PL/SQL » Client Tools » Ignore Sql prompt and command entered while spooling (11g)
Ignore Sql prompt and command entered while spooling [message #528397] Mon, 24 October 2011 12:01 Go to next message
prax_14
Messages: 64
Registered: July 2008
Member
Dear friends,

Is it possible to ignore the sql command prompt and the command entered while spooling. I tried the to set echo off,term off and some more options but it did not work.

Example:
SQL> spool c:\test.log
SQL> Prompt "This is a test"
"This is a test"
SQL> spool off;

The spool file has the following
SQL> Prompt "This is a test"
"This is a test"
SQL> spool off;


Is it possible to set some options so that the spool file only contains output.
"This is a test"


Thanks in advance for you help.
Re: Ignore Sql prompt and command entered while spooling [message #528398 is a reply to message #528397] Mon, 24 October 2011 12:04 Go to previous messageGo to next message
BlackSwan
Messages: 25748
Registered: January 2009
Location: SoCal
Senior Member
sqlplus -s

does above help?
Re: Ignore Sql prompt and command entered while spooling [message #528401 is a reply to message #528397] Mon, 24 October 2011 12:18 Go to previous messageGo to next message
Michel Cadot
Messages: 65254
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
I tried the to set echo off,term off and some more options but it did not work.

They work when you call a script.
They do not work in interactive mode (otherwise how could you know what you type?)

Regards
Michel
Re: Ignore Sql prompt and command entered while spooling [message #528402 is a reply to message #528401] Mon, 24 October 2011 12:24 Go to previous message
prax_14
Messages: 64
Registered: July 2008
Member
Thanks Guys...that was helpful. -s (silent mode) option with sqlplus works.
Previous Topic: Unable to expand and see the tables under schema
Next Topic: Spool in UTF8 not always works
Goto Forum:
  


Current Time: Thu Dec 14 09:36:48 CST 2017

Total time taken to generate the page: 0.02060 seconds