Home » RDBMS Server » Enterprise Manager » How to set Preferred Credentials for Host in OEM 11g (OEM11g Grid Control)
How to set Preferred Credentials for Host in OEM 11g [message #528349] Mon, 24 October 2011 07:12 Go to next message
daverich
Messages: 23
Registered: January 2010
Location: UK
Junior Member
Hi,

I am having a problem in setting Preferred Credentials in OEM. Can experts in this forum can help, Please.


My env:
O/S: Oracle Enterprise Linux 5.3
OEM: 11g Grid Control.

My OEM is running as expected. I have a few target database instances on different hosts. I can login and monitor all these database instances. Now I am trying to set Preferred Credentials to hosts but none is working. I am doing this as:

1. OEM Console->Preferences->Preferred Credentials.
2. For my host I enter normalusername, normal password, privileged username, privileged password.
3. Then I click on test

I get the following error "ERROR:Connection to TD3OEDB01A as user oracle failed."

I can connect to TD3OEDB01A as oracle user and root user. I am entering correct passwords.


Even when I try to set Preferred Credentials to the same server where my OEM and Repository DB is running (same machine) - it does not work.

There emoms.trc file contents looks like this:

2011-10-24 11:14:42,047 [EMUI_11_14_42_/console/pref/setCredentials$targetType=host] ERROR creds.SetPrefCreds testCreds.1690 - SetPrefCreds.testCreds(): CredsException: All values must be specified for each set of credentials.

2011-10-24 11:23:59,350 [EMUI_11_23_59_/console/pref/setCredentials$targetType=host] ERROR creds.SetPrefCreds saveCreds.1490 - SetPrefCreds.saveCreds(): CredsException: Some credential changes were successfully applied. However, one or more credential sets were not saved for the following targets, due to either missing credential values or not clearing all credential values when attempting to delete credentials: TD3OEDB01A

2011-10-24 11:24:52,929 [EMUI_11_24_52_/console/pref/setCredentials$targetType=host] ERROR creds.SetPrefCreds testCreds.1690 - SetPrefCreds.testCreds(): CredsException: Connection to TD3OEDB01A as user oracle failed.

Is there anything wrong in my approach?

Re: How to set Preferred Credentials for Host in OEM 11g [message #530701 is a reply to message #528349] Wed, 09 November 2011 18:39 Go to previous messageGo to next message
caprikar
Messages: 222
Registered: March 2007
Senior Member
You will have to run the root.sh on the agent host, permissions for some of the files are not set right. Once you run root.sh as root user, you should be able to set the preferred credentials
Re: How to set Preferred Credentials for Host in OEM 11g [message #531720 is a reply to message #528349] Thu, 17 November 2011 07:54 Go to previous message
daverich
Messages: 23
Registered: January 2010
Location: UK
Junior Member
Thanks a lot. I did not see your answer before.... but now I have and just tested. And it seems to be working. I have tested to a single node database. I'll have to test on a 2 node RAC too. But anyway it should be same
Previous Topic: Unable to apply Monitoring Template on Database Instance
Next Topic: OEM agent issue
Goto Forum:
  


Current Time: Sat Aug 30 23:32:01 CDT 2014

Total time taken to generate the page: 0.09103 seconds