Home » RDBMS Server » Backup & Recovery » Missing some tables after recover to a new host (11gR2, window server 2003)
Missing some tables after recover to a new host [message #527775] Thu, 20 October 2011 02:43 Go to next message
diekitkit
Messages: 3
Registered: October 2011
Junior Member
My scenario is use RMAN to restore and recover database to a new host.
The structure of two hosts are same.

In Host A:
1. Take a full backup.
2. Import a schema which has 191 tables in order to generate archivelogs.


In Host B:
I put all the folders(backupset, autobackup, archivelog) to the same directory. But after recovered the database, i checked that schema just has 175 tables, the latest few tables are missing.

I really have no idea about this, can anyone help me?
Re: Missing some tables after recover to a new host [message #527779 is a reply to message #527775] Thu, 20 October 2011 02:51 Go to previous messageGo to next message
Michel Cadot
Messages: 59136
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Once you restored, you have to recover till after the latest tables creation.
This needs:
1/ your database is on archivelog mode
2/ you have all archived logs since the backup

Regards
Michel
Re: Missing some tables after recover to a new host [message #527782 is a reply to message #527779] Thu, 20 October 2011 02:59 Go to previous messageGo to next message
diekitkit
Messages: 3
Registered: October 2011
Junior Member
My database is archivelog mode
i have copy all the archivelog to host B
my script is:
run{
set until sequence 34;(the laterest sequence of archivelog)
restore database;
recovey database;
}

but after that i check that schema has the latest few tables missing.
Re: Missing some tables after recover to a new host [message #527789 is a reply to message #527782] Thu, 20 October 2011 03:25 Go to previous messageGo to next message
Michel Cadot
Messages: 59136
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Because I think you use the control that was in the backup and not the current control file of your database.

Regards
Michel
Re: Missing some tables after recover to a new host [message #527791 is a reply to message #527789] Thu, 20 October 2011 03:31 Go to previous messageGo to next message
diekitkit
Messages: 3
Registered: October 2011
Junior Member
yes , i use the backup one
Because i suppose i can only use the backupset, all the latest archivelog to recover at the new host.
So any suggestion how can i fix the problem?
Re: Missing some tables after recover to a new host [message #527798 is a reply to message #527791] Thu, 20 October 2011 04:14 Go to previous message
Michel Cadot
Messages: 59136
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Use the current control file and recover until a time after the latest table creation time.

Regards
Michel
Previous Topic: ORA-16004: backup database requires recovery
Next Topic: Oracle 8i Backup recovery to a New Installation
Goto Forum:
  


Current Time: Thu Sep 18 18:49:40 CDT 2014

Total time taken to generate the page: 0.09626 seconds